Losing connectivity mid ride & resistance out of sequence

Hi, I am running zwift thru my apple tv and bluetooth to my wahoo kickr.
(apple tv, kickr, companion app all within a couple of metres of each other.)

Intermittently over past month on toooo many occassions, i lose connectivity and come to a stop.
I go into pairing and re connects, but this will happen time and time again! - what can i do to resolve this??
And when I can get it all working, i am intermittently getting resistance out of sequence, ie: free spinning / 90 rpm like i’m doing 80km downhill, yet on screen I’m trying to ride up a 14 degree gradient, vice versa downhill on screen but can barely rotate the pedal (as it thinks i’m climbing something real steep)


I’ve switched everything off, closed apps, etc rebooted routers, modems, - not sure what to do !!

Same problems I’m experience over last month with my equipment, which is in the same setup (Apple TV, Wahoo kickr, Companion app) as your Gavin.

How far away is the trainer from the Apple TV? Could be poor BT reception, or other devices on the 2.4 GHz spectrum (even microwave ovens) interfering.

I disable 2.4 GHz Wifi at home. Otherwise is the trainer is in direct sight, no more than 3-4m away form Kicker. From dec. 2020 unitil begining of March 2021 I didn’t have any problems with devices. I didn’t move it or change it - they are at the the same spot from beginig of my training. Can figure out what is the problem. I try today on my iMac and the are also problems, but the the connection don’t “drop”, but it has 25sek delay. No way to train like that. :slight_smile:

And I have updated Apple TV, Zwift app, Companion app and Kicker core to latest update/firmware.

Yep its driving me crazy, I have the latest firmware on my kickr, zwift suggested doing a calibration, but wahoo kickr says calibration happens continually automatically. Just tried another ride and everything is still broke - free spinning up 16 degree gradient, and barely rotate on downhill :frowning:

My apple tv is sitting ontop of my projector, whilst my kickr is sitting 2 metres underneath the projector

same same here, i wonder if the kickr firmware update is to blame…

Today same story - Apple TV, Wahoo Kickr, Zwift workout → no go. When I startet the workout it already has a delay of 15 sek. But I see that if I’m not in a workout, that kickr works fine. Or it was just my lucky day…

Copy that
I was thinking should i try sufferfest or something else to help determine if its a kickr or Zwift issue…

I have the same problem on the same setup.
It worked fine until March (probably a update on one of the devices/ apps).

The delay are now at 1 min +.

Just tried to resetting everything but still the same problem.

Did anyone find a solution?

Hopefully the direct connect from Wahoo will support ATV soon, and solve the problems.

I fact I did. I disconnect bluetooth on my iPhone and find out that my Airpods are causing problems. So I think that if you don’t have any device on bluetooth near Apple TV and Kicker you should be fine. Wifi I didn’t find problematic. Also have both devices as close as possible.
Resetting devices doesn’t help.

I also bought Kicker direct connect, but currently is not supported on Zwift. Hope that will solve all problems with connections to Zwift.

Still not working…
I’ll probably just have to wait for the DC to support ATV.