Long messages crashing Zwift on Windows 10 (repeatable)

I’d heard some others getting the issue before, but today was the first time I experienced Zwift crashing as the result of trying to type long messages when trying to manage a group ride where we had no beacon and it crashed twice on me (I was able to late join after the first crash but the second happened too late).

I’ve tried doing a little detective work in order to try and create a repeatable situation that Zwift can investigate because a lot of the previous reports (understandably so) were like mine just in the middle of a ride and it is hard to pin point/recreate the exact circumstances.

I’ve been able to repeatably crash Zwift 20+ times in the last couple hours by typing long messages, settling on the following procedure.

  • Starting Zwift
  • Joining free ride (upon joining I immediately disconnected my internet to avoid spamming the public chat with junk, but it has also happened whilst online so I don’t believe this should make a difference).
  • Pressing “M” for message
    -Repeatedly running my finger across the top line of my keyboard, pressing the keys: “1234567890-=” and then followed by [BACKSPACE] until the chat box is full. Therefore the typed message appears as “1234567890-1234567890-123…1234567”
    -Press [Enter] to send the message.
    -Repeat the process to send the same message again.

My observations so far:
It never crashes on the first long message.
I’ve regularly made it crash whilst typing the second long message, but not always. Hard to tell if this is because it doesn’t always happen at the same point or I’m not being perfectly consistent. For instance one time my cursor wasn’t in the chat box and so I ended up repeatedly changing camera view.
I believe the use of BACKSPACE is important. Earlier in testing I had tried just several long single character strings without issue.
On occasions where I’ve managed 6 or 7 long messages without crashing I’ve ended the ride and returned to the main screen and selected a different world. Upon pressing the “Ride” button at the bottom Zwift has crashed without fail.

I’d be interested if anyone else can spare the time to try this a couple of times and see if they get similar results/notice anything different.

I confirm - I confirm that I have repeated this on multiple instances of MacOS and Win10 ZwiftApp installations.

“It is not my computer.”

As one who loathes typos, I frequently find myself using the backspace key. However, so long as this bug exists… as does the need for leeway on my poor usage of the speech to text on the Companion application using my iPhone.

PLEASE. Please. Fix this!!!

…as of the update received on 22 June 2021, I have successfully used the keyboard without crashing however without clarity in the release notes about this issue (despite great release notes), I do not know if this was fixed.

I have the same problem for a while (last time it happened just few hours ago twice). After second crash i stoped writing and did 60km with no issue. I think it has something to do with messaging. I did contact support and waiting for response.

It is quite anoying because you can not help on the group ride (sweeping or leading) if ypu can not text.

I had this happen 24 minutes into leading a Pride On ride last week - on the latest build, 1.0.72785

Type type type type (no backspace) and BOOOM!


Companion is an awful chat experience comparatively. It really detracts from the game.

Windows 10 X64, all current patches - 4K Ultra on 1660Ti. Runs flawless except for that messaging issue. Happens on my loaded to top Mac Mini (except Integrated Graphics, because… Mac Mini); I do not think it has any correlation to “system”, it happens to the chattiest among us.

1 Like