Login issues uk

Can’t login on computer today 6th April 2021
Anyone else with the same issues.
Getting very frustrated with Zwift lately

It look like everything is up and running. Currently 14,244 people riding.

https://status.zwift.com/

1 Like

Yes. I had the same issue this morning. So I reset password on companion Zwift app, turned power off. Waited 15 minutes. No luck.

I’ve email Zwift support. Hoping it’s a easy solution.

Totally feel your frustration!!

Eric Min is currently Zwifting, I’m pretty sure he lives in the UK.

Perhaps try powering off your router/modem and see if that helps?

1 Like

I have powered off everything and reset and deleted and restarted and still not working. Husband tried his, same issue. Hailstorm outside so have turned to ironing :woman_facepalming:t2:

Oh man that’s not right. Frustration
I submitted a help ticket to Zwift
Have not heard back from them yet

1 Like

Fine here. Might be worth mentioning your ISP (I’m with Zen).

I went to change user, existing customer, entered my email address & password. Wa-la it worked. Good luck

I checked mine again last night before going to bed and it was working again.

Also unable to login from 07:55 UK time and still not able to login. Is the maintenance still ongoing?

Same problems here in the UK (Virgin Media). Can’t log on using my Android Zwift app or on my PC. Trying reinstalling both apps, rebooting router and changing wifi channels. No luck. I’ve been trying since 08:00 UK time (1.5 hours ago).

On my PC I just get the “logged in but no roads to ride” message. On my phone the little loading wheel just keeps going round.

Just tested and still fine for me.

A bit more experimenting and I seem to be able to connect from my phone via 4G (Three), but still not via my Virgin wifi. But it only seems to be Zwift that’s experiencing problems via my Virgin connection - all other internet services are working fine.

Awesome news. What a relief.

FWIW, I have Virgin internet and my Zwift connects fine. Sorry if this doesn’t help much.

Out again this morning
FFS - Getting really annoyed with it now.

I do sympathise. FWIW, I’ve been Zwifting fine this morning in the UK on Virgin Media.