Locked in full screen mode


(Scott Ripperda) #1

Hello all,

I was having issues with disabling full-screen . I currently use a laptop connected to a TV that only displays when in windowed mode, however, if I accidentally click into Full-screen mode, it is really unintuitive to go back into windowed mode. Left clicking would not allow me to change it to windowed mode. 

My sort of solution: Clicking with the left mouse key several times  then then a right click. I am not sure which worked (probably a right click), but one of these switched it over. If any other users are having this issue, this might be helpful to them.

 

Other solutions I tried that partially or did not work: 

  1. Deleting my Documents/Zwift/prefs.xml file (https://support.zwift.com/hc/en-us/community/posts/204820099-Settings-Menu). This was somewhat successful as it worked for one computer, but not another one. My preferences seemed saved even though I deleted the above folder. 

  2. Using the f11 function, Caps lock, or Alt+Ctrl+Del keys which other users suggested did not work. (https://support.zwift.com/hc/en-us/community/posts/205570556-Exit-full-screen-)

  3. I also uninstalled and reinstalled Zwift. This also did not fix the issue. 


(Tyler Shannon) #2

Hi Scott, 

There is a ‘windowed’ or ‘full screen’ option in the settings menu, did you use that? 


(Rick Dowell ZHR (G)) #3

Same problem. I am currently stuck in full screen. It was stuck once before and I tried all the above. Left Click, Right click, reinstall, nothing. Same experience as above after many tries it eventually just worked. Stuck for now though.


(Scott Ripperda) #4

Hello Richard, 

 

It is reassuring that I am not the only one having this issue, but I am sorry that you are also in the same boat as me Richard. 

 

Hopefully we can get this cleared up so we can feel safe in the settings menu and get you out of Full screen mode if you are still stuck there. 

 


(Scott Ripperda) #5

Hello Tyler,

 

Sorry for the late response, I had a crazy work week, but yes I tried using the ‘windowed’ or ‘full screen’ option in the settings menu. The issue is that it seems to get stuck in ‘full screen’ mode after clicking on it. After doing so, Zwift will require a restart. But after you get in full screen mode, you simply cannot exit out of it using the settings menu until based on Richard’s response and my experience it seems to just randomly work. 

I would try to reproduce the results but I am worried it would get stuck again. It took me probably about 3-4 hours to get it back to “windowed mode”. 

 

As for the technical side: The “full screen lock” occurred on 2 different computers both using windows 10 with more details below:

  1. On the first computer, deleting the my Documents/Zwift/prefs.xml file worked. So I was not successful in switching to windows mode after switching into full screen mode using the Settings menu despite several attempts and several Zwift restarts on this computer. 

  2. On the second computer, the settings menu would allow me to click on the windowed mode. It would make a sound, but the orange dot would not move over and Zwift would not switch into full screen mode. I attempted this several times while restarting Zwift several times over a 3-4 hour period while also attempting all the attempted solutions in my first post which did not work. After going through all the above, and restarting Zwift several more times to try and figure out what was going on it seemed to ‘magically’ or ‘randomly’ work through the settings menu after one of these Zwift restarts.   


(Rick Dowell ZHR (G)) #6

Solution:

Shift + Windows Key + Arrow key to move Zwift over to the extended monitor in full screen mode. Seems to be a bug in the Windowed/Full screen toggle however. Still stuck in full screen but as long as I have access to the desktop on the default monitor with Zwift running in full screen on the bike monitor I am good. 

 


(Steve Schroer The Slow One) #7

I went into this. File on my computer Documents/Zwift/prefs.xml, opened with wordpad or notepad and found the line that had full screen and deleted that line. Then went back into zwift and it worked and I was able to select windowed again


(Jonas Bergrahm) #8

I did run into the same issue. I resolved it on my PC (Windows 10) by editing my Documents/Zwift/prefs.xml file and changed the FULLSCREEN field from “1” to “0” according to the following: 

<CONFIG>
        <SHOWGROUPMSGS>1</SHOWGROUPMSGS>
        <FULLSCREEN>0</FULLSCREEN>


(Russell Tanton) #9

Jonas, thanks for your tip. It worked on my Windows 7 machine…it was driving me crazy.

 


(Ryan Devlin SCCC) #10

Thanks Steve and Jonas. Man that’s a horrible solution. Zwift is purely a software company so how are bugs/faults like this still a thing? Also, no option to scroll in menus, wtf