Latest Mac Update Sierra and Zwift


(Ed Howard SZR D) #1

Hi

Just updated a brand new Macbook with Sierra. I use Wahoo Kickr. The Kickr no longer reads the gradient in Zwift. Furthermore Zwift responds very slowly when clicking on menu or ride etc.

Any ideas?

Ed 


(Jerry Bob) #2

having similar issue after downloading Mac OS Sierra version 10.12. I can log in but then when logged in successfully and I press ‘‘go’’ to launch game post logging in there is no response on either ‘‘go’’ or ‘‘skip’’ or ‘‘menu’’ 


(Ed Howard SZR D) #3

I now use the mobile link as when i connect using the MacBook’s built in bluetooth my Kickr no longer reacts to gradient changes in Zwift.


(Jerry Bob) #4

I switched to Ant+ and this seemed to work. Bluetooth and Zwift don’t work as well as they should as I’ve had a lot of problems with zwift and Bluetooth whereas zero problems with Bluetooth on other apps/programs (i.e. fulgaz kino map virtual trainer ). I’ve also never had anything solved sending log files etc etc. Try Ant+ as this protocol seems much more robust and stable with zwift.


(Jon Shippam) #5

Zwift support asked me to send my logs but nothing came of it. I’m receiving an ant+ dongle tomorrow at the suggestion of Wahoo support - they told me Zwift Bluetooth support I was unreliable. 


(Niclas Sjögren) #6

I’m having the same problems with my Macbook air OS Sierra as you do Ed Howard. Same resistance (or whatever it is called, I don’t know that much English) all the time. Going uphill or downhill is all the same. So I tried Zwift on my wifes Macbook/Os X Yosemite and it worked fine.


(Bing Quezon (Agila Cycling)) #7

i have the same issue.  After updating to Sierra, my Cycleops Powerbeam Pro (Bluetooth) stopped reacting to gradient changes.  Any updates on when this will be resolved?


(Niclas Sjögren) #8

The weird thing is that I tried Zwift on my wifes Mac after failing with my Mac. (her is a Macbook pro, about a year old). And it worked perfect. Both before on Yosemite (worked with gradients) and after she upgraded to OS Sierra (worked with gradients). But still my Macbook/Sierra won’t play with Zwift (gradients doesn’t work, but it all pairs and I get speed and cadence and watt). And I have tried everything. Really everything.

 


(Jerry Bob) #9

There are a lot of folks having this problem. Today connecting with ANT+ caused the same issue when it had been working fine. Pretty frustrating for sure.


(Steven Belen) #10

Hi,

 

I had the same issue but i think i found a solution, but i cannot prove anymore this has anything to do with the update to Sierra.

After i do a Zwift workout the ‘trainer difficulty’ setting gets set on ‘off’ even i do a normal Zwift ride.

For me it is solved to check this setting every time i want to do a normal Zwift ride after a workout ride.

I did not have this issue before upgrading to Sierra.

I’m using a Wahoo Kickr 2016 on MacOS Sierra.


(Niclas Sjögren) #11

Hi all, I found the solution for me. And now you’ll have to excuse me for my poor English.

When I pair my Wahoo Kickr 2016 with my Macbook / OS Sierra, Zwift automatically choose a faulty copy from the three ”copies” that are found under the ”Controllable trainer” icon. When I discovered this, and chose the “right” copy (identical to the power source-icon) to “Controllable trainer” the problem was solved. I have also noticed that the Zwift app sometimes choose Bluetooth, though I use the ANT+.

Sorry if this sounds confusion. It was confusing even in Swedish.

:slight_smile:


(Alan Posner) #12

New Macbook Pro with Sierra.  My problem: laptop ran out of battery in 30 minutes.  Anyone else having battery issues with Zwift?


(Oliver Lang (ZRG)) #13

I also the have the problems with Zwift and OS Sierra. Yesterday i tried some workouts but my trainer (Bkool Pro) didn’t reacts of gradients or downhills. I used the ANT+ connection. Before the update everything was fine. Are there any hints? Thanks Oli


(Kelvin Ong ZF/ODZ) #14

I’m also having Mac OS Sierra issues with my Taxc Neo.  Watts and rpm keeps fluctuating between 0 to 60 etc, and my rider keeps going to rest by the road.

Frustrated, i switch to other platforms. They all worked without drops:

Windows laptop (proves the Ant+ BLE works fine), Iphone 6s, and Ipad Mini2

 

I will try again later with Niclas’ solution