Late join not working consistently [June 2022]

first try was just a little late, so I should pedal up 35s behind a blob. haha
tried, quit, rejoin, getting the pedal support and thrown out.
same setup for me, ATV

Late join (4 mins late) didn’t work on my group ride today. Pedaled from the start line I. The group ride, wearing the jersey, saw the leads’ messages, but couldn’t catch up to the group.

Had to leave the ride, join a solo ride, click on Join Event to rejoin the above group ride and it finally joined me up with the lead and other riders and had the pedal assist countdown going.

I was unable to Late Join the “SZR Groupworkouts by Aktivitus” workout at 7am UTC today.

I signed up for the event several days earlier and checked the previous day that the event was on the list of upcoming events.

I missed the start time by a couple of minutes, but the event did not show in my list of events in the companion app or in the main app (including the full list of events page). I tried restarting the app but it did not make any difference.

I then started a ride to see if I would get the Join Event prompt. I waited several minutes but nothing came up.

I have experienced this issue multiple times since the fall of 2022 where I “Late Join” and it successfully joins – however, at the first major route turn the pack goes one way and I go another way. The world-route does not seem to matter as I have had this happen in Richmond, Makuri, and other.

I had it happen as lately as of 20-Feb-2023 on:

Zwift - Group Ride: Giant Monday Motivation Ride Series (C) on Suki’s Playground in Makuri Islands]

Using Apple TV with the latest version of Zwift.

Perhaps a senior software engineer needs to review the “Late Join” code from top to bottom as it seems to have numerous issues.

This is still an issue that is occurring regularly. See my latest post.

Still seeing a lots of misrouting for late joiners, this bug is definitely not fixed.

I had it happen to me yesterday, joined 3 minutes late and the group was nowhere to be seen, could chat with them for the whole hour, but not actually ride with them

I just updated to the latest version today and proceeded to try to join the Tour of Watopia Stage 2. I was 2 minutes late and it put me in the pen as per usual but the said “finding “rider…” (singular). Then it transported me to the Jungle, miles ahead of where the ride would have been at that point. Then it quit the ride.

I restarted Zwift and tried again. Same thing happened.

Then I restarted my computer, logged back in, and the same thing happened a third time.

Then I signed up for the 2pm ride, but I keep getting “your ride is about to start” alerts for the 1pm ride, which started about a half hour ago

M1 MacBook Pro 13". OSX Ventura 13.2.1. Zwift App vers. 1.1.1