Large Power (& W/kg) Fluctuations


(Joshua Coe ZTR (D)) #1

I’ve got the kinetic road machine along with garmins newer speed/cadence sensors for my set up.
I’m noticing that the power output has large swings while at a steady cadence regardless of flats or inclines. This is getting progressively more annoying with each ride as I can’t get a good read on my power output for a given course section. For example, today I did a group event that focused on a 3 W/kg pace, while riding at a steady pace my W/kg would swing from 0.7 to 3.8 W/kg. This much of a swing makes it impossible for me to set a specific pace.

Are there settings I can change to eliminate (or at least significantly reduce) these huge swings in power??


(Jason K) #2

Power spikes usually happen because your signal is dropping, which we can’t prevent through the software, so the best thing to do is try and stabilize your signal.

Since you’re connecting over ANT+, your ANT+ signal could be dropping. See our troubleshooting steps for some tips.


(Eric C. (Zwift HQ)) #3

Hi Joshua,

You can turn on 3-second smoothing. That may help. Additionally, make sure your ANT+ dongle is close to your sensors. Interference or a bad connection can cause irregularities.

Additionally, since it’s a newer Garmin speed sensor (and doesn’t have a magnate), just make sure the battery is properly seated.


(Joshua Coe ZTR (D)) #4

Jason though I’ve got the dongle under the bike and sensors have new batteries, I’ll take a look at interference sources per the troubleshooting page and report back. I have a strong feeling my 18" dayton fan is causing a charge build up on my mat a a possible contributor. More info to follow…


(Eric C. (Zwift HQ)) #5

Thanks Joshua. Let me know how it runs minus the fan (or, perhaps, with the fan moved somewhere else).

Worse comes to worse we’ll open a ticket and look at those log files.


(Joshua Coe ZTR (D)) #6

Will do Eric! Perhaps a faraday cage is in order ;)-


(Joshua Coe ZTR (D)) #7

Keeping all other variables constant I made one change, I switched from zpower to classic power in the program settings. This almost eliminated the power fluctuations completely though the overall power is a bit lower than before. I’m only seeing ~10 W (or 0.2 W/kg) power swings whereas before I was getting 50-80 Watt swings.

If I was indeed experiencing signal dropout then why am I getting a steady (but lower) power output with this one setting change??


(Joshua Coe ZTR (D)) #8

I turned off everything in the house that was bluetooth or wifi except for the modem/router and turned off the fan. My router, which is a newer 2.4/5GHz dual router, was currently on channel 11 so I went ahead and changed that to channel 3. Everything else within the program (zpower, 3 sec smoothing, etc.) is the same and my sensors/dongle are positioned the same (all within 18" of each other).

With all that said, I am still experiencing large swings in power. Super frustrated, don’t know what else to try. Please advise.


(Eric C. (Zwift HQ)) #9

Well, zPower takes in to account acceleration for the fluid in your trainer. Do you happen to have the larger flywheel attached at all?


(Joshua Coe ZTR (D)) #10

Eric, you comment regarding zpower is confusing. I am pedaling at a steady state (not accelerating) for an extended period on 0% grade and during that same period I am experiencing the large power swings. No I do not have a larger than stock flywheel attached.


(F.Jijo Kizum) #11

hi,Joshua !

I am having the same problem as you. I also tried various things, but it has not been settled. The only thing that I have learned is that the phenomenon that power jumps up to more than 300 w instantaneously is occurring. And this phenomenon started about 1 week ago. Before that it worked normally and I did not change the settings.

I am also a super frustration phenomenon like you too.
Please help someone!