Kurt Kinetic Trainer receiving 'No Signal' when pairing with Android Zwift Companion

trainer
cant-pair

(Kris Clover (D)🤮) #43

Same story here. Screen mirroring works but I want it to connect natively on the ATV. I also tried all Bluetooth devices off in the vecinity just to be sure there was no interference with the trainer connection to the Apple TV. Didn’t help. I spoke with someone at Kenetic, he recommended I try another app just to troubleshoot. I installed FullGaz and it also had connection issues. It has to be a BT connection issue between the trainer and the ATV. Wondering if Apple changed the BT protocol in the latest update they pushed (12.1). Interestingly my Wahoo heart rate monitor and cadence sensor connect to the ATV just fine. (FYI I know the ATV can only connect to 2 BT devices at a time so that’s not the issue. I don’t connect the cadence sensor when I use the trainer).

Regarding membership vs trial account, I don’t think that’s the issue. My kids also use (at least want to use) the trainer so we have two freshly paid and one trial accounts (family plan, please! I noticed FullGaz has it… wink. wink). I tried all accounts and they had the same no signal results. At a loss here until somebody changes some code. Oh I did leave another message for the Kenetic team on Monday but I haven’t heard back yet. I’ll let you all know what I here.


(Steve Bestul) #44

Maybe to better answer your question, I did run both at the same time once, the one on the iphone worked but on the Apple TV did not, it showed me in the game, but I was just stationary.


(Aaron Zwanzig) #45

I’ve been having a similar issue where, after pairing a sensor to the Android Companion app while using Zwift on Apple TV, the paired sensor would immediately report “No Signal.” I finally made a breakthrough with my setup to get consistent pairings to the companion app. I don’t know how well it might apply to the Kurt Kinetic issue, but it might be worth taking a look. I wrote up my process here:


(Vincent W.) #46

Thanks for the heads up Aaron! Quite an extensive tutorial, I’ll forward this over to the teams that are working on the issue.

@Steve_Bestul were you running the Companion app on your iPhone while running Zwift the Game on Apple TV? Not sure if I read that answer right.


(Steve Bestul) #47

When mirroring you can’t have the Zwift app running on the Apple TV. You only want the companion app running on your iphone and the trainer paired to that. Like this: KINETIC>>BLE>>IPHONE>>Screen Mirroring>>AppleTV. I hope that makes sense. I did a short ride tonight, and had only a couple of momentary screen freeze ups. As an added bonus, the Zwift game fits my TV screen better with this set up, then when it was running natively on Apple TV(it would trim the right side enough where you couldn’t see the grade).


(Matthew Rockwell TT1 (D)) #48

This fix worked for me. I discovered that part of my issue was that I have 2 kinetic smart control units and both were paired to my iPad. When I was riding using my PC and an android companion app my trainer would drop connection with the android and form a connection with the iPad. I had to “forget” my trainer on the iPad to get it to work.


(Kris Clover (D)🤮) #49

Apple TV Issue SOLVED! I called Apple tech support today and they got me all fixed up (love those guys!) You must completely reset the Apple TV to get the trainer to reconnect. Once you do that it’s as good as new. Apparently something got hung up with the trainer when the TVOS 12.1 update was installed automatically. The hardest part is just re-logging into all my apps. Super happy this is fixed!

Now Zwift team, if we could just have family plan pricing that be amazing! Cheers!


(Bucky Marks) #50

It seems the issue that is consistent across all versions of this bug, is that we are trying to connect to a “combined speed/cadence” sensor. (Just my 2 cents.)


(Bucky Marks) #51

Workaround works for me. Using an old Kurt Kinetic fluid trainer and Bontrager Duotrap speed/cadence BLE over Zwift companion app.


(Lamar Carter) #52

iOS 12.1, Apple 4KTV, Kinetic Rock and Roll Control The reset did not work for me. After a mile, the connection seems to be lost, yet if I go to the setting to see the Bluetooth sensors, it’s connected. Patiently waiting for a fix.


(Kris Clover (D)🤮) #53

Yeah unfortunately I only made it about a mile and half today before it died. I also tried it on a 4th gen AppleTV running 12.1 and it also does not work. I’m going to call Kinetic tomorrow for an update. I’ll keep you all posted.


(Pat Johnson) #54

I got an email from Steve at Kinetic. He said there was nothing they could do, since it is a Zwift interface problem.


(Kris Clover (D)🤮) #55

The AppleTV issue is not only with Zwift. I also had problems with Full Gaz.


(Nicolas Pierson) #56

@Vincent : can we have an anwer please ? One month with this problem !


(Lamar Carter) #57

I had the same issue Kris.


(Russ Gilbert) #58

I’m having the same No Signal issue. I have a new KK T-6400 Road Machine Control with firmware version 1.3 and ATV 4K with latest updates.

Just renewed my ZWIFT subscription. No sense keeping it active until the issue is resolved!.

Russ


(Steve Bestul) #59

Had the very same problem, with the exact same trainer and Apple TV 4K. As suggested by Kris, if you didn’t see that post, Kris called Apple tech support for this issue. You must do a complete reset of your Apple TV. Go to: SETTINGS > SYSTEM > RESET. It also asked to download latest update during this process, I accepted that and completely reset the Apple TV. It takes quite a while, and you have to log in all of your information along with your Apple ID again. This seems to clear the issue when the latest Apple auto update pushed to your Apple TV. That fix worked for at least 2 of us, hopefully it solves your issue as well.

Steve


(Russ Gilbert) #60

That fix worked perfectly. Last year my trainer was the KK Fluid Road Machine with the single smart sensor(no resistance). I also have Wahoo cadence and speed sensors and I used the Zwift Companion app on my Android phone.

This newest KK Road Machine Control (T-6400) trainer is sweet. I love the resistance change. Though I now pedal at a much higher gear ratio with the controlled resistance.

I did need to unpair one of my Wahoo (Cadence) sensors to allow room for the KK controllable trainer to connect and found I still needed the Wahoo speed sensor paired with the ATV to get the bike to move.

I’ll give a try to using the Zwift Companion app via my Android to the ATV to see if I can use all three sensors.

Russ


(Steve Bestul) #61

Vincent at Zwift had me try another fix to get the KK trainer to work, before the ATV reset solution. My KK (T-6400) picks up all three sensors just fine, what you may have is a conflict with some of your other devices. So you may want to try this: unplug all your training devices, including the Apple TV, also turn off the bluetooth on your phone (there is another known issue with the Android companion app). Now plug in only the KK trainer and the Apple TV, restart Zwift and see if that works. To recalibrate, you can turn off Zwift (you might be able to just turn off the 3 paired sensors on Zwift) then open up the KK trainer app to recalibrate (I find that after recalibration the gear ratio/resistance on my KK changes some). Now close the app, disconnect the bluetooth on your phone, and restart Zwift.

Steve


(Russ Gilbert) #62

Thanks Steve,
I did what you listed and all is well. Here’s a screenshot of my ZWIFT pairing.

Russ