Kurt Kinetic Smart Control Calibration Off - Resistance too Low

Anybody else notice that Zwift overstates the power output when using the Kurt Kinetic Smart Control. Additionally, the resistance is way too easy when going up hills. Any others experience this? I’m running am Android phone and Windows 10 PC.

Hi David,

Please have a look at this post:

https://support.zwift.com/hc/en-us/community/posts/205858683-Zwift-Power-and-Kurt-Kinetic-EXTREMELY-low

Maybe this will help you?

Hello Bastiaan.

That article is not helpful. 

There is a difference between the Kurt “Smart” trainer (the one in the article you reference) and the very recently released Kurt “Smart Control”. I own both.

I do not have a issue with the power level from the “Smart” (In-Ride) setup at all.

My issue is with Kurt “Smart Control”. When heading up a 10% grade, as I often do where I live, the effort required in Zwift is very very easy. I even remain on the big ring up front which I can’t come close to in reality. With the Smart Control, Zwift is setting the resistance. Something is very very wrong with the calibration numbers that Zwift is using. 

Additionally, my average output on the rides with the “Smart” unit are about 170 watts in Zwift, while my average output on the rides with the “Smart Control” are about 230 watts. NOT EVEN CLOSE to realistic,  and too large a percentage increase to not indicate a serious miscalculation when controlling the “Smart Control” unit.

I do not have any issue when using the “Smart Control” with the Kurt software app. The effort required for a given wattage when running in ERG mode is realistic.

There MUST be an issue with either the data Kurt provided to Zwift for the software interface OR with the implementation on the Zwift side of this interface.

Thank you.

David 

 

Hi David,

Thank you for the extensive information. I did a search for you on Google/Youtube but didn’t find anything useful.

I think you should raise a support ticket at Zwift and Kinetic:

https://support.zwift.com/hc/en-us/requests/new

https://support.kurtkinetic.com/hc/en-us/requests/new

Good luck.

 

I have a Smart Control as well.  The issue you are experiencing isn’t related to Zwift as far as I can tell.  I am told that their developers are updating the calibration routine for the Smart Control.  You can get the “Kinetic Calibrate” app for iOS or Android.  The current firmware revision I have is 1038 but the watts still read a bit high.  I don’t have any more insight on it at this time other than to say that their internal testing is positive and they plan to have the firmware updated for the rest of us.

Thank you Duane. Very nice to find out I’m not alone. If the Zwift mobile app requires running another app, I consider this an issue with the Zwift system. Additionally the system should be smart enough to identify and calibrate the mass produced hardware that it is being integrated with. Sounds like a fractured integration effort on the Zwift side if I am hearing you correctly. Even if the implementation requires another app, the software on the PC could at least issue a warning. A fully integrated plug and play experience is not an unreasonable expectation.

I very much appreciate your response.

David

Duane, I may have misread your use of “their developers”. Upon rereading, you may have mean the Kurt Kinetic developers. Let’s see how this plays out. Disappointing for a $900 investment. It should cook pancakes for me each morning for $900.

I received an email from Kurt Kinetic today that their Smart Control requires a firmware update to resolve this issue. It appears the interface issue resides on the Kurt Kinetic side of things. Anticipated release is one week.

Great David. Keep us posted about the new firmware and results.

Hi I got my Road machine smart control today,facing problem in two fronts one with Zwift & also with the fit app. Zwift doesn’t recognize the Kinivo BTD-400 Bluetooth 4.0 USB adapter as a result cannot connect the trainer & in the fit app it is connected but no speed,cadence or power is shown during workout.Any help regarding this Thank you.

1 Like

Yogesh,

It sounds like you are trying to use a BT adapter on a windows machine, but Zwift doesn’t support this.  If you have a smart phone you can use the Zwift Mobile Link application a bridge for Bluetooth communication.  I’ve done this and it works quite well.

Yogesh.

 

Congrats on the new Smart Control. I have one as well. You are now a Beta Tester for Kurt Kinetic and Zwift.

I created this thread to address a defect (now acknowledged by Kurt Kinetic to me) that when using the Smart Control in Zwift, well, it’s really not that smart. There are defects in the firmware in the Smart Control that need to be updated and pushed out to the user community. When you open the “Fit App”, it will let you know when new versions of firmware are available and at that time you push the update to your hardware.  Right now, when I use my “Smart Control” in Zwift, my power output is overstated by ~30%. They plan to release new firmware next week that will fix this.

The second issue you are experiencing the fact that the Fit App does not connect to the Smart Control is one that I experienced as well. Kurt Kinetic had one of their engineers (Stu thank you) walk me through how to get the Smart Control to pair properly with the Fit App. In rough terms, I unplugged the Smart Control, closed all apps on my phone, rebooted my phone, then turn on Bluetooth, plugged in the Smart Control, then opened the Fit App.  After following a “clean start-up”, I could connect with Kurt’s own Fit App. You will find other defects with the Kurt App. If you do one of their workouts, and the work out completes normally, it is not saved. OUCH. Kurt’s work around for now is to “complete/exit” the workout before it would normally end. Oddly enough, as it works, your workout will saved.

I’m using an Android Phone, Windows 10 PC, and Kurt Smart Control. It is important to understand that the Zwift Mobile App (on the phone or tablet)  is the point where your Blutooth  devices are connecting. The Mobile App relays the Blutooth information to the PC based Zwift application over the network they are both connected to. I believe this is what Duane Gran was emphasizing as well.

Welcome to the world of  performing integration testing for Kurt Kinetic. I encourage you to submit a ticket on the Kurt website. I suspected I would be doing beta testing for them. A bit disappointing after dropping almost a grand. From the consumer side, it seems like Kurt rushed the Smart Control to market to try and keep up with the competition who was blowing them away. Us early users have the treat of debugging their product for them. On the good side, they have outstanding support. Contact them.

Hopefully my comments are helpful.

David

 

 

Hi thanks Daune & David for the response,will go through the process decribed by you both.Thank you.

Got the trainer working fine on Zwift as well as the Fit app & Trainer road :slight_smile:

Yogesh, you may think the trainer is working in zwift, but your power output is way higher than you were actually producing . This is a known defect that is being worked by Kurt kinetic. My power output is overstated by at least 30% whenriding a Kurt kinetic smart control and zwift. It is like a toy More than a trainer.

Hey guys. Same problem here. Not so much with the power but the controllability of the trainer. Over the weekend it was working fine. Suddenly today it’s no longer controllable and just fixed at a light resistance. Looked for a firmware update but nothing yet.

I will say though…I got my Kinetic almost as soon it was released and at first it wouldn’t connect at all to Zwift. Updates were needed to both be game and mobile app. But responses from both Zwift and Kinetic were prompt.

I returned my Kurt Kinetic Smart Control. I was finding defects faster than they can fix them. I ordered a Snap. Seems like it is a bit more mature, but let’s find out.

I’m having similar issues with the new rock and roll smart control. Despite multiple calibration attempts and fight with noise and vibrations, the resistance is far too easy and power way to high. It seems that with consistent effort the power readingS get higher as time goes on, even after a 10 minute warm up. I did a FTP test yesterday and it came back with 617w, and I am no god of cyclist g here. It seems after this and coming to a stop and restarting the numbers were more accurate. I could get wattage readings below 100 where it was very difficult to get numbers below 180-200 before. Also tried reseating resistance unit and laying over mat on my hard surface, going to give another shot today

I’m also having that issue.  There is very little control of resistance  on zwift.  It was fine for the first 15 rides I did but I noticed that it was not changing resistance in the tunnel @ the 3% grade of zwift.   There is some additional but not correct resistance when climbing the mountain but it still noticeably low.  I understand that the power is overstated overall but this is an addition issue for sure.