KICKR v6 WiFi connection [October 2022] [SOLVED]

Fresh V6 picked up today. I’ve setup the wifi network within the Wahoo app and it looks good to go. I can see it as a device on my network map 192.168.1.xxx - the same subnet as everything else on my network, but it is not discoverable in Zwift.
Tried on PC, Android, AppleTV - no luck.
The wahoo support page unhelpfully combines the Wifi connectivity and “Direct Connect” on the same page and doesn’t really suggest there is anything else to do. I’ve enabled port 36866 just for fun.
Any ideas?

1 Like

So I gave it the night to settle. I left it plugged in and perhaps it got an update overnight.
I didn’t change any other network settings. It wasn’t working the first time I tried this morning. I unplugged it and left it for an hour or so while doing some jobs.
Second go, success! Shows up on AppleTV, Android and PC.
I have no idea what changed, but it’s now working. I’ve disabled the port access thing and the PC works fine as suspected.

Since wifi can’t be turned OFF on the V6, will the builtin wifi still be active and periodically broadcast for wifi network, even if it has a connection using Direct Connect/ant/BT? Or will it back-off when it has some sort of connectivity, or stop after X time?

Anyone who knows?
Thx

Had it happen twice now in the last 2 days where the wifi connection in zwift decides to drop entirely and doesn’t recover. Between yesterday and today after the 1st drop Zwift didn’t even see the Wifi power option. Unplugging and replugging in the Kickr got that back on this morning. But then today during a ride the drop happened again and did not recover.

Note that Kickr ANT+ connection still works smoothly on same setup. And I don’t see the same drops on head unit via ANT+.

Is this a known issue?

Haven’t seen any reports of it here (possibly too new for widespread adoption/use for now). If you are on a PC/MAC, you could drop your log file into Zwiftalizer.com to see if its picking up any packet issues.

1 Like

I have dropouts every half hour or so even though there doesn’t seem to be a corresponding disconnect if I look at my router’s info.

Wahoo blames Zwift, though I admit I’m not convinced. Zwift hasn’t gotten back to me about my ticket though.

At this time our developers are working with Zwift to try and help them resolve the connection issues they are seeing in the 1.29 version of Zwift.

At this time the only app having issues is Zwift. You can check with them for a timeline or return the unit if you prefer.

There have also been reports of similar on Reddit: https://www.reddit.com/r/wahoofitness/comments/xfygdj/kickr_v6_wifi_dropouts/

2 Likes

Am I looking at UDP packet drops for the trainer Wifi connection?

Same here.
I‘m using my Kickr V6 with Zwift 1.29.1 on both Apple TV (latest model, tvOS 16) and an iPad Pro (iPadOS 15.7) with a AVM Fritzbox and Mesh WiFi (which is otherwise rocksolid).
I‘ve now tried connecting via WiFi, Direct Connect (LAN) and Bluetooth and have experienced basically two kinds of issues with connection loss with all of them, most recognizable in ERG mode:
(1) After approx. 30 mins. complete loss of connection for a couple of seconds leaving ERG disabled (only restarting Zwift and manually (!) activating ERG for a workout in the selection screen can fix that) or
(2) randomly after (and then every) approx. 12-30 mins. with Zwift/Kickr being able to negotiate a new connection and/or possibility to re-activate ERG mode via Companion App.
Interestingly, I can recall one recent workout session in ERG mode of about 1h that went flawless using Direct Connect via LAN, so these issues don‘t seem to happen all the time.
I‘ve supplied .fit and Log Files to both Wahoo and Zwift. As others have described, Wahoo seems to see the issue with Zwift, while Zwift wasn‘t able to get back to me and comment yet.

I dont have a V6 but yes, it should be using UDP. And yes, UDP disconnects are not good. Dropped packets in a Zwift context are generally ok but not so with UDP disconnects.

It could be faulty Kickr or your PC/Mac but more than likely congested WiFi frequency (ie, too many device competing for that signal be that legit devices in your house, or even non-network device that also use that bit of frequency such Bluetooth anything, TV’s, microwaves, fans etc). Dropped packets in networks are a b**** to troubleshoot without the right tools and knowledge of networks but one thing you could do, apart from resetting your wifi router, is grab a wifi analyser app for your phone and check to see if you have wifi channels available less populated than your current, and change your wifi router accordingly.

1 Like

Hey all - reports keep trickling in on this issue, so I’m consolidating them into this thread. We are looking into this at Zwift HQ will update as we have news.

4 Likes

Scanning is initiated whenever a user opens the “Paired Devices” screen. If WiFi connection is lost, please try opening up the “Paired Devices” screen. In our tests, reconnection was instantaneous. We have planned work for more seamless automatic reconnection after WiFi disconnection.

Bought a V6 on release day and had 30sec dropouts on zwift on every ride. Even bought a Direct Connect adaptor but nope, same thing (so save your money if you’re thinking about it).

Tried the BT connection. Nope, still dropouts.

Eventually gave up and went back to my 2018 kickr so the V6 is just sat there gathering dust.

Coincidence that it is only this model that is affected and Zwift Hub came out at the same time?

Oh, and did I mention that wahoo are suing zwift? :joy:

Dircon connector disables wifi when plugged in

1 Like

Good it’s finally having so more visibility… This is ongoing for a month now, and it’s really sad and a shame that nothing is moving forward in such a long time!

Got the v6 a little over a week ago, connecting to Netgear Orbi mesh Wifi, router 5m away, first sattelite 8m away, rock solid wifi, first time on Zwift and losing connection right away. After few rides, I ordered a direct connect adapter with a cat 8 ethernet cable, connection loss exactly the same. Sadly I didn’t read anyone before that or I would have spared 150€ too!!! At least wahoo will have a really nice sale increase like this!

Got wahoo US support on the phone, did the standard steps and whatnot, using Bluetooth only lasted 51s before losing connection!
Back on wifi, losing connection twice per hour at least. Wired, identical.

Then 8 days ago per mail a marketing guy is telling me this is a known software issue and I need to wait for an update to fix it.

Aaaaaaaand that’s it. Just spend lot of money to wait for whenever it would be fixed so you can finally use what you bought. No idea if Zwift has to update something or wahoo. This is not specified.

Reached out to GPLama and DC Rainmaker, Shane answered he has no issues. Ray didn’t answer. Some users on Ray’s website commented they have issues too.

We definitely need to make this more visible as we need to be able to use the v6 as inteded in Zwift. People on Reddit are raising the issue but it’s still not visible enough…

1 Like

The first day, the WiFi connection as a power source didn’t even show up after it dropped so this wouldn’t have mattered. I had to restart the trainer for WiFi to show up as an option in the pairing screen.

In my experience, reconnection was not instantaneous so there’s something going on.

1 Like

While you are leading an event, or racing an event, you have no time to open the menu, and wait for whenever the thing would reconnect. Can be 1s or 30s. Which is what would happen also if you would not open the pairing menu. That’s not the solution of reconnecting, it should simply never disconnect…

1 Like

To pair the trainer the cable is prior to wifi yes. But wifi is still on, unless you delete the connection information in the app…

FWIW, it seems like the are 2 issues here. One with intermittent wifi drops and the other where all connections don’t work. For mine I just get the wifi drops. Paired via ANT+ is normal (just random/intermittent drops that occur which isn’t unusual). Have not tried BT.

1 Like

The only connection working is ant+ (and even, it seems it tries to drop because sometimes resistance goes really easy but comes back and no drops noticed).

In fact, we have wifi drops, linked to direct connect drops, and bluetooth drops.

If you are fine and not dropping with ant+ keep this way, don’t try bluettoth! :wink:

1 Like