Kickr Snap suddenly drastically different in power after calibration?

It’s a trainer specific tire. Some red thing. 100 psi and 23c.

The primary issue is that for nearly a year I’ve been “training” on this thing several days, sometimes 5+ days a week. Took me months to get above 300w FTP, then 320, then 348 was the best I ever did. It’s been consistent this entire time and I felt like I was moving in a linear way. It’s so aggravating to suddenly have that all upended. I don’t know what’s real but there’s no way my best possible sprint power is 600 watts for 3 seconds. That can’t be right.

Will try tightening it up.

Tried both types of spin downs. I just lowered my FTP manually to 200w and now I’m doing Emily’s Short Mix. Maybe this is just my new reality. It’s much less aggravating now that I hit my stars.

I feel your frustration! I went through the same thing while I was figuring how to work with the SNAP and get consistent power readings.

Just a side note… an FTP of 348 is pretty high. What is your cycling experience, and how big of a person are you?

Tire and pressure sound fine. Try cranking the tension knob until the spin-down time is under 15 seconds. It does make a difference.

I put a mark on the tension knob so I tighten it to the same position every time.

Only use the Wahoo App for calibration. I have never had good results performing a spin-down calibration from within Zwift.

3 Likes

A couple of other ideas…

  1. Do you know anybody with a power meter? Pedals would be easiest. Install those temporarily and see how well they agree with the SNAP.

  2. An “Advanced Spin-down” is still possible. Did Wahoo support have you perform one? If not, contact them again and ask how to do it.

I ride a lot. I weigh about 170. I dunno how strong I really am. I don’t race. I survived a 160 mile gravel ride with 10k climbing in January but it took me 14 hours because I bonked. I have a few cups and one not very impressive KOM in town (Tucson) on Strava. Strava always estimates my average power for a ride to be between 150 and 250 watts for a ride of around 50 miles or so. Shrug

You know, I just reset my FTP manually to 200 watts and was able to finish my workout without rage quitting because at least I was hitting my “stars”. Maybe I’ll just adjust to this new reality.

As you’ve discovered, consistency is key. I’m not sure what caused the big change in power readings.

Do try to get the spin-down time between 10-15 seconds. It has been noted that the SNAP reads power on the low side if spin-down times are too long.

Hi, did you get any further with this or just accept your new FTP?

I ask because I have exactly the same situation in reverse. My FTP is about 250 (has been between 230 and 270 for years) then last week my workout was way too easy. Did a spin down, did another spin down, did advanced spin down, nothing helps. I’ve not set my FTP to 400 to get a decent workout and I know that’s not a realistic figure. Without wanting to sound too dramatic - it’s ruined my enjoyment of zwift.

No… Actually, I didn’t. I quit Zwift for a competitor. It don’t think it’s Zwift’s fault, necessarily. I blame it on my Wahoo Snap trainer, which is just really bad at simulating resistance and gravity and probably just isn’t very accurate. I’ve been doing workouts with the competitors program and it gives me much more control over the trainer’s tension. This other program calculated my FTP at 248. I don’t know if this is accurate, but at least it’s consistent now. No more quitting, drenched in sweat mid workout with Zwift, because my 10 min warm up to 200w left me wrecked.

Thanks Timothy, disappointing, but at least I know. I’m still hoping it will fix itself over the next week or so. if not, may have to do the same. My Kickr Snap is the second one, after the first was hopeless (good customer service from Wahoo replaced free of charge) but if this one’s now dodgy, I’ll probably end up switching product (expensive though).

I guess I might enter a few Zwift races this week as I’m seemingly able to put down over 400 watts for over an hour!!!

Hey Timothy,
I purchased a Wahoo Snap one month ago. Being new to virtual cycling (I’m mostly running), I enjoyed my first ride on zwift. The next day I installed the wahoo app and performed a spindown via that one, and I remember that it also installed a firmware update on the trainer. After that I had the exact same problem which you described, the power values appeared very low (roughly 30-40% less than before). As I didn’t have a real reference I was unsure and partly thought that maybe before it was just too easy, but since it was even very hard to start rolling I was skeptical. After some research I performed an “Advanced Spindown” using the wahoo app (somebody mentioned it above already). It is well hidden in the app, but the functionality is still existing (see here ). This solved my problem entirely! Although I was a complete newbie just a few weeks ago, I’m very confident that the current setting can’t be too much off now (not going into details here). By now I’m pretty sure that the firmware update I installed at the beginning mixed up the calibration of the brake, an important but fundamental setting which can only be fixed with an Advanced Spindown, not a “Standard” one. Exactly knowing how you feel, I sincerely hope that this solves the problem for you as well!
Ride on,
Markus

I’ve done that. Didn’t help in my case.

Hi Timothy , I’ve had my Snap for a couple of years now and this kind of ‘madness’ still happens from time to time. Happened to me at the weekend… warmup ride fine… did spin down and it was chaos. Rider kept putting foot down, power was way low.

For me it was a mixture of a couple of things:

  1. Zwift was incredibly busy and it and my laptop were struggling to keep up. HR and cadence sensors were dropping out too. These have always been fine. This just clouded the real issue which I’m sure was…
  2. Spin down was taking too long, should be between 9 and 16 secs… this is crucial. I checked tyre pressure and did multiple spin downs until I was in that range (tightening the tension knob shortens spindown) it appears that this has fixed it.

Hope you get it sorted. For me it is always caused by a spin down , and sometimes I don’t pay attention to how long it takes, but I should! The fact that Zwift is so busy just now just clouds the issue.

Hi Timothy,

I contacted Wahoo support. They said everything looked normal at their end, they can see I have the right firmware and that the spindowns were looking normal. They asked me to send a file with a 5 minute workout using the Wahoo Fitness app. I sent it doing 5 mins at constant 350 watts 85/90 cadence. I estimate I was outputting only about 200 watts.

They said they still couldn’t see anything wrong, but as my kickr snap was only 6 months out of (a 2 year) warranty, they gave me a discount on a replacement rear assembly (basically all the moving parts that attach to the frame). Replacement part is £150, they offered it to me for £80 and I’ve just ordered it. I think I paid £500 for the Snap 2 1/2 years ago.

Don’t know how old your model is, but thought I’d pass on my experience with Wahoo customer support in UK.

Cheers,
Richard

Good to know. Thanks for the reply. I’ll keep that in mind.

In any case, as long as I’m using the competitor’s program where I can control the resistance myself and keep it consistent, I think my current trainer is ok. The inconsistent resistance is only really an issue with Zwift, when going over a 6 percent hill might feel like doing deadlifts. Also, fwiw, I was participating in “A group” races during the Zwift Academy and I come to find I probably should have been in B group the entire time. And it’s frustrating to see people zooming by doing 4+ per kg, not knowing what’s real and what’s not. Psychologically, it’s demotivating when I am suffering in my pain cave mind state to be making comparisons with other riders. With the competitor’s program it’s just me and my numbers, and I keep focus on myself and my goals.

hi all, i just had the same issue as above. i used Zwift to recalibrate (i’ve go a Kickr Snap) and following that, the displayed power dropped significantly (felt like i was riding ~300W and it was displaying as low 200’s.) i tried a few different options, in the end i unplugged the Kickr for few mins, then plugged back in and tried the wahoo advanced spin down (basic spin down wasn’t fixing problem even after tightening and getting spindown time down to about 18s). i kept tightening until it got to ~16seconds and now the power is showing OK on Zwift.

Thank you Timothy for starting this conversation. I also just cleaned my bike and replaced back tire a week ago and have been fighting to get through my workouts ever since. It wasnt they were easy but like the comments have replied… a little like MUD!
It’s hard to put your finger on. I have re calibrated with Zwift and Wahoo and it has not adjusted the problem.It’s very frustrating. I have spent so much time getting it just right and have enjoyed Swift with friends. But now I can’t even stay close to them on a ride.
It has been very discouraging to have dropped so much in my ability to attain the same level of power as I did prior to the tire changing ect.
I am going to try the advanced spin down. I have a Kickr Snap.
I am hoping it helps. The support from Wahoo is not really there at the moment.
At least I know I am not alone!!

Seems like everyone who has this problem has a Kickr Snap. I went for nearly a year, working several times a week, to build my FTP to what I thought was almost 350w. It took a lot of work. I rode on Zwift and did hard workouts at least 3 times per week. I completed the whole Zwift Academy, and did the little races and stuff. When my trainer recalibrated it called into question all of that work, and made me question the accuracy of anything that happens on Zwift.

Having the exact same issue now. Power is 20-25% off relative to what I’m producing on board my wife’s Hammer and what it was just a week ago before I attempted to re-calibrate in game. It’s now super unstable after sprints and seeing power decreases when out of the saddle.

Beyond frustrated.

I might try to return mine for a wheel off trainer. I bought my Snap just under a year ago at REI.

FWIW - I have never used a real power meter. According to the new training program I’m using, my current FTP is 268. I wondered how accurate that might be so I looked back at my Strava for a segment that I did at pretty close to full gas for around 20 mins. Something that represents the closest thing I’ve ever done to an outdoor FTP test. It’s a flat 7 miles on our bike path that involves some little twists and turns. I did 24.2 mph average. The segment took 17:27. That’s my PR. Strava estimated 240 watts. So, if you figure coasting around the turns and up and down bridges, I would say 260-270 FTP sounds about right.

What I guess I’m saying is that I was probably nowhere near the 350 FTP I thought I had.