Kickr Power Drop.

(Derk Lauricks [R2]) #21

I’m going to try that out. I have been troubleshooting for while now and replaced the ANT+ and USB cable. Zwift support thought sending a generic link would help. Disappointing. I appreciate all the helpful members in this forum. Will get back to you once I tried the F-EC option. 

0 Likes

(Rich Colla ZBR) #22

I had a similar problem, but also experienced lag in power responding. upped my intensity without a change in power. Anyone else experiencing that?  My dropout occurred about three or four times on Box hill in London course. My Kickr registers three times in the pairing screen. One is ant+ and one is FEC and I can’t remember the third. I will try the FEC and see if that helps.

0 Likes

(Tom DeFelice (DIRT)) #23

Switched over to FEC and the few rides I’ve done have seemed quite stable.  No drops that I can see.

0 Likes

(Derk Lauricks [R2]) #24

Patient cured! Switched to FEC and went from 2-3 drops every 5 minutes to 1 hour with no drops at all. Did my tests in ERG mode since any drop will be more obvious in ERG mode. Hope this solves anyone else’s problem also.

0 Likes

(Derk Lauricks [R2]) #25

On a similar matter. I have noticed (as have hundreds of others) that there is a lag between power put into the paddle and reaction of the avatar on Zwift. I tried switching from ANT+ to Bluetooth and I would say Bluetooth is more responsive.

Anyone who had the same experience?

0 Likes

(Dylan) #26

Un-pairing and re-pairing my Kickr Snap using FE-C completely fixed this problem for me. 

Since updating the firmware on my Kickr Snap a couple days ago, I was getting  power drops every minute when my controllable trainer was paired using ANT+.  Mid ride today I was reading this forum and switched to FE-C and it completely solved my problem.  What I dont understand though, is why did I have to manually unpair and repair my controllable trainer.  Shouldnt if work correctly the moment I load zwift and pair my trainer in the pairing screen.  Its these kind of stupid issues that are causing so many people headaches and costing companies money because people think their stuff is broken.  Its so un-intuitive…

0 Likes

(Cari) #27

How do I pair to Fe-C? My power drops are driving me mad! 

 

0 Likes

(Russell) #28

Carl,

Unpair and then search to pair again.  You should see two options in the top left Kickr power unit box.  Choose the one the name ending with FEC.  I fixed my today and rode for a 65 minute workout without any drops and other features seemed improved as well.

0 Likes

(Cari) #29

I get searching…  at the top, and at the bottom an OK option.  Nothing in the top left. 

0 Likes

(Rich Colla ZBR) #30

Carl: After you unpaid your kickr and search to pair again, you should see your kickr listed more than once. Pick the one that says FE-C in the description and you should be good to go. Since changing my set up, I haven’t had one drop during a ride. Hope this helps.

0 Likes

(Derk Lauricks [R2]) #31

Other option is to go to swift app and pair with Bluetooth and do cadence through ANT+. Works for me. 

0 Likes

(Cari) #32

I have two Kicker Snap 8551 25.  One in the upper left scree says POWER SOURCE. The one in the lower right has CONTROLLABLE.  Neither says FE-C.  Which one do I use? 

0 Likes

(Russell) #33

Carl,

Have you updated your firmware on your Kickr?  You will need to use the Wahoo app to do so.  According to Wahoo one recently occurred that is related to the issue.  If you continue to have problems you might want to contact Wahoo.  I have found them to be very good at responding and providing useful information.

0 Likes

(Rich Colla ZBR) #34

Firmware update is a good suggestion. I’d just try the two settings available to you for about 15 minutes each and see if there is a difference in the drop rate. I don’t have the snap, Kickr 2 in my case and it shows the FE-C option. Good luck.

 

0 Likes

(Maggie) #35

@Cari - the picture below probably conveys the idea better (at least this is what solved my problem). For BOTH power and controllable trainer, you should have choices similar to those shown in the image below. My drop problem was solved by choosing FE-C — the top option. I hope it works for you! 

 

 

0 Likes

(Kip Kerecman) #36

Also want to share that changing over to the FE-C solved the same problem with me as well. I think I had to unpair, then pair again…that’s where you get the option for the FE-C.  

Interesting enough, I didn’t use Zwift much between July and October…and the problem only happened when I started using in October. Nice to have an easy fix.  I was getting cheated out of stars on some workouts!  

0 Likes

(Colin Chambers C CLS) #37

I installed a cheap powered usb hub for my ant+ extension lead (ant+ sensor is next to turbo flyweel) and changed to FEC on the power trainer section in the login page. Now works perfectly. thanks everyone who suggested.

0 Likes

(Jake Sigal (http://R2R.bike)) #38

As others have mentioned; Selecting FE-C (FEC) KICKR on zwift settings menu for the smart trainer and the power meter fixes the issue. I had a heck of a time figuring this out. I asked Wahoo to update their two support articles to include this.

 

I’m on a 2016 KICKR (that I just bought new from Wahoo in November 2017)

0 Likes

(Samir Shukurov) #39

I bought a Kickr Snap a few days ago, connected it to Zwift on my Macbook by using Bluetooth, and during the first ride had power drop outs every 5-10 minutes. Does FE-C mode solve the issues for ANT+ connections only, or it is also helpful for those who are using Bluetooth? Thanks

0 Likes

(Jake Sigal (http://R2R.bike)) #40

Samir, FE-C is Ant only. it’s managed by Dynastream and the ANT consortium working groups.

0 Likes