Kickr issues after update


(Mark Williams) #1

I haven’t seen any specifics on the Kickr-related changes but first impressions suggest there’s a problem. I just did a single lap and the resistance was virtually non-existent. My normal time for a lap is on the 8 - 8 1/2 minute range. This one took almost 13 minutes :slight_smile: Also, I was peddling like crazy up one of the hills (probably 120 rpm) and managing a whopping 4pm :slight_smile: The folks I was riding with left me in their dust!

After this ride I did start Zwift and try again in case it was some one-off, but had the same again (no resistance).

All other aspects of my machine (Surface Pro 3) seem just fine, including a quick test with TrainerRoad which had no issues.

Mark


(Eric C. (Zwift HQ)) #2

Hi Mark,

Set Zwift to Sim mode from the Wahoo Fitness app on your phone. Also check to make sure it’s updated to the latest firmware.


(Wynand Viljoen (B1 Evo)) #3

I had the same issues today after the update. I tried 5 times, rebooting my computer several times. Submitted a ticket to support. I also had trouble logging in for about 15 mins (both web page and Zwift program) seemed like their secure server had problems. Hopefully they can fix it quickly as riding Zwift island is not the same without the resistance changes.


(Mark Williams) #4

Eric. Thanks for the suggestions. I haven’t got an IPhone so will need to borrow one to make that change (interested to know why this might be necessary though). I have used my Kickr as recently as Wednesday, without any issues (so wouldn’t think this is a firmware issue). I will check all this when I get a chance but Wynand’s post suggests this may not be specific to my Kickr.

Thanks.

Mark


(Eric C. (Zwift HQ)) #5

You can use an Android app as well. This is the best way to calibrate your KICKR. If another program puts it into ERG mode, Zwift should put it back into SIM but the KICKR can be a tricky, complicated beast.

As it stands, if it’s in SIM mode there should be no code that ever puts it into ERG (steady resistance) mode.


(Wynand Viljoen (B1 Evo)) #6

Hi Eric

I just used Trainer Road and my kickr is set to ERG mode and works with Trainer Road. I tried Zwift again and I was stuck at 113W regardless of what gear I was in. Something has changed since the update.


(Eric C. (Zwift HQ)) #7

Yes, your KICKR is stuck in ERG mode. It needs to be set to SIM mode. ERG will not SIMulate our elevation changes.

We do not aggressively GRAB the KICKR and force it into SIM as so many people seemed to complain about this.


(Wynand Viljoen (B1 Evo)) #8

Hi Eric

 

I just tried it again and it seems to be working although according to the Wahoo fitness app it was in ERG mode. I will try it again in SIM mode.


(Wynand Viljoen (B1 Evo)) #9

He Eric

Tried it in SIM mode and the resistance was lost. Toggled between ERG and SIM and the only thing that would happen was that in ERG mode the power would drop off to about 60W and in SIM mode your cadence controlled the power. No change with regards to the slope. Not sure what’s going on.


(Eric C. (Zwift HQ)) #10

Hi Wynand,

Make sure nothing else is running that may control the KICKR after setting it to SIM (the App, TrainerRoad, what have you). If you have anything else open, it will take control and Zwift will never grab it back.

Zwift will take the mode given to it and stick to that as opposed to, before, grabbing it every few seconds and force it back into SIM.


(Wynand Viljoen (B1 Evo)) #11

Hi Eric

Nothing else was open. Only the Wahoo Fitness app on my iPad which I used to control the mode. Will try again in the morning. Like I said this is the first time since I started using Zwift that I’ve run into this problem.


(Mark Williams) #12

Eric,

I am not in a position to test this out right now, but what are the implications for those of us who use TrainerRoad and Zwift (I don’t mean at the same time :))? Anything different we need to do after a TrainerRoad workout, for example, to ensure that Zwift works as expected?

Mark


(Dave Pennington) #13

Hi guys,

Did you get this to work in the end? Having the same problems here. I did an erg session last night on Trainer Road and can’t get Zwift to control the Kickr at all now, so I’m in the same boat as Mark above as I use both Trainer Road and Zwift.

Mine’s not in erg mode, but just resistance it seems - I can whack up the power to whatever by changing gears, but the resistance isn’t changing. I think because I carried on cooling down after my Trainer Road session ended and it defaults back to resistance mode for that.

Its worked fine up until the update just now though.

I’ve put it back into sim mode with my phone and can control the resistance just fine from there, but no joy at all on Zwift. Nothing else running, rebooted the Kickr/PC, swapped USB ports for the Ant+ etc…


(Wynand Viljoen (B1 Evo)) #14

Hi Dave

Still not working! This is starting to become frustrating!! I’ve been using Zwift almost daily for 3 months and this is the first time that I’ve had persistent problems. I’m convinced that the new update is to blame. I have used Trainer Road and Zwift in the past with no issues. Trainer Road still works with no issues. Nothing else is running. I’ve set the Kickr to SIM mode using the Wahoo App and still there is no resistance change.Spent 4 hours yesterday trying to trouble shoot it.


(Dave Pennington) #15

Hi Wynand,

Same as! I packed in after an hour of messing about too. I’m running through a Trainer Road training plan at the mo and have been substituting some of the more boring sessions for laps of the island, so its been fine for me too up until the update.

Win7Pro for me (clean install) with the Sunnto Ant+ stick, all firmware/software updates.

I might try a re-install of Zwift to see if that does anything, (can Trainer Road set it to SIM mode? I can’t recall and am in the office at the mo) but I can’t think of anything else to do now.

 

Dave


(Christopher Pallotta) #16

Something you guys might want to try is to disable bluetooth on any other devices (other than the one using Zwift) that have ever been connected to your Kickr. Additionally, unplug the Kickr power, wait 30 secs and plug in again. Manually shut down any app that has connected to your Kickr other than Zwift. Remember, once you’ve done the spindown using your device, you don’t need to (and shouldn’t) continue to have it connected to the Kickr. The Kickr remembers the spindown. 

If this works, you should then be able to turn bluetooth back on on your other devices without issue. Just don’t then reconnect those devices to your Kickr if you’re using Zwift. Just one app at a time, and releasing an app may require the above process.

The Kickr is designed to be controlled and connected to only one device/app at a time. While it’s been possible to use TR and Zwift together in the past, it’s likely that that will always create some type of problem. 


(Wynand Viljoen (B1 Evo)) #17

Hi Chris

i’ve unplugged the Kickr (do it every time I’m done using It) no BT devices are on. I run both Trainer road and Zwift at different times but have not used TR for a couple of weeks. Going to try a clean install of Zwift to see if that will fix the issue. 

Dave, I don’t think TR has SIM mode listed. I’ve set my kickr to SIM mode using the Wahoo Fitness app on my iPad.


(Christopher Pallotta) #18

Wynand, you wrote above that you had used Zwift with the Wahoo app on your iPad open. Have you turned off bluetooth on your iPad now?

It sounds as though you have, but just double-checking. 


(Dave Pennington) #19

Hi Chris,

Thanks for the suggestions. The only Bluetooth thing I had running was my headphones to my phone. All other apps closed. I did disable Bluetooth on the phone and turn off the headphones, then rebooted everything (inc turning the Kickr off for 2 mins) but no joy.

I’m the same as Wynand, I haven’t changed the way I do anything - it worked perfectly on Wednesday before the update after a Trainer Road erg session on the Tuesday for example.


(Wynand Viljoen (B1 Evo)) #20

Hi Chris

Yes everything is turned off. I just did a fresh install and still the same. Like Dave says I haven’t changed a thing, the only change has been the new upload. I have rebooted, turned the kickr on and off. Cycled through the various modes using the Wahoo App. Turned everything off including the BT on the iPad and rebooted. Nothing has worked.I’m out of ideas now.

I’m running a everything on a newly built (just for Zwift) system running Win 8 Enterprise.I have a Suunto Ant+ dongle plugged into a USB3 10ft ext that places the dongle a foot or so away from the kickr.