Kickr climb problem

Hi. I have the kickr and kickr climb. I have updates available so updated the kickr but i cant update the climb. Its not finding the sensor. Im on Android. Ive deleted the wahoo app and reinstalled it but no good. Ive unplugged the climb for a minute or so and still no good.
The climb works absolutely fine in game

Hi @David_Mckay4, I have no experience with the Kickr Climb so I can’t comment on your exact situation. However, sounds like you should try contacting Wahoo support, I’m sure they can help and are quite fast at responding.
:ride_on:

1 Like

From taking a peek at Wahoo’s support page it sounds like you need to close all apps that connect to your Kickr and make sure that your Kickr is on up to date firmware before you can use the Kickr to update the firmware on your Climb. I recommend checking out that article and seeing if those steps work out for you and checking in with Wahoo Support if you have trouble

1 Like

I had another go today and it updated just fine without me doing anything. Must have been a glitch in the matrix. Thankyou.

Not just an isolated glitch in the matrix, brand new climb, no other apps opened, turned both devices off for 30 seconds and rebooted phone, open wahoo app on my phone, it updates the kickr firmware fine. It can see the title angle of the climb as it moves, and prompts me to update the firmware, but then can’t find the sensor for some reason. Rinse and repeat with the kickr firmware updated, still the same issue. Been trying for hours now, but will leave it alone and try another day. Frustrating! Picked this over the elite razer gradient machine, both because the climb is cheaper but was expecting a more seamless experience.

The issue was an out of date app. After updating the android app, it worked. My phone updates apps every night, so must have been another bug that wahoo let creep in.