Keep on getting an error - "a Bluetooth serial failure has occurred."


(Sean van der Westhuizen) #1

Lately on my iMac I am getting an error when going to the pairing screen - I am using a Wahoo KICKR and an Ant+ dongle - no BT devices.
I keep on getting a pop-up window saying “A Bluetooth serial failure has occurred”

It keeps on popping up and I have to click quick to close it and finish my pairing process - when I move on to the Ride / Work-out screen, it eventually goes away.

Is there a way to disable BT somewhere so Zwift doesn’t search for any BT devices ?

Thanks

 


(Jon Mayfield) #2

Hi Sean, that is a new one to me.  What kind of things are plugged into your mac in the USB ports? Are they all empty?  Do you use a wireless mouse or keyboard that needs a dongle?

If you feel comfortable, can you run “terminal” and type “ls /dev/cu.*” then hit enter, and list what it says?


(Sean van der Westhuizen) #3

Hi Jon,

 I have the normal Mac BT keyboard and mouse - no dongles required for them.

Otherwise I have a Suunto ANT+ dongle for Zwift plugged in and an external USB card reader (SanDisk)

That’s it.

I got the following when using the “ls /dev/cu.*”


Heidi-van-der-Westhuizens-iMac:~ HeidivdWest$ ls /dev/cu.*
/dev/cu.Bluetooth-Incoming-Port /dev/cu.HeidisMacBookAir-Blueto
Heidi-van-der-Westhuizens-iMac:~ HeidivdWest$

 


Could it be that there’s some “old” stuff lying around on my iMac ? (It’s never been re-installed since I got it a couple of years ago - only upgrades as they’ve come out :slight_smile:

Currently running OS X El Capitan (10.11.2)

Thanks

 


(Jon Mayfield) #4

A quick google search of the error shows it could be due to having a bluetooth dongle plugged in at one point in the past, and it leaves the driver behind.

I’ll see what I can do to avoid polling those devices you have in the next update, but this is a pretty rare issue so I’ll be taking a stab in the dark.  I’ll reply here when I’ve got something for you to try. 

Sorry for the trouble.


(Sean van der Westhuizen) #5

Hi Jon,

 thanks a lot !

I’ll have a look as well and see whether I can possibly find a way to “clear” the drivers so this doesn’t happen.

The interesting bit is that we also get this error on my wife’s MacBook Air - when there’s nothing plugged into her Macbook Air & she opens Zwift.

I however see that her MacBook Air is listed under the “ls /dev/cu.*” results … maybe there’s something in that :slight_smile:

 

I really appreciate your help & the AWESOME software :slight_smile:

 

Sean


(Darren Conrad) #6

For what it’s worth I received the same errors on a MacBook Air running OS X El Capitan after I tried to connect wireless bluetooth headphones while running Zwift at the same time.  Once I dropped the wireless headphone from Bluetooth the errors went away.


(Jon Mayfield) #7

Hi Sean, an update went out a couple hours ago that changes how I check for USB trainers.  Can you let me know if you’re still getting the error popups after the Zwift update comes down?  Thanks (and thanks for the kind words too :slight_smile: )


(P Sauve (8610')) #8

I had the same problem whenever I connected Bluetooth speakers or had the Bluetooth laptop nearby.  I just checked, and the error isn’t there anymore, but…

…no sound comes out of the speakers now.  If I hard connect the speakers, there is sound.  But if they’re in Bluetooth mode, nothing.


(Sean van der Westhuizen) #9

Hi Jon,

 sorry for the delay in response.

Got the updated Zwift over the weekend and also checked which BT devices I had linked on my Mac.

I removed 2 devices which I don’t use anymore (wife’s macbook air & some BT speakers).

When I subsequently opened Zwift, no more BT errors !

Thanks - all seems well now :slight_smile:

 

Thanks a lot !


(Harold Chang) #10

I just got this error tonight on my Macbook Pro running El Capitan. I am using bluetooth headphones and tonight was the first time this happened. I went and reinstalled Zwift, but no luck, still having the errors. Once I close close the bluetooth connection, the errors go away. 

 

Any help would be appreciated, my laptop is too far from my trainer for wired headphones. :frowning:


(Harold Chang) #11

Just to add, I’m running the latest version - 9609


(Trevor Hedge) #12

I haven’t used Zwift and the trainer for months, as it has been summer down here in Australia. But just fired it up and did latest download today, Friday, March 18, and had this same error as reported above so jumped on google to search and ended up here. 


(David Riggans TeamODZ) #13

I’m having this problem as well. It began when I started using bluetooth headphones. I connect them to my MacBook Air and they initially work fine with Discord. Then I open Zwift and I get that same error message about 6 times. I can close out all 6 windows, but the same 6 messages will come up again after a few minutes. The same thing occurs even if I “disconnect” the headphones. If I turn off bluetooth, I believe that takes care of the problem. Bottom line is that I can’t use my Bluetooth headphones with Zwift!


(Jon Mayfield) #14

Interesting - sorry for the trouble.  Can anybody still having these issues can you try the suggestion I made above of:

“If you feel comfortable, can you run “terminal” and type “ls /dev/cu.*” then hit enter, and list what it says?”

Then post what it says on here?   

David, what exact headphones are you using? Do you have an amazon link?


(David Riggans TeamODZ) #15

Here is what it says when I use terminal:

Davids-Air:~ DavidAir$ ls /dev/cu.*
/dev/cu.Bluetooth-Incoming-Port /dev/cu.LGHBS850-CSRGAIA

Here are my headphones:

http://www.lg.com/us/bluetooth-headsets-headphones/lg-HBS-850-Blue-tone-active

For tomorrow’s ride, I’m going to try connecting to my iPhone instead and see what happens. I do also us the Wahoo TICKR HRM, so maybe there are too many BT devices going into the MacBook?

Thank you for any help you can offer.

David


(Sarah Michael) #16

This is evidently still an issue. Downloaded Zwift for the first time today and have been unable to circumvent all the ridiculous popup error messages. Guidance would be appreciated. Thanks. 

 /dev/cu.Bluetooth-Incoming-Port /dev/cu.SarahsiPhone-WirelessiAP

/dev/cu.SarahsiPad3-WirelessiAP

 

Sarah


(David Schiman) #17

Same.  Any help Zwift?


(Best Bluetooth Headphones) #18

 This post is very useful and informative. The Bluetooth is one of the best connectivity for connecting one device to another device. The headphones and speakers are also supported Bluetooth. https://bluetoothgears.com/ 


(Fionn McGuire) #19

This issue turned me off returning to Zwift when I got a smart trainer this week. Not being able to use Bluetooth headphones on a turbo ride is a deal breaker. Considering the last reply was over a year ago, it also doesn’t look like it’s being resolved.


(David Riggans TeamODZ) #20

True Fionn! I had to have another device (iPad or iPhone) available in order to use BT since that message wouldn’t let it work on the Zwift laptop. I haven’t tried to use the headphones lately, but I’m curious now and will give it a try again. Apparently Jon hasn’t figured this out yet. It would be nice to get a response at least. Try his “terminal” suggestion in his last post above and see if he responds. I’m also annoyed by the fact that Bluetooth can get on here and place an add without someone deleting it. They really don’t seem to be paying attention to this series of posts.