Keep crashing when i launch

I have tried installing &uninstalling numerous times & the same thing is happening every time. As soon as the Zwiftapp.exe launches the music plays for about 3 seconds then it crashes.

Any ideas on what I can do to fix. I have been in touch with support over the last 6 weeks but all there suggestions I am still having no luck. 

2 Likes

Is this on Windows 10 by any chance?   I just moved my laptop to a new-ish build yesterday, but “zwiftlauncher.exe” crashes a few seconds in.

In your case, have you tried both video and audio driver updates yet?   In my case, I’m leaning to a .NET framework issue thus far.

Na Rob it is on Windows 7, I will try updating the drives etc today & see what happens. Failing that I will just stick to Trainerroad paired with the Sufferfest DVD’s

I have had the same problem. Zwift crashes at the login screen on my Windows 8.1 machine. I then installed it on my Mac with Yosemite and exactly the same thing.  I think the beta version needs a lot of help. 

Time to go back to the Tacx trainer. Sorry Jens and GCN

Ok so I upgraded all my drivers & to my surprise I finally got it working. Did a ride this morning now just got to work out why I get drop outs from the Wahoo to Zwift. I am still pedalling but the little man on the screen stops & my watts show up as zero. Then you gotta try to catch up to all the dudes that just passed while you were stopped but not stopped if you get my drift. Other than that it worked fine did a 60 minute workout & I was pretty shagged when I finished

Hi Todd, indeed drivers are most often the cause of crashes in all 3d applications. Glad you got yours up and running.  Due to the wireless nature of ANT+ and interference with nearby devices, a USB extension cable is highly recommended.  

 

Grant and Rob, if you guys open a support ticket and attach the logs we’ll have a much greater chance of sorting these things out over the coming weeks.  Details here: https://support.zwift.com/hc/en-us/articles/202979045

1 Like

My issue was resolved by uninstalling and reinstalling the Zwift client.

I have the same issue, Zwift loads and then if I choose just watch it will crash as soon as the arrow comes up on the LHS. Clean windows10 build on a laptop that was running Win7 with no problems. Installed and re-installed the Zwift client 3 times now with no success, always crashes at the same spot. Removed and installed latest video and sound drivers with no success.

I’m starting to think it is a permissions thing, maybe a write to a directory isn’t happening because that directory is stopped from being written to maybe ? Every time I try log in my password is not remembered, it is remembered correctly with Zwift installed on my main PC.

I also note the installer from the website says it is 1.0.8, where the beta is only 1.0.6098, no idea if that has relevance or not.

 

Where are the log files kept for Zwift ?

 

G

 

 

This keeps happening to me and I am on MAC Yosemite 10.10.5

Im in the same boat too. 

 

Happened to me, updated my graphics card drivers and it then worked.