"Just watch" mode on PC does not show 'mission' badges

When I use the PC or iphone and select “Just watch” if I go menu, badges then my (two) completed missions do not appear and missions show as “0”

When I ‘ride’ via PC and iphone menu, badges then missions = 2 and badges show at the end of badges list

I have checked this many times and this is a consistent ‘feature’

Is this a bug or feature?
Do you require any more information?
Thank you for your help.

Images attached - these have been taken one after the other, showing first on a PC just watch, ride, just watch, ride - Each ‘just watch’ the mission badges are missing.
Then tried the same on iphone with the same result “Just Watch” missions missing, ‘RIDE’ and they are in the badges.

It might be that if others report intermittent missing badges that they used the ‘just watch’ option.

I have repeated this many times with the same result

PLEASE NOTE - In the images I did not have NEO2 connected, but this issue is the same when connected to a trainer

Thank you for any help, ask if you need any more info
Andy

IMG_1061 IMG_1062 IMG_1063 IMG_1064 IMG_1065 IMG_1066 IMG_1067