Issues with Kinetic Road Machine 2.0


(Soeren Moos) #1

Hello Zwift,

Thank you for the beta invite, so far it has been a very enjoyable experience.

Anyway, this is beta and there’s a lot of work to do still.

Here are the errors I’ve experienced so far in Zwift, with my Kurt Kinetic Road Machine 2.0

Zwift does popup alot with the “slippering tire” warning.

When I go from easy riding to a fast sprint, trying to close a gap I get the warning very often, but it also appears at random times. I can ride with the same cadence for a very long time and still it randomly pops up.

I’ve tightened my trainers pressure screw to experience my back tire at different pressure niveaus, but that does not solve my problem.
Next I have played around with my tire pressure, 6bar, 8bar, 9bar, 10bar – But still no luck.

I have compared my cadence to ant+ response time in both Zwift and Traineroad –
In TR I get accurate numbers that updates very quickly, while in Zwift it takes a lot of time for the game to show the current cadence.
I’ve also noticed that your virtual power feature jump a lot. I can stick with 100 cadence for a minute and the numbers jump from 80-140Watts.

So far it’s a great game for easy riding, but it’s a problem for me, not to be allowed to pump out my desired power, without getting the popup warning.

Does your servers need optimizing ? If our latency to the server is unstable, maybe that could be why the server suddenly gives me random warnings and also why the numbers jump around, instead of being stable and accurate ?

Hopefully you can look into what I’ve experienced so far and give me a better riding experience in the near future.

Thanks for now, it’s easy riding time at Zwift Island :slight_smile:


(Soeren Moos) #2

Hi Dickson Goulart,

I have my usb station with 4x usb 2.0 ports connected to my pc - so my garmin gsc 10 is placed no longer than 1 meter from my ant+ dongle while Zwifting. So I don’t think that is the problem, hmm.


(Soeren Moos) #3

I have connected my ant+ usb dongle to an usb extension cable.
The cable & dongle is taped to my bike 10cm from my speed/cadence sensor.
When I launch Zwift, im now able to pump harder in the pedals without getting “slippering tire” warning, it does still appear though, if I im rough enough.

The watt numbers also seem to be more stable now.

The fun thing is, when I now pair my speed/cadence with TR it says the signal is bad/poor , before it was “excellent”

So better results in Zwift now and worser in TR.:slight_smile: