Issues with bluetooth dropout on Woodway treadmill

Update
I just tried a free app called GymTrakr, it’s meant to pickup speed, distance, cadence etc. It pairs and works perfect with the woodway 4front, this tells me that the unit is capable of pairing and sending the info so I’m thinking that maybe an Ethernet connection would fix the issue or perhaps it’s an issue with zwift right now :man_shrugging:

If your treadmill has the option to hardwire to your router via Ethernet instead of WiFi, that’s going to be the most reliable way to pair to Zwift’s servers.

Fingers crossed that this improves your situation well enough. It may not entirely solve the Bluetooth drops between the tread and the Apple TV, though. The Bluetooth-only ATV box is hamstrung by the absence of a USB port. There’s no way to plug in an ANT+ dongle and pair via ANT+ instead of BLE.

I am not familiar with North Pole Engineering’s GymTrackr app, or their broader technology that some fitness equipment makers may embed in their circuitry. If your Woodway has that chipset on-board, that may be all you need to convert its ANT+ signal to BLE so that your ATV can receive it.

If no: there are two devices that can convert your tread’s ANT+ signal to Bluetooth to act as a bridge to your Bluetooth-only Apple TV box. North Pole Engineering’s CABLE device and 4iiii’s Viiiiva heart rate monitor are discussed here.

I was thinking of hardwiring the Ethernet to the Apple TV…there is a csafe port on the back of the display, I’d have to unscrew the back panel to get to it, I’ve heard a gem retro module would work. This seems like a massive pain considering I already have a smart treadmill, did anyone else have any luck with their woodway 4front? Was it your internet signal? What was the issue?

@Tor_Eckman

We have two Woodways at the Zwift HQ labs, and back before we worked from home, they got the most use of all the treadmills because the Woodway running experience is awesome. We used iPads to run Zwift, and they paired perfectly via Bluetooth.

If you’re getting BLE dropouts, I’d suggest going through this list to reduce local interference sources. Personally, I would exhaust all these possibilities before getting sidetracked with the Ethernet setup.

1 Like

Thanks again, taking a look at this list, the only one I haven’t eliminated is number two. I didn’t realize I needed an ANT+ dongle, where does this get connected?

Also I’ve confirmed the wifi channel is on channel 1 a less used channel in the area, however, my garage where the treadmill is located is only getting a 2.4ghz signal which is likely causing problems as zwift operates in real time whereas Netflix etc read ahead and smooths out the signal. This is my thought process on connecting an Ethernet cable to the Apple TV so I can ensure a fast 5ghz connection in order to run zwift, but again I’m not technologically savvy as I’m sure you’ve guessed

@Tor_Eckman

The ANT+ dongle is not possible with Apple TV because the ATV box lacks a USB port.

@Tor_Eckman

The Ethernet cable should not connect the treadmilll directly to the Apple TV. Instead, you’d connect the treadmill to your router via Ethernet. Then connect your ATV box to the router via Ethernet. This is the hard-wired way for your ATV “see” your treadmill.

Hard-wiring is feasible if your router is sort of near your garage. Is that the case for you? If not, to solve the network dropouts it might be better to get a WiFi extender to boost coverage to your garage, and use the 5GHz as you suggested.

The router isn’t exactly close but it could be done, would have to do some drilling. I’ve tried to pair and run zwift on my laptop, iPhone 11 and iPad and still the same thing so now I’m confident once I get the signal strength up all should be good

Please do let us know if you get this working. I am dying to know if there’s a fix.

At my place, I powered off/unplugged every 2.4 ghz device we have. Unplugged the Kickr next to the tread. Put the router on 5ghz mode only. Connected to iPad at the tread rather than Apple TV which is 5 feet away. We are hundreds of feet from the neighbors. Turned off Apple Watch in case that might be the issue. Tried an assortment of connect/reconnect/reboot steps. All to no avail. My avatar freezes every few seconds, at a regular interval, every time.

-DL

Shooj - glad to hear that there are Woodways that do work. Gives me hope.

1 Like

So to update everyone on the status of my issue. I’ve run an Ethernet cable from my router to Apple TV, same problem
I’ve run an Ethernet cable to the woodway, same problem
I’m beyond pissed off now, this is silly that this thing can’t figure out how to stay paired, so now I have to buy a treadmill sensor or footpod because the Uber expensive treadmill I saved and saved for, can’t get the job done, pathetic.

I have been communicating with my Woodway sales rep since this issue started for me. His most recent update acknowledges the issue and it sounds like the R&D department is now actively investigating, working with the Bluetooth hardware supplier.

Don’t ask me how/when this leads to a fix, but that’s the update I got.

1 Like

@D_Larson
Interesting. Please keep us informed if you hear anything back.

In the meantime, would you try something?

  1. do you have another device that can run Zwift, like a smartphone or a laptop? I’m wondering if we can isolate this as an issue with the Apple TV platform .

  2. Is there another run / fitness tracking app you use to log your runs on the tread? If similar flaky Bluetooth issues crop up there too, we can surmise that it’s an issue with the Woodway.

Thanks for the questions. Woodway, to their credit, has done a great job keeping me updated. I know there is now an open line of communication directly between Woodway and Zwift. I’m hoping there will be a fix, and that it will be able to apply to my treadmill.

Since you asked, I will tell you I have tried the Apple TV, the iPad, and a couple of different iPhones. Yes I am heavy on Apple at my house. Same issues on all devices.

I don’t use any other running apps. The communication with the Apple Watch seems to be seemless although that may be a different communication protocol.

Hey everyone, just to keep you in the loop, I’ve tried connecting via laptop, iPad, iPhone, hardwired Ethernet etc. It’s definately the woodway, just curious what did woodway day to you with regards to their on board bluetooth module? Or if they were working on a fix?
I ordered a GEM retro from North Pole engineering to plug into the csafe port and if it works I will be sending the invoice to woodway. I didn’t have these issues with my last smart treadmill, a sole f-something or other, although that treadmill also wasn’t as comfortable as this woodway is. Hopefully it gets sorted soon, zwift is beyond cool and I feel it’s the future of indoor running for sure!

Any update on this? Did it work? Woodway seems to have given up on this and now only tells me that Zwift needs to fix the problem. I don’t have a lot of time for this issue plus I have mostly been training outside in the summer but would love to get the treadmill working with Zwift by the winter.

Hey! Sorry I thought I had posted my fix to the issue. Yes I have it working now, I had to buy something called a gem retro (treadmill) from a country called North Pole engineering, the company who purchased wahoo a year or so ago.

What you do is unscrew the back of the display panel on your woodway, I have the quickset display on mine and plug this module into the csafe port, it’s labelled inside the woodway control board. After you screw it back together when you pair your treadmill on zwift you select the treadmill option and not the woodway option.

I have had zero issues or dropout since. Hope this helps! I called woodway a month or so ago and said I’d be sending them the bill for me having to buy this to make it work after shelling out thousand of dollars for their treadmill. Explained that my low end sole had no problems connecting to zwift, they mentioned they’d send me a reimbursement cheque but I haven’t received it to date.
I will be following up with them about this

Let me know how you make out!

Cheers
Chris

2 Likes

That sounds great and thanks for the tip!

How old is your woodway. Mine was built about 18 months ago. And has worked perfectly with zwift. No dropouts ever. And connects every time on first attempt (as opposed to my ticker fit and stryd that I always need to play with for a while). Maybe something with woodway older or newer gem modules.