ISP or CDN issue with latest v1.0.52 files - Z117 at line 601 in Patcher.cpp?

[Edit…
@shooj please read this - IMPORTANT UPDATE - WORKAROUND for CDN DOWNLOAD ISSUE, but not a solution for most Zwift users:

I disabled the “Web Proxy Filter” feature that scans HTTP requests on my firewall (I work in IT) and no longer get the Z117 error and Zwift game has updates to 1.0.100278.

My diagnosis is that your Cloudfront CDN is sometimes returning content in a way (‘chunked encoding’?) that the Zwift user’s firewall, proxy, security client etc. does not like and it is being blocked. This is causing the truncated file download and thus the checksum error

Search up this from fastvue, which may be relevant: “How To Solve “13 The Data Is Invalid” Error in Forefront TMG” which suggests:

This error occurs when the destination Web Server is using Chunked Encoding but it is not passing the correct TransferEnconding header.

I am fortunate to work in IT, so can update my home network to workaround this apparent Cloudfront issue. Zwift needs to please work with Cloudfront to resolve, as many of your customers will not be able to.
/Edit]

Original reply:
@shooj hope these firewall logs help. I see the Zwift launcher making lots of successful HTTP connections, then a mal-formed one, which I am assuming relates to the checksum file download issue.

I am trying to add firewall logs to this reply but your annoying forum says I cannot include links, so have had to re-format some of the log content below, you can still see the issue.

Firewall logs: Successful file downloads are made, then this:

Failed Connection Attempt 02/01/2022 08:26:40
Log type: Web Proxy (Forward)
Status: 13 The data is invalid.
Rule:
Source: ( x.x.x.131:0) ← This is the IP of my Zwift PC
Destination: (server-13-227-172-3.lhr52.r.cloudfront net 13.227.172.3:80)
Request:
Filter information: Req ID: 0c256a23
> Protocol:
User: anonymous
Additional information
Client agent:
Object source: Processing time: 0
Cache info: 0x0 MIME type:

Later on a successful connection:

Allowed Connection 02/01/2022 08:26:52
Log type: Web Proxy (Forward)
> Status: 200 OK
Rule: Web Access Only
Source: Internal ( x.x.x.131:0)
Destination: External NIC (server-13-227-172-3.lhr52.r.cloudfront net 13.227.172.3:80)
Request: GET [13.227.172.3] gameassets / Zwift_Updates_Root / Launcher_ver_cur.xml
Filter information: Req ID: 0c256a4f
> Protocol: http
User: anonymous
Additional information
Client agent:
Object source: Internet Processing time: 47
Cache info: 0x58800000 MIME type:

Later on the firewall session with the invalid request times-out:

Failed Connection Attempt 02/01/2022 08:28:51
Log type: Web Proxy (Forward)
> Status: 1460 This operation returned because the timeout period expired.
Rule: Web Access Only
Source: Internal ( x.x.x.131:0)
Destination: External NIC (server-13-227-172-3.lhr52.r.cloudfront net 13.227.172.3:80)
Request: GET [13.227.172.3] gameassets / Zwift_Updates_Root / Zwift_1.0.100278_e38ad30c / assets / Noesis / Blend_Data / noesis.wad
Filter information: Req ID: 0c256a17
Protocol: http
User: anonymous
Additional information
Client agent:
Object source: Internet Processing time: 131766
Cache info: 0x58800000 MIME type:

4 Likes

UPDATE: I just restarted for the umpteenth time, and it suddenly started working! Whew :slight_smile: (this was after numerous other attempts including repeatedly running the file as an administrator, deleting/reinstalling/restarting several times, canceling onedrive sync, and transferring the files from the Zwift file in downloads to the Zwift file in C:\Program Files)

I’ve spent hours trying all the workarounds that I have found, including this one, and am continuing to get the same error :frowning: I don’t know what to do anymore. It seems to be working on my ipad mini, but that is not ideal, and I am not sure if I will encounter problems with my Garmin as I have not used it with my ipad before. (Bike is in the shop so I can’t try that yet.)

I took @James_ames_SGMums advice and tried on a different internet and it worked! I was on holidays when the update was rolled out, had issue on both my work and personal computer. I got home from holidays today excited to try my home wifi reading James post and no problems!

#GiveJamesAJobOffer

1 Like

It’s only a work around if you dont use Vodaphone for household internet and mobile.

Hi there,
it looks like a “firewall” problem.
As James said, i disabled my HTTP filtering (throught a WatchGuard firewall) and it worked for me.
I don’t have so much time to investigate but it worked :wink:
(Its the same as using an alternative wan access, like using your mobile phone data connection).

Regarding the Z117 and Z112 errors which occur after this log line:

Downloader: ERROR: “data\Noesis\Blend_Data\Images\Workouts\performance\performance-workout-one [1024x360].jpg” failed to download with code: 0!

Looks like this is a known issue and is currently being worked on. I don’t have an exact timeframe, but from what I know, the fix should be released pretty soon.

2 Likes

Erm, no it doesn’t. I have never had an update/download issue on either of my laptop’s (Windows 10) until 1.20

Now I get Z117 patching line 602 etc, so perhaps the fix in 1.20 for some created a problem for others.

Switching to try a mobile network won’t work for me as that is all I use, no landline available here. So is it Zwift, Vodafone or me?

Uninstall/reinstall, copying files across etc not working.

I’ll keep reading and trying various work arounds … though that’s not really acceptable for a paid service.

Maybe there is more further down the thread.

This worked for me in the end (Windows 10):

Uninstall Zwift
Search for ‘Zwift’ on the C:\ drive and delete absolutely every file you can find, including program files, documents, downloads, roaming data… This was the key element for me, just deleting folders from documents or downloads wasn’t enough.
Restart the pc
Follow the guide on resetting the Zwift Launcher
Run Zwiftsetup.exe as administrator

UDPATE:

The z117 install error has been resolved with today’s game release v1.21.0. Windows users - please update at your earliest convenience.

Please see this thread for more detailed information

1 Like

Hi.

I’ve worked through the various uninstalls, restarts, deleting any mention of zwift etc, and I’m still getting a z117 error. Is there a direct link to install the most up to date version of zwift?

I am on Vodafone for all my various ways of connecting to the Internet if that affects anything?

Thanks

Tom

HI @Tom_J_Laws

Yes. Go to zwift.com/downloads and pull down the latest Windows package.

As noted in the post above yours - see this thread for details that will save your personal best and custom workout files from getting deleted.

Hi,

When I did thst last night it installed fine but when Zwift first opened it had 1.1.1 in the bottom left corner of the launcher, before the preparing to update bar appeared, and the whole tedious process of waiting for it to fail again started! Very frustrating.

Urgh! I’ve just spent the last hour clearing every last trace of Zwift from my windows 10 laptop. When I then download the application again, the launcher that installs is version 1.1.1 and the updates continue to fail.

Someone above mentioned that Vodafone might be an issue - should I just take my laptop to work and let all the installs etc happen over that non Vodafone internet? Pretty frustrating to have wasted the time I could have had two bikes rides outside trying to make inside cycling work.

Any help or thoughts beyond the links already posted much appreciated please.

Tom

Got an update yesterday and now on Launcher v1.1.1 / Game version v1.21.0 . . . The update was different as it was not ‘inline’/automated, instead it launched the installer and I had to click on Next etc.

The good news is that the update completed successfully, no Z117 error (despite being on my home network which has a firewall that scans web content). As a bonus the ReCaptcha related error in the login screen is now gone. Thank you Zwift team :slightly_smiling_face:

1 Like

Great to hear things are working well again for you @James_ames_SGMums

Everyone: the self-updating process should work fine if you say “yes” at all the steps and give it a few minutes to do its thing.

However - if you’re having issues - you can brute-force a complete uninstall / reinstall. Be sure to save your personal best and custom workout files before you do this, though. Step by step instructions are on our Support Hub

Update 1.20 removed the z117 Line 601 error - Great!!

Update 1.21 has now started giving z117 Line 602 error. Ive not been able to update or load Zwift since Wednesday 12th Jan. Luckily I managed to ride the planned TdZ Stage 1 Short route and found the error after I finished.

Now really getting annoyed that there is no solution that works to remove this new error and caused me to miss TdZ Stage 2 long route on Friday 14th Jan (Not too unhappy I missed AdZ climb :stuck_out_tongue:

Brought my laptop into the office and the game updated straight away. Game will not update at home.

As others have noted Zwift support need to investigate a possible issue with Vodafone. Vodafone supply my broadband (via 4G) and mobile phone service.

Problem solved - one year old Lenovo thinkpad laptop, windows 10, all fully updated (except update to windows 11). Tried all the deleting, reloading, rebooting, etc. suggested above, but Z117 error kept happening. I disconnected computer from wifi and ethernet connections. Connected the computer to cellphone hotspot wifi (Samsung S8, verizon) and it updated and started. Had never done that on the phone, took a minute to figure out the hotspot connection, but it was simple. Zwift runs now. Update upon restart took 5-ish minutes. Closing and restarting, Zwift starts up without further software update. Seems like I lost the four “your best” data entries, but all badges and garage/dropshop info related to my userid seems to be retained. Thanks for the suggestions above to do so, hope this helps someone else.

Nothing to add (more of a vent), other than experiencing the same ERROR #Z117, FILE “Patcher.cpp”, LINE 602. Lurking here, but multiple reinstalls…same error as others. Worked on the 17th, then ran a update before yesterday’s workout…everything went very wrong. Dedicated Windows machine (win10 /upgraded to 11 a few months ago). No AV, no file sync full admin rights, and the logs all are successfully written to Documents/zwift directory. (so no issues accessing documents directory. Have tried copying content from download\zwift to the x86 directory w/ no success. Chat never picked up after a 20 min wait, and cust support emails unhelpful. Is there an alternative download mechanism? Meanwhile, I’ll keep lurking…hopefully somebody can find a solution or an update is provided by Zwift.

1 Like

FWIW, just received the following communication from support. Not sure if boilerplate, but hoping resolution is soon.

*At this time this is a known issue with Zwift. Our team is working on a fix. While there isn’t a work-around for this issue as of yet, the fix will come from our end and all you should have to do is keep your Zwift app up to date. If you are able to use a different supported device while we are working on a fix that would be great. To see our supported devices you can visit our Support Site here . This issue is only affecting PCs and Macs at this time so if you have a supported tablet or mobile device that would be ideal. While I know this isn’t what you wanted to hear, I can assure you our team is working on getting this resolved so you can get riding again how you usually do.
We appreciate your patience and understanding as we continue improving Zwift. Please let us know if there’s anything else that you need assistance with; we’d all be more than happy to help!

Thanks.
Erin R.

fingers crossed.