IOS issues (freeze and crash)

Hello!

I am been a regular user of Zwift (PC version) since August. I never had any issue with the PC app (short of some slight display issues which appear to be well known).

I installed the brand new IOS app yesterday. My first ride was impeccable. No issues whatsoever. However, today, “all hell broke loose” during my ride from 10:15 AM to 10:40 AM EST.

I am using a iPad Air 2 with 64GB of RAM.

It started with Zwift freezing intermittently. Then, I became alone on the road. The communication with my Tacx Neo and Wahoo Tickr HR monitor kept working fine. Eventually, the screen froze for good. I then killed the app and could not open the app again (it kept crashing). I killed all the apps with the same result.

I rebooted and now it starts, pairs fine and asks me if I want to resume my previous activity. No matter what I answer, it does not respond to the feedback. My only option is the kill the app (and get to the same point again).

Correction… I just tried another time (the 10th time maybe) and I was successfully able to answer “no” and get back in the app. It is 11:07 AM in case this is server related. It now looks like it is working fine.

Internet connection is up and running with a latency to the nearest SpeedSmart (IOS Internet speed app) hub of 12 Ms, downloading at 226Mbps and uploading at 33.

Thank you!

Fred

Of course… I meant 64GB of storage, not RAM.

Fred

Same issue here, freezing, Kurt  kinetic smart control trainer, iPad Pro.

Same issue here.  KICKR, iPhone 6s.  Closed all apps and restarted the phone.  The issue continued after the reboot.  I was asked about restarting the previous ride but it would not accept a selection.  I had to keep force quitting the app and was finally able to start a ride but it lost my previous 2.6miles.  I’ve also found some of the setting menus to be very slow to respond.  Sometimes it would be a 20 sec. lag after clicking ok.  Hopefully these are just iOS first release bugs.

Still having the same issues, even after the latest update. Crashes unexpectedly, doesn’t upload ride or partial ride to Strava.  IPad Pro, Kurt  kinetic smart control Trainer. 

 Also, there seem to be more graphical issues then with the previous version . 

Had the same experience while doing a group ride.  All of a sudden the audio stopped working and I was the sole rider on Watopia.  When I tried to stop the ride, the screen froze.  Tried several times and eventually was asked if I wanted to continue the ride.  Said yes, and eventually other riders re-appeared.  Lost about 15 miles of the ride.

Was using iOS for iPhone 6S.  Usually very reliable and strong WiFi signal.  Have used the iOS app four times, with only one occurrence of instability.

My app seems to be crashing almost everytime. I’ve only had one or two occurrences when the app didn’t crash. I was always able to restart it from when it crashed, but it often meant that I couldn’t finish a group ride. I’m thinking about going back to the PC until the crashing issue is resolved.

Glad I’m not alone. I have just sent a mail to the Zwift support folks. 

 

Both myself and the girlfriend have had the iOS app crash on us during a long ride. Today it happened to me whilst doing the KISS 100 ride about 1h45 in. Had noticed some graphical glitches starting to appear such as trees not being fully rendered or white polygon type holes in the tarmac. I was riding along merrily and then suddenly everything froze and I got dumped out of the app back to my home screen. Took three attempts to restart the app (it kept crashing) and it then let me resume back where it had crashed. However, I was no longer in the race and no longer had the distance to go details displayed. I could have continued but it had killed my mojo in the 5 minutes it took me to reload it and I quit. 

 

My girlfriend is better at spending significant time on the turbo than I am and she has had two rides crash on her - she wasn’t in a race but was a couple of hours in. One time she could resume, the other she couldn’t. 

 

I have an iPhone 6plus and she has the normal 6. The trainer is a Tacx Neo and we are on a reasonably good broadband setup. I was thinking this was a wifi drop out issue but as I understand it, if my wifi were to drop I could still carry on with the ride it is just that everyone else would disappear and I would be alone in the world until it came back online. This isn’t what happened - it just crashed.

 

Is there an issue with the iPhone itself overheating during prolonged periods? I am guessing that the graphics of the game tax the iPhone quite heavily? From reading around it would appear that I should get a caution message to let me know the phone is overheating, but I haven’t had that. 

 

Seems as though I am not the only one experiencing difficulties though? I was running things through my Macbook air but went to the iOS platform as my air is 5 years old and the game actually looks better on the iPhone. I haven’t done anything above an hour on the macbook so can’t say if it is any more stable. It would appear that plenty of others are having this issue with iOS though. 

All my issues seem to have gone (touch wood). I’ve updated to the latest Ios system and did a hard reboot, and since then all my rides have been ok. hopefully it is going to stay that way.

Me too. iPad Air2 128 Gb running iOS 10.2. I can log in to Zwift and begin a workout, then within a couple minutes, the Zwift app freezes and I can’t do anything with the screen. I have to exit the app via the home button and sweeping the app up, if you know what I mean.

I have another iPad, an iPad mini, that was working flawlessly with Zwift. I don’t know if there is a hardware difference that is causing the crashes.

I have the same issue with the app on Iphone 7 iOS 10.2. Both times it happened 30 min into the workout. The first time I had to reset the iphone (home and off simultaneously) and the second time it did allow me to reset it via the home button as Dave. 

When re-opening the app, It did allow me to restart the ride where I left it but it did not allow me to go back to the Zwift FTP workout I was doing. 

edit: iphone 7 also gets really hot when running the app (> 20 min) 

Same problem using new iPad Pro. Was working perfectly for 4 weeks and has suddenly stopped, can’t even log on before screen freezes. Noticed it getting slow to load background buildings and shrubbery first and the next day, can’t use at all. This is very frustrating.

Same problem with the iOS app here, but only after the last update (iPhone 5s). 4 starts, 4 crashes. Before the update, there were no problems at all.

same issue with app crashes after the volcano update

tonight for the first time i was able to get the app to react i choose resume ride.

lost all ftp test data

latest ios, iphone 6plus. connected to apple tv to airplay mirror to my tv

really frustrating, not a happy zwifter at the moment.

from this thread i gather there is a real issue here, with no solid feedback from zwift

… and again: app crashed during a group ride. My iphone is connected to an external monitor via Apple HDMI-Kabel. First the monitor shows a black screen, but the app runs on. Trying to reconnect, it suddenly shows the login screen. I was able to resume the ride, but without the group. I found both rides on “My Zwift”, but could only upload one to Strava, because Strava tells me, that both rides are identically.

… same issue yesterday: app crashes in a group ride but I could upload the partial data to Strava. Restarted the app, started a new ride. My summary after the volcano update: 8 rides, 6 rides crashed, 2 rides without issues.

I submitted my logs to zwift support yesterday, they replied to say, sorry the volcano expansion was shipped with a bug (clearly) update app, and it should be ready to go.
I will give it a bash in the morning to see if it’s sorted

I have had exactly the same issue, when strava won’t let you enter the supposed duplicate file, I enter the second ride manually. Not ideal. I have had the last 3 sessions crash and it’s annoying. If it’s not resolved I will be using Zwift less or maybe not at all!

I am using an IPad Pro.  Zwift is crashing for me.  Partial ride logged on Zwift but .fit files will not manually load to Strava.  Reading through thread it appears this issue started with the Volcano expansion.  Hopefully Zwift will respond with a “known problem” statement soon and a bug fix.  Great product and bug fixes are a given. Hopefully a solution will be found soon.