iOS Companion app 3.29.0 (1158) issues [SOLVED]

@shooj , both my Apple iPhone on 15.1 and iOS on 15.1 have same experience. I’m using iMac 24” M1 … For part of my ride today I was on 14.8 and no issue . Any suggestions on how I am supposed to lead a ride tomorrow with no version of companion working. I don’t use Mac as we talk to text.


Sara Lance


Same issue as above, ZCA won’t connect to in-game mode on either iPad or iPhone.
Have deleted and reinstalled app on both devices but still no luck. Will keep eye out for resolution

Noticed a different issue yesterday & tonight. Yesterday I chose the Tick Tock route and tonight Tempus Fugit. When i set off on both rides, my avatar instantly carried out a u-turn??? Thankfully tonight I was able to carry out a u-turn via CA on iPhone, which it wasnt doing yesterday, and the rest of the ride carried on via the selected route. Anyone else notice this u-turn?

Win10 PC for Zwift
iPad Pro 15.0.2 for ZC
Garmin HRM
Wahoo Kickr bike
I have also tried using my iPhone XR 15.0.2. No joy.
All worked fine until a couple of days ago.

Was doing same for me to and then come Saturday morning I uninstall zc and then it went totally doolally and the app icon image got stuck like this see image on my iPad homepage it doesn’t appear in my list of apps and you delete it and restart the iPad only to discover it has reappeared on restart and when u go in the App Store it just appears as if it’s still downloaded but doesn’t Let u open it

Ben that looks like the app is failing to download from the App Store.

Any updates from Zwift devs on this? frustrating issue and as paying subscribers we would hope for a bit more feedback and a fix or at the very least an ETA on one, by now?


Different problem to most on here, but also an issue that has only starting occurring since the update to 3.29.

Companion app starts on iPhone, but most of the time it just gets stuck on the light blue screen with the “Z” logo and never proceeds to the main menu. Have even left it for 15 minutes and it did not move from that screen. Have force quit the app and tried again a number of times and maybe one in every five attempts it will eventually load, but most of the time it still stays on the blue screen.

I even shut down my iPhone completely and the app still stalled the first time I opened it, but was okay the second time. I am on quite an old version of iOS (12.5 I think, that’s the latest my phone will support), but according to the App Store, the Companion app does support this version.

The frozen blue screen and the white screen have both affected me on both phone and iPad , along side the map/workout page disappearing but it’s far more random for me and I can’t reproduce on demand unlike the map issue.
It’s my hope that when they fix the map/workout/chat etc it’ll also fix the blue/white screen issues.

Not sure zwift have actually managed to pin the issues down yet, probably more resources being thrown at Neokyo at the moment.

i’m honestly amazed that Zwift has not backed down to the previous version while they figure this out.


I agree this is a serious issue that impacts many. Do we get credit for a semi functional system?


Can’t even uninstall from my iPad and the App Store is stuck like this

And u tap open but nothing happens

Yes, Zwift please revert to the older version until you figure this out.


I’ve now got the companion app working all I did was run the iPad backup to the latest backup back on the 5th Jan 2021 and wotever was causing the glitch was gone, as for the ongoing issue everyone else is suffering with I’ll see if it works or not on Wednesday evening.

1 Like

My companion app worked after I moved my trainer from the garage and put it in my office hooking it up to the PC via Ant+
Shouldn’t have to go to such lengths though, hopefully they fix the app asap. The bonus I got was that the graphics looked great on a big screen TV from the PC compared to a 22 inch monitor and Apple TV I normally use in the garage.

There have been a lot of bugs in the latest releases. I have run into the no u-turn, and wahoo power reversed and companion app.

Great that this forum is where you can come up with suggestions for changes and so on!
Unfortunately, it gets a little strange that you pay premium for a program that contains so many old bugs that are never fixed plus all the new ones that are added with each update!
Then I think it’s a little strange that it’s paying customers who do the beta testing!

1 Like

They failed regression and user testing on the companion app!

1 Like

Same for me since ipad OS15 update!! I’m still running 14 on my iphone, ands companion runs perfectly…It has to be OS 15!! If you find the answer, please let me know…

1 Like

Shouldn’t have to restore the prior version from an iOS backup to get the application to work. I don’t think that it’s an iOS 15 issue, as I was running the companion app fine on multipe iOS devices 'til its most recent update. I realize that software development for multiple platforms and different OS version is hard. As an interim solution, I’m now using an inexpensive Samsung Galaxy tablet running Android. I do miss the clarity and resolution of my iPad, though.