iOS Companion app 3.29.0 (1158) issues [SOLVED]

Same. Sometimes I glimpse the map before it disappears. Since the last update. Apple TV for Zwift & the Companion App on an iPad.

1 Like

Same here. Apple tv will not pair with companion. Driving me nuts! Only started a couple of days ago. I cannot monitor my speedometer etc when doing a workout. Come on Zwift, fix it!!!

Same here.

Same here

Pc + ipad (companion)

Exactly the same issue for me.

Zwift support indicated they are aware of the issue, but have no timeline for a fix.

They suggested using iPhone instead of iPad. If needed, delete the app from the phone and reinstall.

It works, but now I’m all squinty eyed from trying to follow the chat on a tiny screen :laughing:

What works for me: Zwift App on the iPad or the apple TV. Zwift App on the Apple TV plus companion App in iPhone. I can channel the controls through companion App on iPhone.
What doesn’t work: Zwift App on Apple TV and the companion is on iPad (M1 version).

Agree that the chat on the iPhone is a bit small for an old guy like me. Also agree that it would be nice to have a native companion app for iPad.

1 Like

Same here… Zwift running on an iPhone and Companion running on an iPad… both have just been updated to IOS 15.1…. Coincidence or the root cause???

My iPhone does exactly the same, so can’t even use that.

Both devices were ok on 15.1, it seems to be the CA update that’s died.


Same with me.

1 Like

After many many months of trouble-free operation my companion app suddenly can’t connect to an active ride. When I start a ride it switches over and starts to display the map and then bounces back to the non-ride mode. Both my iPad and my Apple TV are on the same Wi-Fi network and there are no other instances of Zwift running anywhere on the network.


Happened to me on the WEDU Wednesday ride on my Android Companion App while riding on PC.

Ride was active but ZCA was in a non-connected state and all text messaging never reached Zwift. It was weird as it never happened before and after that. Not really sure what asteroid hit my ZCA that day.

I run zwift through my AppleTV box and like to run the sensors through another device using companion to allow real cadence meter. I can run sensors through companion app on iPhone (same iOS version), but not iPad Pro (M1). Curiously will sometimes see the sensors on Zwift, but tell me there is no signal.
This only started in the last week. Main Zwift app is fine on the same iPad. Have rebooted the AppleTV and the iPad as well as turned the pair through companion on and off. Small issue, but mildly annoying. Has anyone else seen this?

1 Like

Maybe easier to start with what actually works 100%. Can only get on the actual payment part. :joy:


@shooj , both my Apple iPhone on 15.1 and iOS on 15.1 have same experience. I’m using iMac 24” M1 … For part of my ride today I was on 14.8 and no issue . Any suggestions on how I am supposed to lead a ride tomorrow with no version of companion working. I don’t use Mac as we talk to text.


Sara Lance


Same issue as above, ZCA won’t connect to in-game mode on either iPad or iPhone.
Have deleted and reinstalled app on both devices but still no luck. Will keep eye out for resolution

Noticed a different issue yesterday & tonight. Yesterday I chose the Tick Tock route and tonight Tempus Fugit. When i set off on both rides, my avatar instantly carried out a u-turn??? Thankfully tonight I was able to carry out a u-turn via CA on iPhone, which it wasnt doing yesterday, and the rest of the ride carried on via the selected route. Anyone else notice this u-turn?

Win10 PC for Zwift
iPad Pro 15.0.2 for ZC
Garmin HRM
Wahoo Kickr bike
I have also tried using my iPhone XR 15.0.2. No joy.
All worked fine until a couple of days ago.

Was doing same for me to and then come Saturday morning I uninstall zc and then it went totally doolally and the app icon image got stuck like this see image on my iPad homepage it doesn’t appear in my list of apps and you delete it and restart the iPad only to discover it has reappeared on restart and when u go in the App Store it just appears as if it’s still downloaded but doesn’t Let u open it

Ben that looks like the app is failing to download from the App Store.