Incorrect Dashboard Language

When I open the Spring Training dashboard from the companion app most of the text is in German. Running CA on iPhone 14, iOS version 17.4.1 and language set the English.

When you log onto Zwift.com, which country does it think you’re from? The website tends to put me in Canada…frequently. Even though I live in the US and have never selected CA. I’m wondering if maybe something similar is happening to you, where your account is being tagged as German for whatever mysterious reason.

United Kingdom

Ah well. I got nothing for you then, sorry :slight_smile: :confused:

@Kev_Lewis Perhaps it’s a sign. Have you ever heard of Duo Lingo?? :joy::rofl:

1 Like

I took German for a year at school. Unfortunately none of it was on cycling or computer game bugs :wink:

1 Like

I currently get EU, and have seen UK many times, despite being in the US (no VPN either). Never bothered to mention it since I get the correct language.

I think they set me to Canadian because of my well-documented love of flannel.

1 Like

Hi @Kev_Lewis,
My name is Fernanda, I’m part of the support specialist team at Zwift. Thank you for using this space to bring this issue to our attention!

Can I kindly ask you to please check the language in the Zwift game, not in your profile directly? This can make a change in the Companion App, to do this, I will ask you to please go to the Settings in-game, and the language preferences.

Also, in the Zwift companion App, I will kindly ask you to please force closing the Zwift Companion following these steps on the iOS device, and perform a reinstall of the Companion App. This will delete any malformed files affecting the dashboard.

If the issue persists, don’t hesitate and please use the Contact Us link on Support.Zwift.com. We are happy to help!

1 Like

Hi Fernanda,
Many thanks for the reply. I have the language in game set to English. But uninstalling and reinstalling the companion app fixed the problem.

2 Likes