HUD-enabled screenshots blank since 1.31 update [November 2022]

Since the game update for Urukazi, all in-game screenshots are broken for me on MacOS - at the point of upload, they just appear blank white, and even the empty white images are not associated with my activity or Strava feed. This screenshot (taken with the MacOS native functionality) shows the issue:

I am using a late 2014 iMac 27 inch retina display, which has an AMD Radeon R9 M290X graphics processor with 2GB memory. It’s running Big Sur.

I am/was having other issue with screenshots—the game has started taking them automatically, though I have it disabled in settings. Using a Win10 PC. First noticed it after the previous LOUD update. Thought this morning it would be fixed along with sound levels in newest update, but not to be.


This issue around screenshots is known about and being worked on.

1 Like

You can “unveil” the screenshot by clicking the green graph icon.

BTW. There are also other issues. Zwift crashes when over 20 screenshots are taken during a ride which is being investigated by the Zwift developers.

1 Like

Thanks for the partial workaround - that does work, although you lose the overlay data, and indeed, with the number of automatic screenshots Zwift is currently taking it can be hard to find the ones you want to keep.

Biggest issue for me is that screenshots of the final coloured graph of zone power over the ride are not included in the collection of images at all, which is strange. Hope we can get a fix for these things soon.

I’m finding that the game is now taking screenshots when it never used to and i haven’t changed any settings, has the update forced a setting change to take pics? mine is set to upload only my shots but with 3 rides this evening around urujazi it has taken screenshots of pr times and route completion without me doing it or wanting it to do this

Known issue: Screenshot upload preferences ignored [November 2022]

1 Like

I had the same issue and investigated the files (I’m on MacOS, too).
I usually do my screenshots using the companion app on iOS.
After itting the screenshot button Zwift is doing the “screenshot flicker” - but there is none - neither in Zwift nor in the Camera Roll of the iPhone.

If you have a look at the screenshots folder (usually ~username/Pictures/Zwift) youl’ll find out that there a always two files per screenshot. The normal one an a “clean” one without the HUD information.
The “clean” one is fine. The normal one is broken and has a size of 0kb.

This is the reason why they don’t appear within the save-box. Normally Zwift shows the files with HUD information - which can’t be read 'cause they are broken (–> “white” picture). You can change from HUD to non HUD by klicking the pic - this is the way to choose if you want to upload HUD or not. As the non HUD grpahics has been stored correctly that file can be shown.

I was able to fix that problem.
I’ve used the screenshot function of Zwift itself (F-10 key) instead of the companion.
Don’t aks me why - but that worked fine. The screenshot was saved correctly.
Since I did one (!) F10-Screenshot the companion app is working finde again, too.

1 Like

Now that IS weird; I’ll give it a try tomorrow and report back whether it works for me too.

@Phi_Zirker i tried this, but unfortunately it didn’t work for me. The F10 screenshot was no better, and it didn’t help subsequent ones taken with Companion either :frowning:

You’ve written that you’ve used the F10 function and it did not work (I overlooked that in your first post). So my “do a F-10 screenshot” couldn’t be the solution here. I did some more screenshots during my ride today - broken files.
Solution: It’s not working in FULLSCREEN! It’s working, as soon you switch to windowed mode. This is where I did my tests to have a immediate loook at the picture folder in Finder. Today I was riding fullscreen and was wondering why it wasn’t working (anymore).

To make things more tricky: First I resized the Zwift window to nearly the complete screen - broken files. As soon I resized it to about 2/3 of my MBPs Retina display the files went ok.

I suggest doing some tests: Start at about 50% of your screen, do a screenshot. If it’s ok: choose a larger size. Repeat until you receive the 0kb files and go one step back so you can ride with the largest working size.

I’ll report that bug to Zwift.

1 Like

That is exactly the same issue here (5k-iMac late 2015). The issue doesn’t depend on the way the screenshot is taken (Companion app, F10 or by menu). It only depends on the window size: as long as the Zwift app window is less than approx. 2/3 of the screen, the screenshots are saved well. If the window is above that limit or in full screen mode, the issue occurs.
Example: first picture taken after starting the app in window mode, then switching to fullscreen and taken the second picture:


Here’s the bug report I sent via eMail a few seconds ago. I keep you updated.

Hi Zwift support!

I thought I had solved the screenshot issue I reported this week. I didn’t.

But I did some more investigations to send you the following bug report (I don’t think there’s a solution without an patch/update as another user has the same problem, so please don’t ask me to reinstall, see Screenshots broken since Urukazi update :wink:)

Zwift : v1.31.1

Plattform: MacOS Big Sur (11.7.1)

Hardware: MacBook Pro 2019, Retina

Chosen resolution: “ultra”


If you do a screenshot (F-10 or with the companion app) in fullscreen mode, the file containing the overlays is broken (0kb in size).

The “_clean” file is ok.

This can be reproduced for 100% of the screenshots (I didn’t do tests with game resolutions set <”ultra”).

If you are running Zwift in a window, there’s a different behavior:

If you set the size of the window to nearly 100% of the screen the screenshot is broken, too.

As soon you decrease the size to about 70-80% of the screen the files are generated correctly.

Could you please investigate (and confirm) that issue and offer a fix?

Oh, and please fix the “20 screenshots will crash Zwift on MacOS”, too, which has reported in the forums several times – I can confirm that bug, too…

Thank you!


That fits - I’ve been running the app in full screen mode.

Hello all,

This seems to be a new bug affecting Zwifters on Mac devices with AMD graphics cards. I’ve reported this to our engineers to develop a fix. Big thanks to @Phi_Zirker for helping narrow down the issue.


Wow. Good detective work!

I can confirm that I too have the same issue with “white screenshots”.
I’m on an iMac 5K with an AMD Radeon graphics card.