Heart beat not showing on shwift


(Serge Perron) #1

Good day

  lately, I have issue with heart beat  showing on screen of swift when I trained. My heart belt is connected but pulse is not showing. I have to connect/  disconnect 2 to 3 time to get work. It work fine on my Garmin device but showing on screen of   Swift. What should I do to get it work the first time? Thanks

 

    Serge


(Paul Graham) #2

Can you provide a little more info on your hardware Serge, that is, computer/tablet/phone/ANT+ dongle and/or Bluetooth?

How old is your HR device and belt?


(Serge Perron) #3

Good morning

 

   My heart beat belt is brand new, it’s a garmin. I use and iPad Air 2 with a ant + antenna. 

 

               Serge


(Steve Copeland) #4

You may not be wet enough to get it broadcasting. I use aloa Vera gel on mine which creates the required electrical contact until I start sweating. 


(Serge Perron) #5

The heart beat is showing very well on my garmin device. It shows pair with my heart belt on swift apps but the heart beat is showing dash line while I ride with swift. The only to get it work is to stop the swift apps from running and start again. After a couple times, I got it work. Annoying after a while. 

                 Serge


(Steve Copeland) #6

Ah, that’s possibly  because the HRM is not latching to Zwift. If you are viewing it with another app it stays locked to the app for ages. I get this with mine when I get too close to my treadmill before it locks to Zwift. I have to turn the treadmill off to get it to release the HRM so it will lock to Zwift. 


(Serge Perron) #7

Ok, thanks for the info, I will try that. 

 

     Serge


(Serge Perron) #8

(M Troutd0g) #9

Make sure your HR monitor is not paired with another app on your iPad.  I had that issue as well and the problem was it was auto-pairing with Wahoo Fitness App when I ran the spindown calibration.  To fix this, I make sure to close and exit the other app before starting up Zwift.  Just closing an app does not cause it to exit on iPad/iPhone.  It keeps it running in the background.  You need to exit the app after closing it.  This solved the problem completely for me.