Having issues with not joining the Robo Pacer? [May 2023] [SOLVED 1.42]

Zwiftizer? Never heard of it. Sounds like another piece of software. Not doing it. Zwift should be able to analyze there own stuff without using paying customers as Guinea pigs for its “fixes”.

Took me 7 attempts to finally join Bernie in Makuri. When I joined I was the only rider with her. Usually there are many, so looks like others gave up trying. I have had this issue several times over the past few days on 1.41. Apple TV user.


I feel your pain

Unfortunately, Zwift is nearly all software, that tries to operate on a variety of platforms, and there will be bugs. Even in the commercial space, there are bugs, and often consumers are asked to run diagnostic software to help the vendor pinpoint issues. I totally get not wanting to be part of such an ecosystem, and letting your money do the talking. A vendor that controls both hardware and software, like Peloton, might be a more stable platform. Alternatively, you can put your subscription on pause while they sort this feature out.

The recent instability in joining pacer rides is irritating, but I can always go on a solo ride if I can’t join a pacer.

I did that and perhaps will have another try in a few months time and keep an eye out on this forum. In the mean time I moved my rides outside and also will try various other platforms to compare with Zwift.

I just want to know if Zwift is aware of the issue and workin on a fix…

It’s fixed in 1.42, I was having issues on 1.41 but none on multiple occasions with 1.42.

1 Like

Despite my repeated attempts to locate Jacques on the map, I was unable to find him, so I ultimately decided to ride with Yumi. Could this be a glitch? :face_with_diagonal_mouth:

Yes, it should be fixed over the next couple of days with release 1.42.


My wife has started Miguel 2-3 times on each of the 2 routes and doesn’t join pace partner . . .

This has now happened a few times :frowning: So frustrating

As above it’ll be fixed with the update

1 Like

Thanks @Michael calfzilla and @James_Zwift !!

I checked and I had 1.41 on my AppleTv and have just updated to 1.42 (released yesterday in the App Store) and I’ll give a try in the morning…

At least Coco has been on Volcano Loop this week, so if I drop in away from the pack, I don’t have to wait long for them to show up :slight_smile:

As James notes - this issue has been resolved in Zwift version 1.42. We’re doing a a phased rollout over the next two days - please update when when it’s available to your device.


Since the last update, it’s difficult, at best, to join a pacer. Can this “feature” get fixed??!!

This is similar to issues that have been reported previously, but after doing a group ride with Maria, I decided to switch down to Miguel, and he disappeared after only a 1-2 seconds, along with all the other riders that were supposed to be riding with him.

This is HIGHLY frustrating as every time I tried to restart the ride, I needed to go through the bluetooth device connection process, which - for me, at least - is always a slow and time-consuming process.

If by ‘pace bots,’ you mean the roboPacers, I’m running into the same issue. I was able to join a ride with Maria, but Miguel and Bernie kept disappearing after only 1-2 seconds whenever I tried to join their rides.

I’m on a Android device if that matters (Samsung Galaxy Tab A8)

It’s been covered many times in other threads.

This has been fixed in the latest update which you will be receiving imminently.

1 Like

I’ve answered in your other post but to make it easier…

This has been fixed in the latest update which is rolling out as i type.

Are there 2 separate issues? Sounds like:

  1. Trying to join RPs one is dropped nowhere near the RP and the group following the RP. Vs.
  2. Successfully join the RP and group, but then they seem to turn invisible and vanish within a few seconds.