Having big trouble with Apple TV 4G remote in Zwift App


(TC Cronin) #1

Just got Apple TV 4K to use with Zwift, but the app doesn’t seem to receive input from the Apple remote.

The problem is that I can’t seem to scroll around the screen options, as I can when I use the Apple TV with other apps outside of Zwift.

Every once in a while a command gets through, which has allowed me to log in. But now, for instance, I have paired with my Kickr and want to ride, but the app is frozen on the option to enter a heart rate monitor. That option is flashing on the screen, but I can’t get off of that option to scroll down to ‘Let’s Go’, no matter what I push on the Apple TV remote.

Any suggestions?

Tom


(Steve Copeland) #2

Its an acquired art. Took me ages to master it having experience the same problem.  My advice is persevere. 


(John Merle) #3

I’m having the same issue. Remote works with other app but not Zwift on ATV.


(Rob LETTiERI) #4

I have AppleTV version for in the exact same problem very frustrating and waited about two hours trying to upload a work out after resetting AppleTV and uninstalling the app and reinstalling it the remote simply would not communicate properly by the toggle touch


(TC Cronin) #5

I did some adjustments to the controls on the Apple TV, like setting the responsiveness to ‘High’. This didn’t immediately seem to help (at all), but then miraculously a day or so later the remote started to work fine. Spent a lot of time trouble-shooting, but then somehow things came together. Good luck.


(James Oehlcke) #6

I am having this issue as well. For example I can’t scroll down the list of rides, on the LHS of the screen. Must be a Zwift issue, as the remote works fine on other applications.


(Mike Kearney) #7

I am having the same problem. The remote works fine with all other apps but can’t scroll in Zwift app.   I’ve reinstalled Zwift and rebooted several times but remote scrolling function does not work in Zwift after two weeks with no issues.


(Ian Brewer) #8

Anyone have an issue with the Remote app on your phone not working?

I was thinking about unpairing the ATV Remote so I could use that connection for Trainer, HR & Cadence sensor & use the app instead but it only works when it feels like it.


(Stephen Eddleman) #9

I hate using the remote but I really like the apple TV zwift app, all but the parts that need the remote control.  I almost threw the remote at one point trying to pick my ride.  I think they should make use of the + and -, and play button when on some screens to help us move around better.  The other thing that would help, and would help everyone, is to not make us select our course every time.  If I want to ride Jon’s short mix every morning, why do I have to spend 10 minuets trying to select it… how about the default ride be the last ride you did… and not always go back to “just ride”.  That would save me a couple of remotes… over the summer and I can get 10 more minutes of sleep.


(Stephen Eddleman) #10

I hope people at zwift are reading these messages, how else can they feel our pain?


(Jim Emory) #11

Same problem for me. Apple TV remote (including the app version) no longer functions.  


(Travis Kubicek (C)) #12

With the ATV remote issues Zwift is almost completely unusable. Frustrating that Zwift isn’t comment on this thread…


(Steve Copeland) #13

It works fine for me…  it is an acquired art though!


(Travis Kubicek (C)) #14

Steve, are you able to access workouts and training plans with the remote? I tried for 30 minutes with no luck. 


(Steve Copeland) #15

Yes, but it requires careful swiping. It’s not very intuitive but it does work. 


(Stephen Hinde (BC)) #16

This is still a problem.  I’ve set the ATV remote sensitivity to ‘high’ which has helped somewhat, but now it sometimes flips past the selection I want.  It is very difficult to select the power boost circle, and I am unable to select riders from the list to provide kudos.  So my work-around is to use 2 remotes–the ATV to get into the Zwift ride of my choice, and iOS remote for other functions.  And yes, this is distracting, so yesterday I had my wife sit beside me to operate the iOS on my command!  (Huge cost for that service–I’ll send the bill to Zwift, shall I? :slight_smile: )


(Andrew Ong) #17

My friend had this problem too. I, on the other hand, did not. We both have the same ATV 4G device. The first thing I noticed was his Voice Over feature was turned on. Every time he moves the cursor, ATV would say the word, letter, number or punctuation causing so much delay to move the cursor. His remote is working fine now in Zwift after I turned off the voice over feature.

Fix: Turn off Voice Over from Settings --> General --> Accessibility


(Andrew Ong) #18

Stephen, have you tried using the Zwift companion app? It is so much easier to send kudos or send commands to Zwift than the ATV remote.


(Stephen Eddleman) #19

You have to have an apple iphone to use the companion app.  Since I prefer Samsung phones (because they are better) that will not work for me.  The remote is just a poor tool, apple trying to be too fancy.  They seem to think more than 6 buttons is too much for people to understand.  They should learn the engineering expression “form follows function” and stop treating people like idiots.  


(Andrew Ong) #20

Zwift companion is already available for android devices.