Had issues this morning getting Zwift to recognize computrainer


(Jesse Sharp (C)) #1

This has never been an issue before.

I use a computrainer and a garmin ant+ heartrate strap. When I started the zwift program this morning, it downloaded the latest update. After the update logged in and landed on the Power/Speed screen. It found my computrainer and kept it connected but I noticed the computrainer go to “pro” mode for 1 sec then drop back to the roll-down mode. It would let me start on the island but I had no power (the computrainer was in the calibration/roll-down mode). I tried to reboot the computer, and restart the computrainer. You name it, I tried it. All with the same result. No power when I got to the island. Pretty bummed. Can you help me out?


(Craig Pate) #2

I’m having the same issue. One time I was able to get to the ride but even though I was pedaling, no watts and no other riders moving or stats changing…just sound.


(Jeff Abbott) #3

Yeah, I have been using the Computrainer for months now. Today was the first time I had an issue. I got to the Pairing screen. Clicked on Power. Selected my computrainer, then hit OK and Zwift froze and went into Not responding mode. I thought it was a fluke and I was going to try again tonight. But if others are having issues too, it must be the newest update. Log a ticket Jesse as yours is a little different issue than mine. After I try again tonight, if it still doesnt work, Ill log one too.


(Jon Mayfield) #4

Hey guys, I’ll look into this today. Thanks for reporting it. Computrainer code was changed a bit for the mac version, and one of the changes may have not sat well with the PC version. It tested fine here, but obviously something isn’t quite right.


(Craig Pate) #5

Thanks Jon,
I sent a couple other emails to support. I went to use my CT and now that doesn’t work on its own either. Just curious if the others using CT’s have the same issue. The timer doesn’t start in any of the RM1 applications.


(Jon Mayfield) #6

Yup, I just reproduced the issue here. There should be a small update later today that’ll fix this. Sorry for the inconvenience.


(Craig Pate) #7

OK…I’ll check in a bit later. If no one else chimes in, I’ll send you a thumbs up when I’m back riding. Thanks.


(Jeff Abbott) #8

My Computrainer still worked. I gave up after a few tries on Zwift and opened up Mutlirider and was able to use that without issue.


(Craig Pate) #9

Jeff,
I don’t have Mulitrider…do all your other apps work in RM1? PCV, Power Training, SS, etc.?


(Jon Mayfield) #10

Ok, the update is out. Computrainer should be good to go. Thanks for reporting it so quickly here.

Craig, maybe powerdown the computrainer and power it back up? Zwift doesn’t send any sort of commands to it that’d make it act strange in other applications.


(Craig Pate) #11

Jon,
Thanks…yes Zwift now works. But the CT still wasn’t.

The initial update this morning must have booted me out of the #1 position in the CT software. Once that happens it won’t recognize a rider ready for a training session of any kind. If anyone else is out there make sure you’re still in position #1 on the app staging screen in your RM1 setup.


(Craig Pate) #12

Jon,
I spoke too soon. Zwift is fine. All apps in CT (Racermate1) except for the Real Course Video work. So there still must be one glitch somewhere just for that application. I double checked all my settings, the video just won’t load after the preview box and you hit START. It goes to a black screen instead of the overall route map that then slowly fades away to the video.


(Craig Pate) #13

Jon,
Just to clarify that last line… the video just won’t load after the preview box. You should hit start at it would normally go to the overall route map that then slowly fade away to the video (real course video). Instead after you hit start, it goes to a black screen with your data below. Timer never starts.


(Jon Mayfield) #14

Interesting. I don’t really know anything about the computrainer video software as I’ve not used it. As a reminder, only one piece of software can talk to the CT at once, so make sure you dont have anything else open. If all else fails maybe shoot computrainer an email to see if this is a known issue with their software.


(Anthony Cree (STC)) #15

I had the same issue Jeff describes last night. 3 or 4 instances of Zwift locking up and not responding, each requiring the program be killed from task manager in order to continue. Never did get Zwift to work last night.

Also, after pairing, the CT would be identified for power, the garmin HR strap for HR, but speed or cadence from the CT were not identified.


(Jesse Sharp (C)) #16

This issues has been resolved. Thanks!


(Michael Brazel.pnw (B)) #17

Slight variation of the same problem, last experienced last night…

I DO have the updated (and required) USB to Stereo adapter for the Computrainer.
I DO NOT normally have problem pairing the Computrainer with Zwift.

The HR Chest strap I was using with the Computrainer died (Polar).
Rather than buy another Chest Strap that ONLY worked the Computrainer, I opted to add an ANT+ Dongle and use my Garmin HR Chest Strap.

When I pair Zwift with the Computrainer it defaults to the Computrainer HR Sensor as expected. No Problem.
In order to use my Garmin ANT+ HR Chest Strap instead, I have to ‘unpair’ the Computrainer HR Sensor.
At this time ALL paired Computrainer elements are unpaired, not just the HR Sensor.

This is when I pair the ANT+ Garmin HR Chest Strap with Zwift. No Problem.
When I go to pair the Computrainer at this point, Zwift DOES NOT recognize.

The ‘work around’ I have discovered is to unplug the Computrainer’s USB to Stereo adapter, and plug it back in. BOOM! Computrainer paired with Zwift and the Garmin ANT+ HR paired with Zwift.