Gradient of 1% suddenly feels like 5% on Direto

Acer laptop with Windows 10 64-bit

Following this thread with interest. I’m having the same problem with my Direto and it was NOT solved by the latest Zwift update.

Is it possible to get the version of Zwift before the last 2 updates? On IOS that would be version 1.0.28834.

I have had similar issues with my Direto which where - in my case - related to a miscalibration of the Direto. The Elite support highly recommended to tension the belt up to the exact offset value you can find on the sticker underneath the trainer.

You may double check the calibration and if needed tension the belt. The proper calibration solved my issues.

Cheers, Matz

Today I received this email from Elite:

Good Afternoon

The problem is not caused by the trainer or Elite but from how Zwift has implemented the standard Bluetooth FTMS protocol
So if they have made some mistake obviously the issue is not from our side but from them

Please refer directly to them

Hello people at Zwift. Any news, progress, activities, communication on this matter?

Had a first ride at NYC course and the problem is still there. Since this is a rolling course, staying with the group in the race was a real challenge.

Hi Vincent, any news or progress?

Guess not :confused::frowning:

My first ride of the NY course revealed this issue for me as well. Without changing the trainer difficulty, my climb up the alpe the previous day was infinitely easier than my first ride of NY. In NY I am now using gears that I had not even touched to climb up the 10-15% gradients in watopia. Funny thing is that trainer seems to be reacting a little quicker in relation to the terrain change, which is actually a good thing. The problem is that it seems to go from flat to climbing a wall. I’ll be playing with Bluetooth and firmware updates now that I know this is a known issue.

@Paul_Bryan @Peter_Castrop
Are you all still experiencing these resistance issues? We’ve made significant progress in resistance trouble with BLE connections as pointed out here:

1 Like

Hi Vincent,

Thank you for your message. I will try this tomorrow. Normally I would plug in my trainer and then open the Zwift app on the Ipad. I immediately get on my bike and pair the trainer and the hr. I normally do not walk out of range.

I will let you know if the problem still exists.


1 Like

Looking forward to get this fix going. I will be smashing everyone in races due to artificially increase resistance in past months. My point: my Direto is never out of reach. All devices are plugged and unplugged before and after each session…

Just found this Direto specific thread…have been posting on another

then tried the above suggestion to reset…

FYI ://

This is either something Zwift DID or Apple DID

Hi Vincent,

The update has not changed anything for me. I still have the same resistance issues.

Kind regards,


Well…I disconnected and then reconnected EVERYTHING…AGAIN… re calibrated my Directo after proper warm up…and adjusted the belt tension back to factory spec.6458… it had loosened 6 pts…in about 7-800 miles of riding.

The NEW UPDATED 1.0.31664 for my hardwired Imac loaded at start up and I did a test ride on Volcano loop…also used companion app on ipad pro as always…Realism set to 100% as always…
and it SEEMED to be acting “normal” again…

I need to ride NYC today and see if it is still good there…THAT is where the problems were 1st noticed and made my Direto unridable…


Well, Zwift seems to have no interest in solving this issue. They are busy unlocking socks and sunglasses.

I don’t think it is just Zwift as slope in PerfPro also causes unrealistic tension when slope goes above 1.75%. As soon as it has to load 2% or more slope. Calibration is spot on required by unit 6805, cal on Elite app 6803. I am stumped!

Hi Peter I had the exact same issue and tried everything (including re celebrating ) but nothing worked. I did notice a slight squeak when turning trainer on and when zwift gradient changed. I took off plastic cover on light sensor side and blew out any dust that may have been inside unit with my compressor and re greased threaded shaft with food grade grease (very thin grease). Problem solved I have been using it every day for weeks now without any problem. Hopefully your problem is similar.

Thanks Max. Great to hear your trainer works without problems now. Due to other issues Elite replaced my Direto. I have no issues with the new one.