Gradient % issues

I know my way round zwift and can usually resolve issues myself or help others…but I find myself scratching my head at this one.

Whenever I cycle in London and start to cycle out up tube section at the 15% escalator, I get to the top and the % incline changes to zero on screen, but the trainer resistance stays the same requiring the same effort until I pass over the bridge. It quickly eases off back to normal when the % incline changes at that point.

I run zwift on andriod and use a kickr core. I’m going to try it again tomorrow with my laptop to try eliminate this being an android glitch.

Has anyone else experienced this issue?


That’s odd, I’ve ridden up that escalator lots of times and never experienced that.

Hi G, I’m facing the same issue in London when the % gradient is going from 15% to 0%. Resistance does not change. I haven’t the courage to go until the bridge. However, it used to work.
I also run zwift on an android phone.
Do you resolve the issue?



Hi Mick…glad to hear Im not the only one with this issue…thought I was going mad. I havent tried recently so cant say if the recent updates have changed anything, but it only happed on andriod for me. I tested using my laptop and all was fine.

Strange behaviour and only at this particular location. It was working well until the 4 may for me. Android + Wahoo kickr v5. I will try on PC…