Gear sticks on 4

Thanks Paul, I’ve just been flicking through the forum and saw that this issue wasn’t listed as a known issue, glad it’s been highlighted now

I got my power/heart rate graph back by deleting and reinstalling Zwift on my iPad this morning if anyone else is having an issue with the toggle button for that not working.

Any updates from the dev team on this?

Still no news, I will get back in touch with them next week for an update

Apparently the new Zwift update has fixed the gears.

Has that fixed it for you? I’ve still got the issue…

My last app update showing 7th June and was relating to late joining issues…

Deleted Zwift app, rebooted iPad, downloaded Zwift again… Still got the gear4 issue.

No still not fixed , heard someone say they were. I’ve messaged Zwift for an update.

I was in conversation with them on the 4th June and there was still no sign of a solution at that time.

Going off how long this issue as been going on I’m not convinced that Zwift have put any sort of priority on finding a fix…

1 Like

Any update on the issue Zwift, you must have a change log file and know what you changed between new and old versions for the app to talk to the bike???

I messaged Zwift yesterday and they are still looking into it.

I just start the app start pedalling then Just flick
The power switch off on the Atom and turn it back on without pausing the app then it works fine, earlier I locked the tablet by accident and the fault returned then I just did the same turn Atom off then on without pausing Zwift then it was back working, it would appear to be a sequence of connection issue might have a BT priority in wrong order ? Fingers crossed it’s sorted soon, if it was through test flight I could send the crash logs

I don’t think there is any need to pedal as the reboot works fine for me by doing it before I climb on the bike, mainly as you can’t reach the power button once clipped in, plus doesn’t pedalling set the time off running?

I know the reboot needs to be done before every session, so if you close the Zwift app down you will need to reboot the bike again when you open it back up.

Most of my rides are done in ERG mode so this isn’t an issue most days, but I do a few races and social group rides and this issue is really bugging me now, The watts/HR/cadence/gear box (top left) isn’t there when you’re waiting to start a group event, this now only appears once the events start, so I’ve no idea if the reboot has worked until I’ve set off for those rides, and I’ve also got to best guess what gear I’m in when sat on the start line.

I’m getting bored of talking about this issue now.

1 Like

Yes, this has been going on too long. It’s clearly a bug in the app, and it’s very easy to replicate.

When we’re paying £12.99 per month, I’d expect the fix to be one of the team’s top priorities.

1 Like

Hi

I’ve had enough of the issues, so I’ve asked Zwift to freeze my subscription until the gear problem is fixed.

Just in case this is not a a Zwift issue…

Wattbike have just released a firmware update: 1 July 2019 - through the App Store. Download the updated App and then run with the bike and it will update.

Apparently it does the following:

The first major Wattbike Atom firmware update has arrived.
V1.02.00 (Atlas) makes changes to the Atom’s ergo and gear algorithms for an improved ride experience. Based on user feedback, and in our pursuit for continuous improvement, we’ve paid particular attention to resistance when using ride simulators such as Zwift. The update also improves sensor connectivity for Bluetooth and ANT+ heart rate monitors for easier pairing.
The core of this update has been tested by our beta user group, and feedback has been fed into the Atlas firmware.
To experience our latest firmware, just connect your Wattbike Atom to the Wattbike Hub and start a ‘Just Ride’ session. This will prompt the automatic update.
If you’re currently using the beta firmware you can continue to use this without updating if you wish; the new beta firmware has some further tweaks and fixes.

1 Like

Has this issue helped out with the Wattbike update?

Problem still here with firmware update - any news on this?

We have the Wattbike atom at HQ and are currently doing testing. We’ll update once we know more.

Edit: (July 15)
We have been able to reproduce the issue on this bike, and it has been bugged: ZG-6800

Next steps are to create a fix with the Dev team.

1 Like

UPDATE
I have some good news and some bad news.

Good News - our dev team was able to fix the issue.

Bad News - the fix won’t take effect until our next update.

As of right now, we do not currently have an ETA when the next update is released.

2 Likes

Doesn’t matter how long, it’s fixed woohoo :partying_face:

1 Like