Garmin speed and cadence sensor not reading data

Zwift picks up my speed and cadence sensors but doesn’t read any data from them. Using an iPhone 11 Pro. I’ve tried with a different iPhone and it seems to work. The first time I set it up with my iPhone 11 it worked now just doesn’t read anything

Iphone 11 Bluetooth sync seems to have some issues. As a friend also curses off it for same reasons. I think its the antenna on IPhone 12

Hi @George_Henderson welcome to Zwift forums.

Have you given the Zwift app permisssions to use the Bluetooth radio during the installation process?

Please double check under Settings.

Yeah tried absolutely everything just doesn’t work with iphone 11. Seems to be a bluetooth issue between the Garmin sensors and the iPhone 11. Works absolutely fine on my laptop through Bluetooth and also through iPhone 10 and iPad. Just and issue with my phone! :roll_eyes:


Hmmm. Doesn’t make sense because the iOS app is the same for iPad and iPhone. If it works on one but not the other, it’s something specific about one of your devices.

Did you check if the sensors might be connected directly to iOS? If so, the operating system is stealing the BLE signal before the Zwift app can grab it. Please check that too under your iOS Bluetooth settings. If they’re stored in there, please “forget” them.

Yeah I’ve forgotten them on my device. Deleted and re downloaded Zwift just seems so strange!