Garmin Connect sync not working anymore


(Claus) #1

I have been syncing my data to Strava and Garmin Connect for months without problems, but the last week or so, Garmin Connect does not get data anymore.

Rides are registered in Zwift and synced to Strava, only Connect is missing.

Anybody else had anything like that? Any ideas on how to resolve it?


Upload to garmin
(Kevin) #2

It is still working for me. I would try disconnect Garmin Connect and then reconnecting on Zwift.


(Gerald) #3

Hi,
I‘m having the same problem since last week. Everything works but GC doesn‘t


(Vincent) #4

Hey Gerald, have you tried disconnecting from Garmin Connect then reconnecting as Kevin suggested?


(Claus) #5

I disconnecting Garmin Connect from Zwift and then connected it again. Just did my first ride on Zwift after that - it still doesn’t upload to Garmin Connect.

When saving the ride, I have both the Strava and the Garmin logo, so the connection seems to be registered in Zwift and the Strava uploads work fine.


(victor) #6

are the devices you use up to date with firmware ? i had to update mine like last week or 2 weeks ago ish might have to do with that ?


(Claus) #7

The only device involved in these activities is my Wahoo Kickr Core and it is up-to-date.

Zwift is running on Mac OS, so automatically updated at each start.

I did another workout this morning, which didn’t upload to Connect. So I checked my stats. I had one workout on February 17, which failed. Then on the 19th it worked again, so I thought it was just a glitch. But every single Zwift workout since then (5 in total) has failed. Two of them after I disconnected and connected again.


(Claus) #8

So, last time I tried to disconnect and reconnect from my.zwift.com and it didn’t work. So I thought today I would try to disconnect from Garmin Connect web site and then go to Zwift and reconnect.

This didn’t work either, still no sync to Garmin Connect.

This is really starting to annoy me, since I normally use Garmin Connect to keep track of everything :frowning:


(Uwe ) #9

Same for me :frowning: No upload to GC
Also tried to upload the exported .fit file manually. Doesn’t work :frowning:
I converted th .fit to .gps and finally the upload worked but misses some information


(Ricardo) #10

Unfortunatly I’m having the same issue. Zwift sends correctly the file to TrainingPeaks but nothing to Garmin Connect. I already disconnected and connected again but…

3 days ago I was able to export the file (.fit) from my Zwift.com page and successfully import (manually) to my Garmin Connect page but yesterday when I’m importing to GC some error is occurring.

I also converted the .fit to .gpx, it worked but no HR or Watts information.

Any ideas?


(Nick) #11

Definitely not working unless you do the GPX export workaround from Strava :frowning:


(Marc) #12

Check out the known issues. It is something they are investigating since many people have this problem…


Zwift rides/runs not saving to Garmin
(Stephen) #13

Stopped updating since Garmin took their servers down at the end of last week.


(jordi) #14

Is there e problem with since strava en garmin. not working …


(Alexey) #15

Same to me!


(Kurt Muetterties [BRT]) #16

Same issue. Includes rides done on PC , and runs done on ATV. No uploads since latest update.


(Adam) #17

Strange, it always worked for me till today.
Today’s ride was not uploaded to Garmin Connect, but instead I could see only my watch’s activity of the virtual ride and not the Zwift’s activity.
Could it be some sort of conflict between two types of activities in the same time?
One is the virtual ride activity done by the watch and another one is the Zwift virutal ride activity.


(Uros) #18

Same here, Garmin stopped accepting Zwift rides. Please fix this asap.


(Brett) #19

Well Uros, I’m having the same issues, broke all connections and see if that works this mornings rides not syncing.


(Uros) #20

I know, I reset conection and still no good. Frustrating…