Game Update v 1.45 [August 2023]

Zwift stated that they would be updating the graphics profiles

Yeah they hinted that the 2022 ATV might get something. I don’t think they made any commitment about what would happen or when.

2 Likes

Hmmm. After update I’m losing pairing to the right controller. Starts out fine then it seems that after I get a ride on, and the haptic buzz goes it loses connection. When it does, I still have steering but the Z button is non-functional. Have reset repeatedly to no avail. Also, when paired there no haptic for braking.

Had a couple of rides since the update and I am getting one major issue, the connectivity of my left zwift play, it goes in and out more than fashion. It was fine before. Also had it pull me out of the draft on several occasions and the responsivity of the button when it’s actually connected is about as reliable as the word of a politician. I have reinstalled zwift but still having the same issue. All other connections seem solid.

Other issues experienced is that my cadence is always 1. It has come up as 190 something but that was for a second and then it went back to 1.
I have also had periods where my screen went black. As this is on a new machine to me (but same GPU) I have checked my GPU setting but they seem fine. This has only occurred today whilst it was fine last night. Will see what happens tomorrow.

Running on Windows 11 i3 12100F PC with 16GB of RAM.

I had this today (Chasing Rainbows race) too, exactly as @Verde_Espada described. Circle disappeared after a while, holding Z buzzed the left controller, everything else worked.

And today’s ride, the circle displayed as expected, even with the HUD hidden. I was on a free ride, not in a workout.

macOS started to do the update yesterday, but quit before doing the actual download. Today, it did do the update. It faked me out yesterday, got me thinking it was going to update, only to be left wondering what happened. A ‘get ready’ indication of the update coming soon to a computer near me, or a glitch?

‘It’s coming…’ :smile: :crazy_face: :dotted_line_face:

For these to be counted, do we need to finish the “Climb Portal” route? I did Platzerwasel today, and although I rode about 4km around the Volcano after exiting the portal, the “route” indicator was still only about halfway to the chequered flag.

Do we get credit just for reaching the top of the climb, or do we need to descend, ride out of the portal and reach the flag/official end of the route?

Also, on the badges themselves, the “10 climbs” one is a bit of an odd one out as it spells out the word “ten”.

image

Other similar badges just use the numerals.

image
image
image
image
image
image

3 Likes

Something maybe screwy with this Portal route?

Some observations after my first group ride using Windows v. 1.45.0

Zwift Play controllers were extremely slow to respond when steering, slow-motion like. Perhaps by design with this release? Maybe a good thing actually, no need to zig-zag like a maniac.

After 15 minutes into the ride, the Z button on the right side Zwift Play completely stopped responding. It would no longer give a Ride-On Bomb or respond to any input i.e. executing the menu selections brought up via the Left side Zwift Play or returning a Ride-On.

I had to resort to the mouse to execute a Coffee Stop. Yes, the controller was still paired to the PC. Other buttons were working on the Right Zwift Play, I was able to use the “A” button to execute Power Ups throughout the entire ride.

I also experienced random right side controller haptic feedback for no apparent reason.

Even after the event finished and I was dropped back into the general population of Tire-Bouchon, the “Z” button was unresponsive still.

2 Likes

Further to my earlier post about not being retroactively granted a Climb Portal achievement after installing 1.45 and reading this thread since, I now suspect there’s a problem too. I did my first Climb Portal ride a few days ago and my experience mirrored Stephan’s.

I selected the ‘Climb Portal - Volcano + Col de Platzerwasel’ route in Watopia, and followed the defined route in its entirety. Once I was on the climb there was no Timer & ETA in the HUD, and when I reached the summit I didn’t get a ‘climb complete’ smash screen with my time stats. I noticed too that my ride never appeared in the Live Results table! It was s if I’d not ridden the climb…

Wondering if you had to ride the whole route, I continued riding, descending and passing through the portal back into Watopia. At this moment the ‘Climb Portal’ route progress bar appeared in the HUD (showing several km to go to reach the chequered flag) and it was approx 1.5 laps of the Volcano Circuit CCW until I completed the route at the Volcano banner. But there was no ‘Route Complete’ splash screen, the route simply vanished from the HUD. I then ended the ride totally puzzled about what constituted completing a Portal climb?

And after installing 1.45 I have not been retroactively granted the Climb Portal acheivement, which of course is disappointing. So it would appear as though my effort and achievement doesn’t ‘exist’. It makes me reluctant to ride a Portal effort again in case the same ‘you haven’t ridden it’ error repeats.

Please see the attached pics.Note: the summit screenshot was (fortunately) manually taken by me, Zwift didn’t automatically take a shot as you’d normally expect it to.

I’m hopeful this can be rectified for ‘error’ Climb Portal rides?



1 Like

Three new activities since last Friday and two with big issues.

First one on Saturday during Chasing Rainbows. Since it was a race and I spent 3/4 of the race with the same group of ~20 riders I didn’t used the Ride On bomb so can’t tell if there was something wrong again. But after 60k in the race, I noticed that my avatar was on the far left of the road (it was on Scotland so riding on the left side of the road). I pushed the right button to take it back to the center but again it went left. If I did nothing, the avatar was sticking to the far left of the road. I tried turning off the left controller to no avail. Without pushing the right steering button, it kept going to the left… So I spent about 10k pushing the right button every 5s to try and maintain it in the pack to be able to draft…
Once the finish line crossed, everything went back to normal.

Second one on Sunday, during a custom workout. Same as Friday : first everything was okay. Then no “Ride On bomb progress circle” but still haptic feedback on the left controller. Then no haptic feedback at all. Then I just got a “device disconnected” message in the white top center box and from this point, the right controller was dead while the left one was working fine.

Today, short 30mn ride, everything was working fine.

1 Like

I’ve had this happen once with the Play controllers… a reinstall of the latest Visual C++ Redistributable files and a reboot resolved it (which is my usual go-to task on Windows when Bluetooth peripherals don’t work as expected in Zwift).

3 Likes

Ciao,
Gentilmente vorrei sapere quando l’aggiornamento 1.45, sarà disponibile per Apple TV, perché a distanza di 3 giorni, io non lo vedo ancora.

@Rowdy got the latest update and can confirm that kickr bike no longer steers with plays when not connected so that’s good. Not sure if the disconnection bug was supposed to be fixed in this release. Right hand play still drops out every 20-30 seconds unless connected to power

1 Like

That must be something with your controller…mine is not dropping at all.
I also tested reconnection during a ride and it worked fine.

Were rider shadows removed from apple M2 devices in 1.45?

1 Like

Turn options aren’t showing up at many but not all junctions. Happening in different worlds not just Watopia. Edit: next lap around the option to turn to the portal showed up.

Right Zwift Play controller keeps disconnecting all the time, win11
and steering is awful slow

1 Like

I’ve had loads of support emails with @Rowdy and it is a known problem, connecting to power is a workaround and a fix is in the works. Just didn’t know if it was supposed to be in 1.4.5

1 Like