Game Update: Oct 29, 2019

Starting this update, rides no longer start at zero miles. Grand Central Circuit shows 1.7 miles when I start riding. Knickerbocker shows 0.2. this is very annoying since it messes up my mental calculations.
It happens on both pc and mobile app


Since the update, now the InRide sensor on my Kinetic trainer and my Wahoo tickr heart rate monitor won’t sync up at all. Like they’re not even there anymore. Used to connect flawlessly. Please help! I’ve tried to uninstall and reinstall the app on both my iPhone 8 and my Apple TV 4th gen that I always use. Made sure all my ios systems are up to date etc. very frustrated. Missing all the Halloween fun :pensive:

+1 on the gfx

1 Like

Good honest update - personally looking forward to ant+ on Android and Road Feel for the Tacx Neo Bike Smart!

1 Like

I noticed it too yesterday, and XP-points are given at uneven km/miles. 2.6, 3.6, 4.6 km and so on. Very annoying.


I only noticed it once, but yes. I got 20 XP at something like 26.8km and couldn’t work out what I’d got it for.

PC. Version 1.0.41943 - up-to-date.
Watopia’s default route is “Watopia’s Waistband” can’t select “The Maginificent 8” for the Halloween event.
Also no option for the Movember event yet…
What’s up with that?

1 Like

Thanks for the update on rolling resistance. We did have a “toys out of the pram moment there” and appreciate the future fixes to manage the transition for changes like this in future. Onwards and upwards :+1:

Same here. And while in a group ride the (automatic) directions selector before intersection was sometimes wrong. If this was intentional to scare me it worked! If it is another bug, well …

Same her, no Magnificent 8 route for me, too.

It is defined in world1/data_1.wad:
1</ƒÁÓ¬ ï naÀ\† The Magnificent 8" eHashÀK®ñšt21ñ¤¢distanceInMeters=“289ñG7ÀúŠas=Æ e154.961ÀoÜÂÕ8DÍ >0” ÂÕSAË< avelLockedÁ3sportType="3" eventOnlÀ„á" sup aedLaps="1 Paddock ,2,3,4" useAlternateE DRamp 2mapID <(locKey="LOC_ROUTE_WATOPIA_THE_MAGNIFICENT_ó4¸

I found lots of these entries in log file (PC):
[11:58:40] Loading WAD file ‘assets/Worlds/world1/data_1.wad’ with file.

[11:58:40] Loading routes…

[11:58:40] Load Route Error - Cannot find leadincheckpoint in data/Worlds/world1/routes/routes0.xml

[11:58:40] Load Route Error - Cannot find leadinhighrescheckpoint in data/Worlds/world1/routes/routes0.xml

[11:58:40] Finished processing 266 checkpoints - 0 stripped

[11:58:40] Finished processing 2476 checkpoints - 0 stripped

[11:58:40] Load Route Error - Cannot find leadincheckpoint in data/Worlds/world1/routes/routes1.xml

[11:58:40] Load Route Error - Cannot find leadinhighrescheckpoint in data/Worlds/world1/routes/routes1.xml

continues to

[11:58:40] Load Route Warning - failed to open “data/Worlds/world1/routes/routes46.xml”

[11:58:40] Route manager info: 72 routes

[11:58:40] Select Route in DropIn Dialog Constructor

[11:58:40] Setting Route: Watopia’s Waistband

[11:58:40] Calculating route stats for 231 CPs

[11:58:40] Printing Regular Route. Decisions Count 26. Infinite loop start at: -1 Finite loop start at: -1, end at: -1 for -1 loops

I can’t find the movember mission sign up? Is it out yet? I only run on Zwift now.

No, You should see it tomorrow 1 November.


I have been with you guys for 7 or 8 years now and other than a minor glitch here and there my experience has been fantastic. I love the concept and for Canadians it has been a godsend. Thank you for providing such a brilliant tool for me to kick my own ass. You are appreciated as are your efforts to improve and keep the platform fresh. Yes I pay for the privilege and I am a customer but this is a partnership and I am happy to support it.

Thank you to the entire team. Please know that what you do is thoroughly enjoyed and certainly appreciated.

Ride on


1 Like

running have bugs from update on macOS, starting runs with 2km+ distance and xp is awarded per 0.25km as earlier but not at 0.25 0.5 0.75 1.00 etc but on different places.

Ah explains that. Cheers for the reply.

This new version resolved the screen sizing problem Apple TV 13 only using lower left corner of screen.

The ZCA seems to be correct and was awarding XP at each mile, but a little after the odometer clicked over like it used to a while back.

How do I get this update? Does it update automatically or do I need to do something? It says the Supersix evo is added, but I don’t have it.

It should auto update if you have auto updates turned on. Go to the i-store and see if there is a update.

Super Six EVO will not be available in game until Sunday, to coincide with the Giro de Rigo ride. (And if you complete the longest distance Giro de Rigo route you can unlock a special paint job for the Super Six EVO.)