Game Update - November 18th, 2021

Hi there. I am encountering an issue using the Apple TV. What I am now noticing, which I had not noticed on the previous release, is when I’m mid-pack or near the rear of a very large bunch (say 200 riders), the riders at the bottom of the screen render and vanish repeatedly. It can be described as a flickering effect. The issue is visual only. When near the front, this issue does not occur. Riders enter and exit the bottom of the screen smoothly. To me this points to the hardware or software struggling to manage the workload of rendering the screen.

Has anyone else reported this? Cheers Al

I am using an ATV 4K 32GB on the latest software.

1 Like

Hi @Steffen_Fischer_ZRG, we are aware of an issue with Zwift crashing on Monterey and are looking into this now.

The Asset Load Failures you posted are bit of a distraction. Everyone will have those errors in the log. This issue you are experiencing is almost assuredly due to the Zwift-Monterey combination. Hope to have an answer for you soon.

@shooj @Mike.Winfield the Tacx road-feel feedback in Neokyo seems to be off in quite a few places. It would be great to get this sorted. Also, not a fan of the new sound when the XP are awarded every mile/km (at least on iPadOS and TVOS).

1 Like

The mouse click sounds make you feel like you’re at work again. And the sound for earning XPs is pretty obnoxious with headphones on.

That XP sound is obnoxious even without headphones. Not a fan of the ‘chirping’ at the crosswalks, either.

1 Like

I was having issues with the Apple TV and Wahoo Kickr with it not setting any of the climbs (ie. felt the same). This is well documented on a lot of other posts here. At the time the suggestion was to downgrade the Kickr firmware which solved the issue.

With this latest game update the problem has returned. What can we do? It pretty much makes Zwift useless.

1 Like

Mike,see my Othello post. A complete deletion and install fixed it. Seems updater/patcher spoiled it last time.

I encountered today an issue where zwift would show me a message “connection failure” in the top of the screen above the blue rectangle where is power, HR and cadance, but nothing was disconnected. I am wondering what this can be? This message occurred at least 5 times during the long group ride.

@Steffen_Fischer_ZRG, happy to hear you were able to resolve the issue.

Yes, all good. Please fix your uninstall procedure as this can lead to problems having corrupt Zwift installs on the Mac. Thanks

See Some avatars flickering in large bunch

Another one here for Zwift / Monterey crash.

But not only is it crashing Zwift, it is crashing my entire Mac - the entire system stops responding and restarts itself.

Try a complete uninstall/reinstall. See my post

Just had a PC crash on Temples and Towers. Almost done and went to my garage to change bikes when Zwift completely shut down. Was able to restart but lost the ride :frowning:

I have eaxactly the same problem. Updated zwift but couldn’t get past the login screen. Deleted the app and reinstalled but the problem remained the same. So I can no longer use zwift at the moment. Pretty dissapointing. I have the latest apple tv version with the remote that came with it.

More crashing on macOS Monterey (12.0.1) and the latest Zwift version (1.0.100118).

Went through all the steps outlined by Steffen - but it didn’t work for me. And not only is it a Zwift crash,
it’s crashing my entire system and rebooting it.

It seems pretty intermittent as to when it will crash. I was leading a group ride and joined the pen early - it crashed with a minute to go. By the time I had got back into Zwift I had missed the start - but then for about 5 or 6 goes, I got to the “Finding riders” stage, and then it crashed.

As a last resort I tried another completely fresh install and this time it allowed me to join the group ride I was leading - 15 minutes late, but then crashed again with 2km to go in the ride.

1 Like

I don’t know if it is gonna be helpful but worked for me. I deleted everything regarding to Zwift( all files from documents and disc), also went to app data on c disc and deleted everything with word Zwift. After that I also cleared cache and history in IE and Edge. Restarted pc and make fresh download, instal game on C disc, updated and then went to login. For now is working:)

2 Likes

I find Neokyo a bit repetitive and frankly that kind of makes it boring - would rather see more like rest of Makuri islands but with more pavement. I also do NOT like that so many updates have regressions that are simply unacceptable. Maybe a little more effort on QA and build process should be reviewed.

2 Likes

Zwift needs to start paying attention to their QA issues or start losing folks to RTG cycling and/or Rouvy

Hi Gareth

This happened to me this morning? Is still happening for you or has it fixed itself?