Game Update - November 18th, 2021

also funny that the reflections are on the lower level road under the elevated roads as if the light is somehow going through the solid roads above. Similar to when underwater in Watopia and the sunlight water reflections pierce through the solid rock caves and onto the roads :grinning_face_with_smiling_eyes:

Overall, no huge problems for me with the new roads. However, I did notice the frame rate seems lower than I’d normally see. It was particularly obvious when riding through the arcade.

I also noticed that the contrast between the gradient indicator in the top right and the map behind it is poor. Most of Neokyo is quite dark on the map tile, and this made it harder to see what’s coming up in terms of gradient changes.

Like many of Zwift’s built up areas, Neokyo is rather slab-like in places. The same texture used repeatedly for large areas. It reminds me of a video game from the 90s in that sense. The more vibrant areas don’t suffer from this as much, but it’d be visually appealing to me to see more variety in larger planes.

Oh, and this is worth noting: when riding around a busy Neokyo earlier, I really notices the apparent lack of sticky draft. That’s more related to blob 3.0 than the map itself, but this was the first time it really stood out to me.


Apple TV and Kickr Core. The ERG/incline bug still exist. Super annoying. No resistance on climbs and have to push 4w/kg to get down the hill. Just read that I should uninstall. Did that and now I can’t log in on Zwift, it just crashes. Both on iPhone and Apple TV. Please fix bugs before spending time on new worlds.

1 Like

Same here on Apple TV doing the All Nighter loop.

Agree. The reflections on the smooth surfaced roads don’t change even though I am moving and the light sources are changing. That stood out as very strange.

Hi Paul, could ytou please send a ticket for me as well?
Since latest update I had the " ERROR # Z117 , FILE “Patcher.cpp”, LINE 602 : Failed to download needed server files for update!" and can’t get pass the update screen.

I’ve tried all that’s written in the support page for this issue:
" * Right-click on the ZwiftInstaller file and choose ‘Run as Admin…’ even if you already have Admin access on your computer. (>>Tim: I navigated to the Program Files (x86) folder and selected Run as Admin on Zwift Launcher).

  • If you have an antivirus program installed, make sure it’s not preventing Zwift from writing to your account folder. (>>Tim: Disabled AV but still nothing)
  • If you have a sync program (e.g. Dropbox, Microsoft OneDrive) installed, make sure it’s not syncing your Documents folder. (>>Tim: No sync set up for Documents)
  • Make sure your default Documents folder is accessible. (>>Tim: Yup, it is)
  • If the workarounds above don’t work, try deleting the Zwift folder under Documents , and then re-launching Zwift."

None of that works.

Thanks in advance!

Even more dropouts today. First all sensors disconnect and frame rate drops to 2 (two) fps, frame rate recovers as soon as I unplug the ANT+ dongle. Un- and re-pairing sensors works, trainer stays connected for an hour plus change, but HRM (Polar H10) keeps disconnecting. Switched the HRM connection back and forth between BLE and ANT+ a couple of times. BLE worked fine but ANT+ kept disconnecting at least once per minute as soon as I switched to that. Nothing else has changed with my setup and I didn’t get these kinds of problems before.

Oh well, at least now I’m finally looking forward to the Direct Connect support for real.

Hi Gerri,
The link you provided redirects to another address, I can not find any download link on this address.

What do you mean “download launcher”?

I have downloaded Zwift 3 times from this address from the “Download menu”: [Download Zwift on iOS, MAC, PC, or Android Devices | Zwift EU]( www )

Reinstall does not help.

Program worked fine yesterday, before the update.

It also works today on my other laptop, this laptop is also Windows 10, but this laptop sometimes loose contact with the trainer, Whahoo Kicker, via Ant connection. I raced today on my other laptop with the new version, after 50 minutes my bike stopped for a few seconds (no power detected)


Nice job, all working as expected on Mac OS. Thanks for the update.

Please make sure to submit a ticket here. I’m not always monitoring the forums and this will ensure you get support quickly. Thank you!

Do I do so by clicking the “start chat” button? Nothing happens when I click on it.


The same problem

Do you have an ad blocker on by chance?

I thought it might be it but I tried it while disabling it, same results (on the pc). Same thing happening with the smartphone (without any ad blocker)

Anyway, I managed to open a chat box somewhere else an hour ago on the website but no response so far.

I see the ticket has made it into our system. Someone should be reaching out soon. Appreciate your patience!

Hi @Shayne_Wachtel_6990 are you running Zwift on a Mac with beta Monterey OS installed by any chance? If not, please let us know if you are running Zwift on Mac or PC.

For resistance: check your Settings/Trainer Difficulty–this update may have changed from where you set it.


It’s just that the Zwift email said the new version was 1.19 including Android. My misunderstanding I guess.

Thanks for letting me know/

Thanks, Paul. Companion app says it updated just yesterday, but who knows if that was before or after my ride! I’ll take a look the next time I’m out that way.

1 Like

Ok, looks like I’m not the only one with all-new dropouts:

(I did eventually check the logs and apparently I was having some ANT+ issues already before the update but never to the point that it was noticeable UX-wise.)