Game Update 1.43 [June 2023]

@Chris_Holton I’ll send you a direct message to collect some more information regarding what you are seeing.

1 Like

Noted and bumped this ticket.

1 Like

I have already received the update Apple TV (A2737), but I can not find the video screenshot function in the menu. Will the feature come later despite the update to 1.43? It is not mentioned as a new feature in the Apple TV Appstore.

It’s a gradual roll out after 1.43

3 Likes

Ok, great thanks for the feedback! :wink:

1 Like

@shooj As always thanks for your updates! I do really appreciate you guys seemingly focusing a bit more in this version with fixing bugs and a little less on adding new features and bugs.

Unfortunately as amazed as I was that the Play controllers I received at launch seemed to work effectively flawlessly when I got them, with this (Zwift) update it looks like we’re back to the norm of introducing bugs along with the new features:

I’m on ATV and pairing everything through Bluetooth and ZCA running on an iPhone. After the update, after 20+ tries my Plays have only paired from the Zwift startup pairing screen successfully twice. It’s all a bit haphazard, but generally what’s happening for me is that the lights on the controllers go solid, indicating they’re paired, and the Zwift startup pairing screen steering indicator also indicates “Connected”, but the battery level indicators remain blank, the bluetooth indicator on ZCA remains orange, I get no haptic feedback from the Plays indicating that they’ve paired, and they remain unresponsive. The moment I select “Let’s Go” the BT indicator on ZCA turns blue, but the Plays remain unresponsive. One time all indications were that they’d fully paired successfully, but in fact the right controller was completely unresponsive.

The only way I’ve been able to consistently get the Plays to fully pair and work after the update is to leave them off during the initial startup pairing sequence, select “Let’s Go” (using my ATV remote), then re-enter pairing mode from the main Zwift landing screen, then turn them on. Once I figured this out they’ve paired flawlessly for me every time using the sequence, but just don’t pair correctly from the initial pairing screen. I’ve tried different combos of when I turn the controllers on (before/after starting Zwift, before/after starting ZCA, etc) but nothing seems to work.

Here are my setup deets:
Apple TV 4K G2 #A2169: TVOS 16.5 (latest) running Zwift 1.43.0 (latest)
iPhone SE2 #A2275: iOS 16.5.1 (latest) running Zwift Companion 3.48.0 (latest)
Original Play: v1.1.0 (latest)

1 Like

@Velolion Out of curiosity, on your mobile device running Zwift Companion, have you tried turning Bluetooth off and then on again (or restarting the device)?

And either way, thanks for reporting this issue, we’ll investigate.

Used Zwift Play 3 times since updating firmware to 1.1. (game version 1.42)

Each time companion app is used as bridge to ATV. At random timeframes, companion app loses all Bluetooth connections in game and cannot reconnect. Tried restarting companion app and reconnecting but won’t work.

No other apps running on phone, no other Bluetooth devices around. Zwift play worked perfectly prior to firmware update

Stupid question… I noticed the tile for the challenge last night, but rather started warming up for TTT, thinking I’ll join the challenge later. Got the update this morning - and now I do not see the tile for the challenge?! Not there on iPad or Mac. Same for everybody else? Will it be re-activated?
Did not have trainer connected to Zwift, just wanted to quickly pop in and join the challenge, but cannot assume that this would have made a difference.

Hi - which challenge are you talking about?

Everyone please update to v1.43 at your earliest convenience.

3 Likes

I was hoping in the new update to have the snap video feature in Apple TV… any update?? Thx!

Android and iOS:

  • Fixed an issue where the Leaderboard and Zwifters Nearby lists could not be hidden by swiping to the side.

While warming up for an event last night doing a freeride, I tested this and could indeed swipe away the Leaderboard and Zwifters Nearby lists. Thanks for restoring this capability. But once I was in the TTT event, I could not swipe away the lists. Perhaps this feature was restored when freeriding but not in an event? Running Zwift on iOS, iPhone 12.

See the following. It’s a gradual rollout and even then only to the two most recent models of ATV:

1 Like

Sorry, that may have not been my most accurate description of the day! The portal climb challenge. I still see all the others of the month. (Tourmalet, WTF and ZRacing Beach Party)
But the tile for the portal climb challenge is gone.

Not sure this is going to the right person but, once the last update hit I lost my ability to do a U-turn on my Apple TV screen menu and on my apple phone. Any ideas on how I fix that? Also the coffee break button finally showed on the menu bar but, it is also not lite up and can’t be used.? Thank you
Brie

Hi, @evan-zwift. Yes, I’m pretty sure that was one of the first things when I initially encountered the problem after updating to Zwift 1.43 and updating the Play controllers’ firmware to 1.1.0. However, just to make sure I just did it again…completely turned off the BT radio on the iPhone, power cycled the iPhone, then re-enabled BT. Behavior is exactly the same.

I did figure out another way to dependably pair the Plays, although in effect it’s not a whole lot different than what I described in my prior post:

  1. Turn the Plays on at the initial log-on pairing screen, as normal. The Play’s LEDs go solid blue, indicating successful pairing w/ZCA, however the paired haptic feedback doesn’t occur, the BT indicator on ZCA remains orange, and the Zwift pairing on-screen indication hangs either on “Pairing” or on “Connected” but with no battery level indication.

  2. Select “Let’s Go”, which brings me to the main Zwift landing page.

  3. Cycle the power on the Play controllers. Once they’re turned back on they successfully and fully pair.

Issue is effectively the same, though: they won’t successfully pair from the initial startup pairing screen, other than maybe once in ~15 tries, and seemingly at random.

Yes, I’m seeing odd behaviour particularly of the Right Play controller.
Win10, latest, Android 10 running the companion, direct BT pairing with Win10.

Both Play LEDs blue, right controller would not register A in the menus, then found workout bias could only decrement and not increase. Thinking about it, that is consistent with the Right controller not working.

I had two Zwift full lockups before starting (Win10 'stopped responding ', logged to MS), so suspect the Right controller may have lost connection - despite the initial pairing screen showing both Play devices.

The steering worked for 3x Repack (sadly, binary controls not proportional), then the workout was a bit poor and forced me to breakout a keyboard mid-ride.

Beta for a reason! :grinning:

Climb Portal is available to everyone as of ~30 minutes ago.

Note that you must be on Zwift v 1.43 - mobile OSs may not auto-update. If you’re on iOS / Apple TV / Android - please check your app store and manually update if necessary.

If you’ve had Zwift app running before we flipped the switch on the server - try logging out of Zwift, and logging back in. You should see the Climb Portal Challenge tile across the top of the home page.

3 Likes

@Brigitte_WEEK Could you please share a photo or screenshot of what you see in the blue Action Bar? That will help us better understand the issue. This is an example of what I see on my Apple TV: