Game Update 1.34 [April 2023]

It’s weird that I’ve never seen it before. Is it something new (and that there’s a potential upcoming fix for) or something that I’ll have to try to fix with my hardware forever (I have an AMD card)?

Hiya @Paul_Himes I confirmed that your most recent session log that you’re not yet on v1.34, so what you saw is not a symptom of that.

How many people were in that group ride with you, out of curiosity?

1 Like

~250 were in pen C of the Tour of Watopia at my timeslot last night. I would say that I was only riding with ~30-40 at most in my group, but I gave up with camera view 1 after we all turned into the pink dinosaurs in the desert (so maybe 3 km in), so there were probably a lot more people in the area that the system was trying to track.

When the above poster said that it was called rubberbanding, I googled that and zwift and I see someone saying that AMD GPUs are part of the problem. I run an AMD processor and an AMD RX 590 GPU, so maybe that’s the issue. Could be this was just a bigger group ride than I usually do, so I just didn’t notice it before?

Thanks for looking into this.

If it matters, I also usually have a browser window open (to Zwiftpower), Discord, Pretzel, Voicemeeter Banana, iTunes, OBS, and a Twitch Chat overlay running when I’m racing. Maybe all that somehow slows be down below the 60 FPS and last night I only had iTunes and Zwift running when I saw the rubber banding. Or I have no idea what I’m talking about.

Also, I run Zwift on a projector, don’t know if refresh rate matters.

Update April 7
We’ve made the 1.34 update available to more Windows / Android / macOS users. If you notice a new issue, please report them in this thread.

We will not make additional changes over the weekend. Staggered rollout to iOS and Apple TV devices will begin next week. Enjoy the holidays if you’re celebrating with family and friends.


I’m not always the most complimentary here but i tried a pace partner yesterday in a big group the dynamics were FAR better much more natural. Good job!


I saw two minor bugs today with the latest version…or maybe they are features? @shooj

  1. I was freeriding in Scotland (not an active world today) and noticed that people were in workout mode (screen in front of then) but the Zwifters Nearby list did not show an icon that used to be there in past for people doing workouts (the little bar chart).

Note: You can ignore my workout icon missing as I was not doing it via Zwift.

  1. Zwifters Nearby list is showing riders that are riding in opposite direction. Not sure what is the purpose of it but it makes it hard to follow who is in front and behind me. I suspect this is not new as I noticed the same in the Tour of Watopia earlier on Volcano Climb.

Other than that - happy that PD4 is public now. Great job Zwift :clap:.

I think this already happens

1 Like

See Zwifters nearby list ignores direction in Scotland

Update April 10

Phased rollout of Zwift v 1.34 to Apple TV and iOS has begun. More macOS devices will begin to receive the update today as well.


Hi @Martin_Skapa
I looked at your latest ride in Scotland - the one on Muckle Yin doing the Emily’s Mix workout. Your Android was still on the 1.33.6 for that session, so it wouldn’t be a 1.34 issue.

3 posts were merged into an existing topic: No gears displayed after last update

Is the roll out to PC users still being staggered? No update still available for me and others on PC, just checking if the roll out is still ongoing for that platform.

1 Like

Nothing yet in my PC or my Mac. I got 1.34 in my iPhone, though.

Yeah I just noticed iPhone app update is there too

Yes. The roll out is staggered on all OS platforms.

OK just seemed odd since the current gamer version on the pinned post now shows 1.34 as the current version. We will wait patiently… :+1:t2:

No upate here on Android since 23-03-23, Nothing on PC either, mind you if its only really racing related its no real problem

HI guys.
i have a problem since today. i did a Workout (Micro Burst) on Scottland. After the Ride it synct to Strava but not to Garmin. If i upload the .FIT File from this Ride from my Zwift profile it does not work on garmin connect page.

Anyone else who have this issues? - when i ride on group rides or solo it does work without a problem. Only on workouts i have this issues…

I updated today, started riding, and after 8 minutes Zwift dropped ant connection to all my units (powermeter, heart rate etc). Zwift was asking if I wanted to quit Garmin Express as it was running in the background. I clicked “no” and went into the pairing window. Now all seemed fine, but when I started cycling again, I got the same problem. I now clicked “yes” and quit Garmin Express, but it didn’t solve anything, instead I could now not find ANY units in the pairing window. Also tried restarting Zwift.

By the way, does Zwift need .NET 3.5? It asked me to install it during updating, but I didn’t do it. However after the problems arised I updated Garmin Express and it requested me to install .NET 3.5, and I did it this time. Restarted Zwift, but still it didn’t work.

Is this a known bug?

As of today, (4/10/23) the most current zwift version is 1.34.0. However still have 1.33.6