Game Update 1.33 [January 2023]

That’s a feature, and you should just learn to love it. You will be assimilated.

I’m experiencing this same new “feature”, on both an iPad and iPhone. It appears the ride time (or some sort-of time) is mapped to nearly all the different fields, and where it’s showing that time right in the middle of the screen, where it should be displaying current power output, the time actually goes up and down with my power output. Also different workouts all show “Finish in 1:50:24” at the top-right (that time is obviously wrong and doesn’t count down) and what appears to be a datafield name at the top-left: “Workout Title”.

Restarted all devices (ATV, iPhone, iPad) and it was repeatable…except right in the middle of me force closing and restarting ZCA multiple times the page actually worked correctly…one time on each device…then it went back to being whacked out.

The workouts do seem to execute properly, but obviously the workout page on the iOS ZCA is all jacked up.

2 Likes

I had something similar to Velolion with the ZCA during a workout.
During the cycling workout “Expand,” the ZCA displayed missing or incomplete information. It also indicated running metrics in the center gauge, even though this was a cycling workout.
ERG was functional, and the workout details were correct within Zwift.

I tried the ZCA on a couple of devices, and things finally did sort themselves out. It took a few cycles of force-closing and relaunching the app.

Zwift Launcher v1.1.5
Zwift Game v1.33.1
Windows 11 (22H2)
ZCA v3.43.0
iPhone 6 with iOS 12.5.6
iPhone XS with iOS 16.2

1 Like

I was a DS for 2 different ZRL races yesterday and for both of them, this is what the top of the screen looked like while fan viewing riders. I briefly scrolled up and didn’t see any other mention of this.
image

This is on Windows.

1 Like

We saw the same thing while DS’ing.

image

2 Likes

Hi everyone

Zwift game version 1.33.2 fixes these critical issues.

  • The Windows / macOS / Android versions are released, and you can update the next time you launch Zwift.
  • The iOS / Apple TV versions are pending Apple review and will release as soon as possible. We’ll update this thread when they’re avaialable on the Apple App Store.
7 Likes

@shooj is there an update to the known bug for Zwift not receiving speed data from Bowflex trainers even though they’re paired on PC? It’s been over 3 months and no update on a fix and my treadmill still doesn’t work with the PC app but works fine with AppleTV

1 Like

After doing stage 7 of TdZ I wanted to do a cool down on “Fine and Sandy” in Urukazi.
Not only for a cool down but to achieve the route badge while I’m at it.

But is was misrouted and did the mech island route twice without doing something to turn actively and to leave the route.

Ride on Strava is even called “Fine and Sandy”.

On PC, update forced to 1.33.2

Misrouting still present in 1.33.2. Occured two hours ago in meetup on Watopia “Legends an Lava”, when the group has been divided - interestingly, the chat continued working…

System Windows 10, 1.33.2.

Since the 1.33.0 update my Precor ChronoPower bike will no longer pair. I been told by support that the bike isn’t supported. Spending thousands on a new bike isn’t an option. Please support your loyal members and undo the line of code that ruined Zwift for those of us with Precor bikes that used to work last week.

1 Like

Same with my Precor bike. The update killed it.

Does 1.33.2 not resolve it?

copy- I played with it last night, the auto-brake is still very grabby at 0w / 0rpm. What’s the dev take on incorporating a toggle for autobrake on/off?

I can guarantee you that at the moment, auto braking will only come into play if you are doing less than 27km/h and stop pedalling (it assumes you want to stop).
Above that speed there is 0 auto braking.

1 Like

27 km/h? Well, maybe that’s the issue. Perhaps set it at 15 km/h, or maybe even 11 km/h.

Okay, that would make sense, where I was playing with it it was just spin up and seeing how it would catch was definitely below that threshold (agree with @Nigel_Tufnel it seems high). Interesting logic though, 2 questions:

  • Could we be given the option to toggle it on or off? set a delay?
  • If it is speed triggered, does that impact climbing (or really any gradient >1%) as well?
  • Could we be given the option to toggle it on or off? set a delay?

In theory we could, but given the list of priorities and things to do + the amount of work to do that, I wouldn’t hold my breath waiting for that option to come. Because essentially this was a problem when you were in a group ride (robo pacers for ex.) and wanted to coast for a bit. I don’t see this being a problem as it is now…

  • If it is speed triggered, does that impact climbing (or really any gradient >1%) as well?

It’s not only triggered by speed, but also by power. You need to stop pedalling. And yes it also happens on climbs.

From being a Zwift Beta back in 2015 and a competitive racer, it was a huge blow to the UX in my experience when it was added. It’s like having your avatar ride without a helmet, it’s a virtual space- there’s some allowances to be afforded. RGT has never implemented it, but did implement speed limiting in corners (where it isn’t physically possible to go a certain speed) and the UX from a ride quality perspective is much more conducive to indoor riding.

I would humbly ask that an ‘issue’ be captured for a toggle, assigned ‘feature request’ and prioritized in the backlog to at least track for possible closure.

1 Like

I still don’t understand. What is the actual problem we are debating here?

Having the game mechanically bring you to a stop when you don’t intend to stop, but coast for a period of time [speed agnostic], is not desired.

2 Likes