Game Update 1.31 [November 2022]

Don’t hold your breath. There are tons of issues with this release, and there’s been precious little information on progress of addressing any.

1 Like

That fix is figured out, and will be released as soon as possible

1 Like

Mute button fixes that. :wink:

Stg 5 Turf and Surf Group Ride: at the last turnoff on the way back to Neokyo folks started going weird on me - mini-map clue that I didnt notice during ride, riders were heading off left in waves and rider list doing things too …

and doing donuts in front of me all the way to the finish line…

Then came across this lot burning it up on their little make believe mini-crit course - some had already finished.

Zero UDP or TCP drops

19th ride in Makuri since update but this was a new one.

Hard to keep up with the bugs these days so point me off to an existing thread for this if one exists.

После этого обновления у меня на п.к. миры макури стали не доступны. При их включении происходит отключение программы ZWIFT. WIndows пишет ошибку и закрывает программу. Остальные миры работают нормально. На телефоне исправить это удалось удалением с последующей установкой а вот на п.к.не получается ни как.Есть ли решение этой проблемы?

The game is taking ~50% longer than normal to load on this release, on very well known hardware. Same as we had in February and March, prior to April’s threaded optimisation changes.


Not sure if this a bug with Zwift, or just the way I am connecting to Zwift, but I have been experiencing a lot of dropouts via Bluetooth when connected through the companion app recently. I ordered a ANT+ receiver hoping it will solve the issue. I know people that are using both Bluetooth and ANT+ that seem to be having issues recently though. I am running Zwift on the latest version of Windows 10.

Oddly enough I’m experiencing the same. Never had any issues with BT link but all of a sudden I’m getting 1-2 second drops which when running causes the avatar to stop.

Not sure if it exclusively happens in races where a power meter must be paired to even join the race pen, but Bluetooth on the Android Zwift app keeps telling me every ~30secs in the race pen that my turbo (Saris H3) connection has been lost.

No such issue using ANT+.

Hmm, I’m not noticing this on Mac.

I got my old dual CPU Mac Pro 5,1 running again (replaced faulty CPU) and did fresh install of macOS Monterey 12.6.1 on an SSD. Then loaded Zwift and Ful Gaz in this machine.

It’s otherwise the same as my normal Zwift computer (dual X5690 instead of single) and about the same for speed to load Zwift.

can’t say i’ve noticed any slow down either and i’m running windows

I’m talking 10-20secs more than the norm I expect. For many years the load time has been very consistent, so it’s easily noticeable to me when it changes. Exact same thing happened last time they mucked up CPU load behaviour, that’s why I linked my comments from the time.

1 Like

I’ve just done a clean install of Windows.

Installing the app took an age compared to normal and taking into account the clean install the load time for Zwift isn’t anywhere near as quick as it was the last time i did a clean install.

I have had similar issues, lot of Dropouts via Bluetooth. After reinstalling the all-in-one VCredist Package it wasn’t fixed. Switching to ANT only Communication between Trainer and PC, I had some drops every ~5 Minutes. So something else was wrong.

It turned out, that one of the BT Antennas of my PCIe BT Card was faulty. After fixing the WLAN Cable for 2,4GHz, its stable now.

But if I have a mixed configuration in the pairung screen, like BT (Power) and ANT (controllable) to Trainer, drops reoccur. So I prefer BT only connections.

I didn’t realise at first but my connection had switch from the companion app to bluetooth directly from my PC. I used the Wahoo app to put my phone somewhere close to me where I got full bars. Using the companion app I have been getting a more stable connection again. I am interested to see how ANT+ compares though. Going through my PC’s bluetooth directly I always seem to get drops. It never seems to be an issue with other devices, but always seems to be issues when using the trainer. I have a cable for the ANT+ device, so I will be able to put it right under my bottom bracket when it arrives. Noticed aftewards one of my antennas was actually loose on my PC as well, curious if it will help now that secured better.

Just a follow up note/edit. Switching to ANT+ significantly improved stability for me. I noticed though that the issues I was having seemed to usually happen when I paired both my HRM and trainer through my phone. Using just the trainer alone seemed more stable. I am using a Pixel 6 at the moment. ANT+ paired immediately, and I haven’t had any connection issues yet.

2 weeks later, and the ZwiftGPS maps are still not updated.

1 Like

I would actually like if they give access to Jesper from He is always proactive with these things.


Myself and several others on this thread are also experiencing the same thing! It happened on the Rooftop KOM reverse and Railway Sprint reverse, both of which are not timed but are timed in the forward(?) direction.
I saw this on an iPad, game version 1.31. Haven’t tried on PC yet.

@James_Zwift @shooj ?

It does it on all platforms