Game Update 1.31 [November 2022]

Love the PR HoloReplay

Not sure if it’s new but did Chasing The Sun route on Neyoko today.

As i went through the reverse Railway KOM the timer started as i rode through the KOM so the distance to go was going up and the ETA just got more.

Carried on until i made a turn.

I had similar on one of the other routes yesterday in Neokyo until the display showed N/A.

Please note that the bug affecting Zwift training plan progress has been fixed. Please update at your earliest convenience.


I’ve noticed that version 1.31 forces a screenshot to be uploaded, and there’s no way to deselect it.

I have set ‘Only My Shots’ in my settings, but Zwift automatically takes screenshots anyway, which it didn’t do before. It seems like there’s a blend of automatic random shots mixed with shots when I got a new PR.

At the end of the ride, Zwift automatically wants to upload several of these shots (even though my setting is ‘Only My Shots’ as described earlier). Also, when deselecting the shots Zwift wants to upload, I can only deselect all but one. The last one can’t be deselected.

1 Like

Known issue: Screenshot upload preferences ignored [November 2022]

Been the case for years. And really annoying. No option NOT to upload a screenshot

New issue I think? I arranged a Meetup to do the Island Hopper route before leading it on a group ride Monday. I wasn’t on that course however, as it kept me on endless circuits of what must have been Mech Isle. On 60 minutes my meetup ended and displayed that I SHOULD have been on Island Hopper, but as you can see from screenshot on Companion I was not. There was no badge unlock either, for Island Hopper or Mech Isle. Is this likely to be an issue on a group event? People will expect to unlock the route badge.

12 posts were merged into an existing topic: Lost Training Plan Progress [Nov 2022] [1.31] [SOLVED]

I’d like it to show the last selection also. I’ve never shared an activity with a club, yet after today’s ride, the one club I joined was the default, not my previous selection of “No Club”.

1 Like

Got the update to 1.31.1, did stage 4 on Tour of Makuri (All-Nighter), and Zwift crashed as I was hitting the end ride button. Just POW, back to desktop. So I uploaded the ‘ride in session’ fit file and it’s short almost 4km.

I deleted Zwift, rebooted, and reinstalled, hoping for better times today. It was a shock that it crashed, for sure. I haven’t had Zwift crash in YEARS. The ride was uneventful until that happened. (I did have a couple ripples in the matrix, but that seems to be a feature lately?)

Is this an issue with other macOS Zwift users? Is there anything that I should have done? I did save the log folder.

Intel Mac Mini, Ventura 13.0.1, 8G, 1TB.

EDIT: The last message in the log file is “[18:45:10] [INFO] Uploading image to mobile device /Users/XXXX/Pictures/Zwift/2022-11-12_18-45-09_20.jpg”

Not really much help, no anguished cries for help as the app dies. No bread crumbs either.

And the .fit file is blown. FIT CSV file tool says:

“FIT CSV Tool - Protocol 2.0 Profile 21.94 Release
Error: A problem occurred while decoding the file. The decoded csv file may be truncated 2022-11-12-17-28-22*.csv files.
Warning: No CSV has been written as this file does not contain FIT message data
FIT binary file decoded to 2022-11-12-17-28-22*.csv files.”

1 Like

Had the exact same thing happening Friday. Result on ZP, but no .fit file and no activity …

No InProgressActivity fit file?

Yes, but it’s empty. I’ve tried fitfilerepair etc, but doesn’t seem to work. Checked all available .fit files from the day and the race- file is gone :frowning:

It’s actually 0? Wow. I had two files, the dated file and the InProgressActivity, and the former is corrupted and tokenized so I can’t see the data, but the In Progress file did upload to Strava

Wow, that sucks… I’ve been trying to find crumbs that might indicate what happened. How far were you into your race/ride?

I completed the race, it’s on ZP (using live data), and I’m seen in the results of other racers activities - but mine is gone.
Game crashed upon saving post-finish.

Crash log sent to Zwift. It is what it is, but it’s the first time ZwiftApp has crashed like this - without a warning.

Hoping it was the first and last time :slight_smile:

Moving on :cowboy_hat_face:

Are you taking screenshots? If so don’t do more than 20 (leave space for the auto ones Zwift does).

There was (probably still is) a bug that occurs when screenshots hit 20.

None taken :slight_smile:

There seems to be a camera angle bug, at least when you join a bot. Previously, with about 2 seconds before you needed to start pedalling, the camera would move back and up. Now it remains annoyingly close to the back of your avatar. Also, when you join a bot, instead of appearing on the road, typically a bit behind the pack (which you soon find yourself in), you now start in a field, or in the sky, or in a mountain. Very strange.

Exactly 20, and the required exit shot was 21. I don’t think I’ve ever hit that before though.

I know some I have done more than 20, maybe it’s exactly 20? Weird…