Game freezes and crashes on 4K setting

Hi all, I’ve been using Zwift for a few years now and have recently changed to. 4K monitor. I have an Intel 12th gen CPU and a GTX 1080 graphics card connected by a Display Port cable, all running on Win 11 and have been for last two months without any issues (prior to trying 4K)
Zwift runs fine at 2K but when I change the monitor settings to 4K the game freezes every other km or so and then crashes back to the desktop at between 6 and 10km. I’ve tried riding in Watopia and London in the last couple of days and the results are the same. The monitor is running at 60Hz and other games run at 4K without issues.
Is this just a Zwift problem and has anyone else had a similar experience.
Thanks in advance for any advice/suggestions.

This isn’t normal, and sounds like your graphics card is crapping out. You shouldn’t have any issues with a 1080 but it may be worth checking the power supply is beefy enough to handle the extra load. It ramps up massively between 1440p and 4K.

Also, if you have any overclocks on your GPU and VRAM, back them off a bit (or remove altogether for testing). Stability in other games doesn’t count for Zwift.

Thanks for the reply Dave, I have an 850 watt PSU and nothing is overclocked in my system, it also has 32GB of ram.The next step is to check out the DP cable and try another to see if that works. When it does work it looks great so fingers crossed it can be sorted.

850W should be fine (assuming it’s not poor or faulty - wattage alone doesn’t necessarily guarantee quality), but the game should never just crash like that. See what’s in Event Viewer and Reliability History.

might be an issue with the cable ur using
there’s lots of different types of displayport cables and if it’s a cheap janky one it won’t be able to handle 4K.

p.s. r u running fullscreen or windowed and have u tried both to see if issue only happens with one of them?

A crap or incompatible cable wouldn’t cause the game to crash though.

Will try looking at those to see. Thanks

Will also try your suggestion. Thanks

Finally sorted things out by using a different display port socket on graphics card and changing the cable. Done two longish group rides in Makuri and Watopia without any issues at all in 4K. Thanks to Dave and Ben for your suggestions.