Flickering graphics caused by launcher version or integrated GPU?

Do they now force the new launcher? I still have flickering with it. Still no fix for it?

Correct. Launcher 1.0.50 no longer works, and 1.0.52 still has issues.

It’s a shame they couldn’t fix it after 5 months you first reported.

Closer to 10 months now, December 2020 was Dave’s first report of this issue.

Sorry, didn’t know, just noted the first post datum in this thread.

April (this thread) is when the launcher first started checking itself for updates so I made a new post. :+1:

Original is here: New launcher (1.0.51) causing stutter on Windows systems

2 Likes

There is no way they can’t reproduce and test/debug such a simple problem that is very annoying. Mostly was using my iPad Mini but now I wanted to use my ant+ only power meter and was surprised that the old launcher was not working. Installed the new one and the flickering is back but seams the frequency is not at the level I first experienced. My avg FPS was 94 with ultra settings.

It’s a bit late, especially since using the old launcher as a workaround isn’t possible anymore in the meantime but nevertheless I wanted to thank Dave for sending it over.

I was already afraid that at a given point using an older version would not be possible anymore. (In addition to the fact that the old file was signed with a certificate, assigned to Zwift inc. that is expired in the meantime)

I’d like to add to my previous post: In the meantime a newer Nvidia driver has been released than the one mentioned in my previous post. I updated to it but that didn’t have an effect on this issue. (Which didn’t surprise me since other games or graphics benchmarking software don’t have a similar issue, it is specifically a Zwift thing, but I tried nevertheless)

Also, it seems that at around the 95-100FPS mark the issue starts to get noticeable, but is ‘intermittent’ so not flickering the whole time. But from about 110-120FPS and up the flickering really gets crazy and you really can’t bare to look at it for any extended amount of time.

I hope Zwift support will investigate further and implement a solution.

1 Like

Yup, spot on. My monitor is 95Hz so with vsync turned on I now get the flickering on an intermittent basis at 95fps. With vsync disabled (allowing the frame rate to be the maximum my GPU can produce) the flickering is near constant and makes the game completely unusable for anyone with a high refresh rate display and strong GPU. This was not the case with 1.0.50.

My bigger annoyance is stuttering which occurs at all frame rates, so it’s not like I can just cap my frame rate to avoid the flickering and all is well. Again, this stutter was not present on 1.0.50. New launcher (1.0.51) causing stutter on Windows systems

Unfortunately there is now no way to demonstrate/prove that the old launcher did not have these issues with every other variable unchanged, since it cannot be used any more.

1 Like

Shuji, If that’s the case why did I get drastically different video performance when I switched between old and new launchers? It was very easy to prove the launcher was the direct cause.
Either the engineering team don’t know how to fix it or the don’t care because I refuse to believe this has never been noticed at Zwift HQ.

1 Like

Well, I am having flickering image issues now. Here is a video:

I have a brand new pc laptop G15 Special Edition gaming laptop - image attached of specs.
I view the game on a TV via HDMI cable…which changes to 1920 x 1080 60hz when viewing Zwift with TV.
The laptop is brand new. Bought on Black Friday deal. I think Zwift and my new gaming laptop specs are incompatible.

1 Like

OBS workaround described here will work: New launcher (1.0.51) causing stutter on Windows systems - #49 by Dave_ZPCMR

1 Like

My fix works perfectly…just discovered thru trial and error…
Change laptop to only display on the TV via the hdmi cable. (Turn off the laptop display)
Change settings in Zwift to 4k.
Voila! Super sharp images and no flickering at all!
Just have to use the tv as your pc screen. No big deal.

That’s because your frame rate is now at 60fps; capped by vsync to the refresh rate of your TV. The flickering appears at frame rates approaching 100fps. Your laptop screen is 165Hz (at default Nvidia settings this would equate to a cap of 165fps) and your GPU is pretty strong, so previously you will have been pushing 100fps or more, especially on the 1080p resolution. You should have been using 4K anyway with your hardware.

I would still recommend the OBS trick, it also makes the game run more smoothly and you’ll be able to use your laptop screen as a second screen if desired without risk of the flickering coming back.

2 Likes

I downloaded a Dell GeForce update today and now there is no flickering, I can use both laptop screen and TV at same time. Running in 4K and it is super sharp. I guess the update did the trick.

You probably installed (or activated) GeForce Experience, which has the same effect as OBS in resolving this problem. :+1:

3 Likes

I came across this thread because i experienced flickering with my new ASUS TUF Laptop.
Specs are nearly the same as Lee´s laptop from Post #143 except CPU is I5 and WIN10.

The flickering is now gone after activating VSync… i can live with it now.

The reason i bought the new laptop was because after updating my older Laptop from WINDOWS7 to Windows10 (Zwift no longer running on WIN7 soon) i had this ugly stuttering.

I still have a second system HDD for the old laptop still with WIN7 and an up to date Zwift Installation.
The interesting thing is that in WIN7 (also launcher 1.0.52) the game is running somewhat acceptabe (15-20FPS in the simplier worlds) without stuttering!
The same hardware with a clean WIN10 makes Zwift stuttering… although there´s no real difference in FPS. I´ve switched HDD_WIN7 and SSD_WIN10 back and forth multiple times to verify.
GPU Drivers are up to date on both (WIN7 and WIN10).

Maybe someone more competent than me can find hints where the stuttering comes from as in my case the Windows version makes the difference.

Greeting from Austria!
Wolfgang

It depends on your definition of stuttering, but if it’s the same as mine then the OBS trick mentioned above resolves that too.

PS: Vsync is enabled by default, you shouldn’t have disabled it. :wink:

1 Like

The stuttering on the old laptop/WIN 10 is for instance if i look at the rider from the side he loses a quarter of the crank revolution… the whole picture makes a time skip every few seconds.
The OBS trick didn´t solve it… i´ve already fiddled with setting in OBS.

That’s a different issue then I’m afraid, unrelated to this.