Flickering graphics caused by launcher version or integrated GPU? [SOLVED]

All already been done, up the thread. And submitted to Zwift.


My avatar (and everybody else) flickers horribly. Zwift will eventually crash. I have some success riding in the least populated game world, but only last about 2 minutes in Watopia. How can I get back levels of the code?

This sound like a different issue. What are your PC spec. Did you put your log file in Zwiftalizer.com and looked at the FPS?

1 Like

Premium gaming rig with current gen Raedon card. Zwiftalizer is happy and shows a 175 fps average. No network errors or re-pairings. I was able to ride Richmond and London this weekend, but Watopia has been crashing within minutes since the last update or so. The less avatars the game has to render, the more stable it is.

Edit: I deleted and reinstalled Zwift. During the process, windows decided it wanted different versions of dot net, so that was also installed. I was then able to ride Makuri with no avatar strobing at all.


I’m encountering the issue as well. (The flickering of the rider avatars) Below I will provide further information, hoping it helps with your investigation, and hopefully help in solving the issue for all users that are experiencing this.

Up until recently I never encountered this issue but it appears to be related to the refresh rate your system can run in Zwift (as others already noted). On my old setup I had a very low framerate (we are talking less than 15/s) That is probably the reason that I haven’t noticed it earlier.

I recently upgraded my Zwift setup and since then I encounter the issue. The new setup is capable of running Zwift at a much higher framerate. Hence I’m noticing it since the renewal.

(I tried to insert a link to an example / video in this reply but wasn’t able to) (I can provide it later if needed)

At first I thought it was an issue with my new setup, maybe an error on my end when building the system, so I did troubleshooting a couple of times and several tests. As a result I have lots more recordings than the above one. If it helps, I can provide them on request.

I am on the latest (and standard) launcher and Zwift application version. (1.0.52 for the launcher) (I forgot to take note of the Zwift application version but it is fully up to date, I installed it a few days ago and did a ‘check for updates’ yesterday to be sure)

  1. I am using a dedicated (‘add-on’) graphics card
  2. See further below regarding refresh rates
  3. I don’t have access to the older Zwift launcher so can’t say anything about that. However, there seem to be others in this thread that were able to provide you with the necessary feedback on that. (After testing with the old one and observing the difference in behavior of the application)


  1. OS platform and version number: Windows 10, 64-bit version 21H1, OS build 19043.1165
  2. GPU hardware make & model (if integrated GPU, please note that): Nvidia Geforce GTX 1660 super (from vendor Gigabyte)
  3. GPU firmware version: 90.16.4F.00.C3 (I suspect that is the firmware version… it is mentioned as ‘Video bios version’)
  4. OS driver version for that GPU: (Nvidia 471.68 driver)
  5. Number of monitors (i.e. laptop + 1 external / workstation + 3 monitors, etc): desktop with 1 monitor
  6. Display cable type(s) (i.e. HDMI / Displayport / Thunderbolt 3 / etc): Displayport cable (However I also tested using an HDMI cable and had the same issue, more info below)
  7. Make & model of display(s): MSI MAG274QRF
  8. OS driver version for that display:

Some additional observations / more info. (Some already mentioned by others)

As you can see in the recording, I was getting around 165fps at that time which is the maximum refresh rate the monitor supports and the flickering was visible. (See the OSD of the monitor in the video for resolution and other info)

It seems that only the avatar body and most of the clothing is ‘flickering’ (disappearing and reappearing). The avatar bike stays visible, as well as the surroundings (roads, landscape etc.) I think that the avatar helmets or caps do not flicker.

The shadows of the avatar are flickering as well, together with the avatar itself.

The flickering is also visible on other riders. So not only my own avatar in the game. Additionally, it is also visible when ‘fan viewing’ other riders.

It is visible in different camera views.

It is also visible when the avatar is standing still on the side of the road.

When the framerate is lower, because the visuals get complexer and the system can’t generate this high FPS anymore, the flickering stops.

This isn’t exact but it seems (on my system) that the point at which the flickering is visible or disappears, is around 90-95fps. Above that number, the flickering is visible. Below that, the flickering stops.

I am using a g-sync compatible monitor, maximum 165Hz refresh rate, with displayport cable.

I also tested with a HDMI cable. Using an HDMI cable, at maximum 144Hz and in this mode this monitor does not support g-sync. Using the HDMI cable and without g-sync, I also observed the same flickering at high framerates. As with using displayport, the flickering goes away when the framerate drops.

If I limit the monitor refresh rate to 60Hz it goes away as well. If I leave the monitor to maximum 165Hz but I set a ‘maximum refresh rate’ in the Nvidia control panel, for example a maximum of 80fps, the flickering stops as well.

In summary, it occurs at higher FPS and goes away at lower FPS, regardless of the ‘cause’ for the lower fps (whether that being due to ‘heavy graphics’ elements, or because set in the monitor refresh rate in display settings, or with a specific limit configured in the Nvidia / GPU settings.)

It is using the Nvidia control panel ‘max refresh rate’ setting that I am currently mitigating the issue. Nevertheless, I hope that you will still continue your efforts in finding a real solution (instead of this mitigation) so we can enjoy Zwift in the maximum experience / fps our systems allow for.

Kind regards.


1 Like

I’ll send you the old launcher. The flickering will go away and the experience is much smoother, you should notice this very obviously if you’re using adaptive sync.

But everything you’re seeing and have detailed there is correct and matches what I have outlined in the thread (and previous one).

I spoke too soon. After a few rides, the flickering returned. Additionally, any attempt to enter or spawn in the desert results in an instant crash.

As Gerrie said, crashing is a different problem. I suspect your flickering would go away with the old launcher though.

Dave, can you send me the launcher so I can rule it out. Thanks.

I installed the latest video drivers and so far no crashes or flickering. So apparently one of the zwift updates (Makuri Islands maybe) required the newer drivers.

The flickering I experience is exactly the same, only less frequent. Now that Launcher version 1.0.50 is no longer allowed, it’s back again. Very annoying…
Zwift obviously considers it to be acceptable, as they have done absolutely nothing to correct the problem and now have prevented us from using the only available solution…
Not good enough.

I probably would have never noticed if you hadn’t pointed it out :joy: :sob:

1 Like

Do they now force the new launcher? I still have flickering with it. Still no fix for it?

Correct. Launcher 1.0.50 no longer works, and 1.0.52 still has issues.

It’s a shame they couldn’t fix it after 5 months you first reported.

Closer to 10 months now, December 2020 was Dave’s first report of this issue.

Sorry, didn’t know, just noted the first post datum in this thread.

April (this thread) is when the launcher first started checking itself for updates so I made a new post. :+1:

Original is here: New launcher (1.0.51) causing stutter on Windows systems


There is no way they can’t reproduce and test/debug such a simple problem that is very annoying. Mostly was using my iPad Mini but now I wanted to use my ant+ only power meter and was surprised that the old launcher was not working. Installed the new one and the flickering is back but seams the frequency is not at the level I first experienced. My avg FPS was 94 with ultra settings.