Flickering graphics caused by launcher version or integrated GPU? [SOLVED]

Yes: New launcher (1.0.51) causing stutter on Windows systems - #49 by Dave_ZPCMR

It’s happening now because your frame rates are higher than before.

I’d also recommend removing/undoing all the tweaks and changes you’ve made, because the chances are you’ve made things worse. The problem is the Zwift launcher/installer (or more accurately, some files it installs); and using the workaround above resolves it.

I used the standard Dell Update. Don’t recall the version. Did not use the experience method. And by the way…it went back to flickering again.

The only thing that does eliminate flickering is disabling the laptop screen and only viewing on TV thru HDMI.

I posted the fix. It works.

Thanks - I’ll try the Download | OBS OBS work-around first, since it looks easy to add, and as importantly, easy to remove if it doesn’t work.
If that fails, I may let the GeForce Experience install and “do it’s thing” and see if that works instead. I will also check if the other two Zwift systems we have are using GeForce (we don’t see the problem on them). I’ll get back to you…

1 Like

Follow the steps in my post; so long as OBS is running, the flickering at high frame rates will go away. Not sure why you guys don’t believe me. :wink:


Here are a few examples I recorded ages ago.

Start OBS, flickering goes away: Streamable Video
Close OBS, flickering comes back: Streamable Video

OBS fixed it. Thank you so much for the detailed work in describing this issue, and the details as to how to implement the work-around.
I tested it several ways on my G15 laptop (RTX 3060), with and without OBS running. It definitely has to have OBS running before Zwift runs, and that resolves the flickering issue.
I tried it with 60Hz refresh, and with the crazy 360Hz option on this Dell laptop, and both refresh rates worked. And I have the VSync set to Application 3D adaptive (neither ON nor OFF).

With some test rides in Pace Partner, and alone, it seems I’m getting about 90-120 fps on average - way over 60!

I found that I didn’t need to have OBS in my Startup items; I could simply just run it, minimize it, and then run Zwift. I generally unload the Zwift loader when I’m done with Zwift, because I use the laptop for software development, and need all the power I can get for that.

Dave_ZPCMR - again thanks; an excellent write up on how to work-around this. I hope Zwift can find out a way to eliminate the need for the work-around.



Yeah you don’t need it in your startup folder, but my PC is dedicated for Zwift so I definitely can’t be arsed running it manually every ride. :rofl: So I have it set to run automatically and minimise itself to the system tray, hence those steps to do the same.

PS: You should put Vsync on ‘Use the 3D application setting’ and enable triple buffering, for the best experience in Zwift. This allows the frame rate to fluctuate without hard drops to 50% refresh rate, and without screen tearing at any time.

1 Like

Still the same. Thread is almost a year old, original is well over a year old. Fully demonstrated and steps to reproduce provided.

If you’ve no interest in quality assurance on PC (or have plans to abandon the Windows platform now that you’ve moved to Metal on Apple), please let the users know, so I can stop wasting my time promoting it.


Come on Zwift - it’s not only Dave who’s complaining - it’s all of us!


Hey Zwift Support, when are we getting a fix for this issue!!
This has been happening for far too long now and we shouldn’t have to use OBS as a hack to fix your software issues.


Still waiting, zwift support… Would rather not be running workarounds to your software bugs.

1 Like

Me to. Shame that Zwift had no time yet to fix this error that is clearly their software bug as with the old launcher it was not manifesting.

1 Like

Yeah at least there’s a ‘set and forget’ workaround with OBS, but still annoying that it’s necessary in the first place.


Thanks for keeping this thread alive… indeed this needs to be fixed. The heartache and headache I went through when I got my new Win11 laptop with RTX 3060… thankfully Dave_ZPCMR posted the workaround… but I was ready to return my new laptop to Dell! And I didn’t want to get a new laptop, except Zwift dropped support on my great M4700 Win7 laptop.

1 Like

Bump, still the same coming up 1.5 years later. I can literally give you [again] EXACT STEPS to replicate.

Yeah, but new fonts!

And here also :frowning:

Fixed in version 1.29.1. :grin:

1 Like

Thanks for keeping this one “alive” till it got fixed @Dave_ZPCMR.