FIXED: Trainer Resistance Issues (Mainly on iOS Devices)

I’m a Neo owner too.

I use a tickr and only fire up Zwift on the TV when I’m ready to ride, so I don’t go out of range wearing my HR so don’t think this is the problem.

TBH I don’t want to be a guinea pig for Zwift to fix their problem. All the rides I do are either training or races so I don’t wish to not have it not work properly or fail half way through, so therefore I’m doing all my using my MacBook Pro and ANT+.

This is very frustrating though as I bought an TV 4K purely for using with Zwift to save keep the my Mac out to the cabin.

OK. This is getting silly now and really needs to get fixed. Currently my trust of zwift working properly for a workout is close to zero.

I’m generally confident that if i stop pedaling that erg mode will find a silly high resistance and stick there. Week 11 of a 12 week workout plan is not a good time to be having these issues and I’m incredibly frustrated and rapidly losing confidence in the zwift platform. Please do let us know some next steps (other than unpair cadence sensor).

Apple TV
BLE on Tacx Neo & 4iiii Viiiiva HRM (latest firmware on both)
Zwift game version 1.0.31304
Companion App on iphone 7

2017 Neo
Apple TV 4K
Latest Zwift version
Latest Neo firmware
Sim mode

The latest incident I lost road feel. Resistance simultaneously dropped as well, but I was able to keep riding once I shifted gears. I rode for a while before giving up.

When shutting down everything, the Neo is last. I noticed that the flywheel was still spinning and spinning and spinning. I watched this for a few minutes before unplugging the unit. With the flywheel spinning like that, it would make sense that my resistance dropped (Neo simulating mild downhill ??) and necessitated my dropping a few gears. This is the first time the problem manifested itself this way. Normally, it’s total loss of resistance where regardless of gearing, I’m getting less than 100W.

I don’t know if this is a step in the right direction, but I was able to confirm that Zwift CAN control my kickr. Using Kicker Gen1 (latest firmware) on Apple TV 4k, up to date, running Zwift New York edition, using BLE connections.

What I did: I took the batteries out of my Tickr HRM and RPM cadence meter, turned off my phone, unplugged the Kickr and the Apple TV, and unplugged my fan. After waiting a couple minutes I turned on the Apple TV, launched Zwift and proceeded to the connection screen. I plugged in the Kickr, woke it up and paired it to Zwift. I performed a cold spin down (with success - previously my spin downs had been timing out). I selected a training route (Hilly Loop) in sim mode. Zwift performed flawlessly. In fact I was hating life as I approached the radio tower! At about halfway up the ascent I turned on my fan and Zwift continued to control the Kickr. At no point did I turn on my phone or replace the batteries in the Tickr or RPM. The Apple TV was positioned around 5 or 6 feet from the Kickr.

Yet to do: Follow these same procedures in a group ride. Last week I was pushing 250 watts in 50-13 at 85 rpm up a 15% grade the KOM in the Tour of New York.

Ive had same issues since late summer. Had to drop the Apple TV platform and use my laptop using ANT. Big issue with the BLE since late summer for some reason. No issue since switching too ANT. Also don’t think Zwift is be honest with community

Yep, same here. Same issues as everyone when using BLE on either ipad pro or macbook. Issue is only resolved when using macbook with ANT+ connections.

ITS UNACCEPTABLE THAT ZWIFT HAS NOT ADMITTED TO THIS AND NOT URGING USERS TO SWITCH TO ANT+. Absolutely dissapointing letting paying customers ruin their training sessions.

To date Zwift has always been amazing about these things, but this time you are in danger of seriously damaging your reputation, as Garmin has.


1 Like

Hi Vincent,
today during the race, I experienced an issue wtih dropping cadence and watts along with resistance.

  • Your exact trainer (including the year if applicable) Tacx Flow Smart T2240
  • The device you’re using to run Zwift iPad 6 gen 2018
  • BLE or ANT+ connection? BLE by default
  • Zwift Game version 1.0.31304
  • Trainer Firmware the latest provided by Tacx
  • Sim or ERG mode Sim?
    It is a bit annoying as the race was set to 4 laps and I did not even manage to complete 1 lap…

Dear Zwift, and respectfully, @Jon

This is getting intensely frustrating. Bluetooth connectivity on iOS and tvOS is basic functionality, and should work reliably. For those of us on these platforms, Ant+ is not an option, unless we move to PC or Mac. Not everyone can do that.

The problem has been occurring since late June, and at the end of the first week of November, we are no closer to having a solution. In this time, Zwift have launched two new worlds and fixed numerous bugs and rolled out many other small features, but this major issue still remains at large.

Next week, Zwift raises it’s prices by 87% (for those of us paying in GBP/£). This doesn’t sit comfortably with me.

Many of us can recreate this problem on almost every ride. Some of us who have the technical chops are offering to help debug this with you - please let us!

I love Zwift, I’ve been here 2 years now, and it’s changed how I think about cycling, but it doesn’t feel that Zwift loves me.


I have the new Kickr core updated to the latest firmware using the latest Zwift and getting no resistance

KICKR CORE Firmware v1.0.6 - 31 October 2018
Devise running Zwift IOS Latest update 12
Connection BLE
Zwift game version 1.0.31304

I made a few post earlier in the thread about the core loosing resistance and dropping connection when using the Giant ridesense speed and candence sensor , I reftified this by changing the sensor to a Wahoo candence sensor and this seamed to rectify the drop outs whilst riding , but I still lost connection if I stopped for longer than 3 minutes.

I bought a Wahoo Ant+ key and tried to use this with my ipad pro ,it wold connect to my heart rate,candence sensor and Kicker core but not smart trainer so I did not use it as no support for smart trainer,
I decided to try it again with the Ant+ key and connected my heart rate ,candence and Kicker core to Ant+ and smart trainer to bluetooth, this has now been running connected blue flashing bluthooth light for an hour with no drops after 3 minutes, will try a ride this afternoon when I have time

1 Like

Update #2
Thanks to everyone’s help here we’re working well on the investigation. Will update everyone with more detail as soon as possible.

I’m new to Zwift but today I’ve been having a nightmare with my power dropping out to nothing. Heart rate monitor and cadence sensor carried on working throughout, but speed and power just fell off the scale to nothing. Why does this happen? I did a spin down and then a factory spin down, I also tried turning erg mode off and on.

I have a 2017 Kickr which seems to have all its updates in place and I am running zwift on a mid 2010 MacBook Pro, with an ant+ dongle, hrm is Garmin as is cadence sensor. Internet is BT but all seemed to be working fine. Until random power die offs.

Am I just being thick? It all worked fine on Sunday night, in fact it was really good (today was only my third time using zwift and it was glitchy and rubbish, nothing like Saturday and Sunday. Does it make a difference which course I am on? Sunday was a race in watopia - today was New York) any help/advice gratefully received!

Zwift membership - cancelled. Happy trails, guys & gals.

Hey Laura, the two times you rode before the glitchy ride did you also have your HRM and cadence sensor paired?
Also did you happen to pair your Kickr to Wahoo app at all? If so can you unpair from the Wahoo app/forget your Kickr then only pair to Zwift to see if that helps?

Hey all, some good news. After identifying what was common across most of the reports of this issue (using this thread!) we finally today got it to reproduce 100% of the time. Once we had that, we tracked the issue down in about 15 minutes.

It appears that if you let a device go out of range (ie, walk away with your heart rate strap), or let your cadence device go to sleep (ie, don’t pedal for a while), our re-scanning code that starts searching for the missing devices can sometimes conflict with sending commands to the trainer from that point onwards. This would be why it was impossible for us to consistently reproduce, and also why 100,000+ other users were Zwifting happily over bluetooth and reporting no issues.

We’re putting together an update now, and will try to get it submitted to apple in the next 48 hours. From there it can take up to a week to get approved by Apple - so in the meantime, the workaround would be to pair up your devices only once you’re ready to ride. Sorry for the inconvenience, but it was really due to the posts here that we were finally able to track such a very specific bug down.

It could be possible the bug could also happen ‘organically’ mid-ride if a device drops out for a long enough time, and that case too is probably handled with this fix although we’ve not fully verified that case yet.

(NOTE, another case that could cause sim/erg not to work is by performing a spindown, but cancelling it without making it through to success. This too will be fixed in the update).


Thank you for directly chiming in w/an update. :+1:

Thanks for the update @Jon I think mine is must be due to it rescanning organically as I only start Zwift on the tv once I’m fully ready and on the bike. Hopefully the fix will cure this too.

Thanks for the update and that makes a bit of sense. I originally thought it was just the Bluetooth combo speed / cadence sensor, however today when I was riding, I got interrupted and left it idle and walked away (wearing my BT HRM) and when I returned the connection dropped out.

Hopefully the fix is approved quickly and we all live happily ever after

Hi Jon
Thanks for the update. Your summary of the root cause is consistent with what I’ve been reporting to Zwift for months, and speculating as a theory. Can you confirm whether this is a regression, as this seems to be something that changed late June, or around the time of Innsbruck?

I am reluctant to criticise - I work in a similar domain - so I understand how the process of triage works, and the necessity of reproducibility of issues, but it is disappointing for it to take this long to get to fix. Despite my repeated offers to help, I was met with silence. Providing a debug build to a tiny set of trusted savvy customers (under NDA) could have solved this months back. I urge you to consider this approach in future.

Looking forward to getting Zwift back working properly again.


Hi Kevin, indeed it was a regression around the time of Innsbruck. The issue at play here is really our companies growth. I can no longer read forums as often as I like (nor can the rest of the developers), so some information doesn’t end up getting to the right people as quickly as it used to. In this case, you tagged me and it was the first time I’d personally seen this treasure trove of info. It is embarrassing (and something we will address), but true. This thread really was the final key we needed to unlock the mystery of this seemingly impossible to reproduce bug.

Now we will spend the next day or two vetting the fix and seeing if it addresses the less clear cut cases that some Zwifters in this thread came across.


@Jon thanks for the heads up on the workaround. We are are however consistently getting no ‘ERG’ when joining a group workout event directly from a freeride (warmup) on TvOS. This can be remedied by a workaround, ‘ensuring you exit zwift and restart zwift and join the workout directly in pen without turning the pedals’. Not sure if this issue is related/same.