FIXED (1/17/2020): Saris Trainers Are Lacking Resistance In ERG Mode

Has this issue been solved yet? I bought my husband a tacx Neo 2T for Xmas. The erg mode didn’t function in Zwift which is the only platform he uses for training. I exchanged the machine for a wahoo Kickr and had the same issue. It is not us. We were able to get erg mode functioning in sufferfest, the resistance changed well and followed an erg workout program. Tried in Zwift again and the power was all over the place and resistance didn’t change on the Kickr. We are very familiar with the wahoo, it works well on our first generation machine, the setup is the same, just a new machine. Wahoo customer support say it’s a known problem with Zwift. Here most people see it’s a problem, so why hasn’t it been fixed yet? ZWIFT PLEASE HELP!

We use ant+ on windows. We have the same problem. Is there a work around?

Is there a workaround for ant+, windows, kickr 18, or Neo 2T? Had the same problem on both machines

Hi Zwift Support,

I too am new to using Zwift and I’m also experiencing zero resistance with my Tacx Flux S. I’m running a Google Pixel 3 Android screen mirroring via Chromecast to my TV.

On the app I can be pedaling like a mad man and still only showing 3mph on what looks like a hill and not feeling resistance at all.

How do I find out if I am in ERG mode or whatever?

Same here; the Tacx Flux S is connecting with Tacx Utility and Tacx program, it is up to date and possible to calibrate.

Back to Zwift; no calibration possible, not possible to put ERG mode on (while training) and speed/wattage has constant fluctuations.

Firmware is new (bought it this november) en software all up to date.

I’be bought a ANT+ Dongle (good/expensive one, from Tacx itself) so i’m going to try this afternoon. Hope for the best…

Nb: I used Zwift already for 2 months without problems. From last monday these problems had occure out of nothing.

2 Likes

I am having the exact same issue. About a week ago out of the blue my Tax Flux S started having myriad of issues with Zwift. Sometimes when I open Zwift, it can take 10-15 minutes just for it to be found (Using Mojave on Mac). I have verified also that firmware is updated, everything is correct on the Tacx Utility App.

I have been trying to use Workouts in Zwift and it doesn’t even recognize that I’m doing a workout - constantly shows I’m on Step 2 and I did a 28 step Workout. The ERG mode does not work AT ALL. It’s incredibly frustrating. I do not want to have to use an ANT+ Dongle, that is ridiculous.

Zwift - what’s the fix here?

Another Tacx flux S user with same issues (on mac), Tacx firmware is up to date, I calibrate the trainer frequently and yet as of 11/1/19 whilst following training plans there has been fluctuations in resistance using ERG mode, sat at ~330w and there was large drops in resistance, displaying in the range of 200w-250w whilst my legs start spinning like billy whizz - a bit frustrating knowing it’s a subscription service, hoping for a fix fairly soon.

Exactly the same today on Wattbike Atom. Large wattage fluctuations up and down during workout in ERG mode. Has never happened before.

@Kyle_Rogerson @Adam_Benson_Moxie @Allard_Lourens @Cameron_Webb

Hello all, our team has not been able to reproduce this issue specific to the Tacx Flux Trainers, and we’ll need some more information on your setup. If you have not already done so, please contact us at support@zwift.com and let us know any details of when this started to happen, along with your Zwifting device, Trainer brand and model, firmware version, and how you are pairing with Zwift (ANT+, native bluetooth, or bluetooth via Zwift Companion).

I’m having the same problems on my tacx flux s , using blue tooth , firmware is upto date and so is the zwift app . I can do any thing upto 600 watts in Erg mode but then if I try to do a 1000 watt sprint the trainer doesn’t apply resistance

@Josie.L: Can we change the topic of this thread, it hasn’t been about Saris trainers for some time.