Fix for no resistance on Elite Direto


(Steven Chavez) #1

After a few days of frustrating use of my new Elite Direto and Zwift, I finally figured out what the to do.

If you have had:

No resistance on flat lands, but a change in resistance in climbs

No resistance at all

Calibration stuck at 175ish

Here is what I found worked (for me) MacBook 2011 ANT+ dongle

Download the Elite trainer app from the their website on your desktop.

Connect and try to calibrate. 

When I did this the first time, I entered 2133. On the screen it showed, 173, WHAT!?! 

I couldn’t get the trainer to spin fast enough to calibrate. 

So take what ever 2xxx number you want to be the final number and TIMES that by 12.1. So it will be in the 25,xxx range. This will put the on-screen circumference  to the appropriate number that you desire. 

THIS IS ON THE DESKTOP APP, if if works on the iOS app please confirm and reply, I didn’t try it, my trainer is finally working and I don’t want to mess it up! :slight_smile:

RIDE ON!!


(Joe Daknis) #2

The Elite iPhone app worked perfectly well for me from day 1.
No weird fudging of wheel circumference needed. The only caveat seems to be: don’t attempt to calibrate the trainer via iPhone/Bluetooth while it’s already paired with Zwift via ANT+ on your PC! Doing so seems to cause Bluetooth to override the ANT+ Control signal - so you lose hill simulation etc. To fix this, all you need to do is turn the trainer off & on and re-pair the ANT+ control w/ Zwift.